Version 0.7.0.
Verify that license is valid SPDX.
This commit is contained in:
parent
917715cb00
commit
adadbc0b55
45
python-pyproject-metadata-test.patch
Normal file
45
python-pyproject-metadata-test.patch
Normal file
@ -0,0 +1,45 @@
|
||||
--- python-pyproject-metadata-0.7.0/tests/test_standard_metadata.py.orig 2023-01-17 19:01:58.000000000 -0700
|
||||
+++ python-pyproject-metadata-0.7.0/tests/test_standard_metadata.py 2023-01-17 21:38:11.172958197 -0700
|
||||
@@ -225,20 +225,6 @@ from .conftest import cd_package
|
||||
'''),
|
||||
('Field `project.dependencies` contains item with invalid type, expecting a string (got `99`)'),
|
||||
),
|
||||
- (
|
||||
- textwrap.dedent('''
|
||||
- [project]
|
||||
- name = 'test'
|
||||
- dependencies = [
|
||||
- 'definitely not a valid PEP 508 requirement!',
|
||||
- ]
|
||||
- '''),
|
||||
- (
|
||||
- 'Field `project.dependencies` contains an invalid PEP 508 requirement '
|
||||
- 'string `definitely not a valid PEP 508 requirement!` '
|
||||
- '(`Expected end or semicolon (after name and no valid version specifier)'
|
||||
- ),
|
||||
- ),
|
||||
# optional-dependencies
|
||||
(
|
||||
textwrap.dedent('''
|
||||
@@ -277,21 +263,6 @@ from .conftest import cd_package
|
||||
'expecting a PEP 508 requirement string (got `True`)'
|
||||
),
|
||||
),
|
||||
- (
|
||||
- textwrap.dedent('''
|
||||
- [project]
|
||||
- name = 'test'
|
||||
- [project.optional-dependencies]
|
||||
- test = [
|
||||
- 'definitely not a valid PEP 508 requirement!',
|
||||
- ]
|
||||
- '''),
|
||||
- (
|
||||
- 'Field `project.optional-dependencies.test` contains an invalid '
|
||||
- 'PEP 508 requirement string `definitely not a valid PEP 508 requirement!` '
|
||||
- '(`Expected end or semicolon (after name and no valid version specifier)'
|
||||
- ),
|
||||
- ),
|
||||
# requires-python
|
||||
(
|
||||
textwrap.dedent('''
|
@ -4,13 +4,15 @@
|
||||
%bcond_with doc
|
||||
|
||||
Name: python-pyproject-metadata
|
||||
Version: 0.6.1
|
||||
Version: 0.7.0
|
||||
Release: 1%{?dist}
|
||||
Summary: PEP 621 metadata parsing
|
||||
|
||||
License: MIT
|
||||
URL: https://github.com/FFY00/python-pyproject-metadata
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
# Remove two tests that throw different errors in python 3.11 and 3.12
|
||||
Patch0: %{name}-test.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -20,7 +22,6 @@ BuildRequires: %{py3_dist packaging}
|
||||
BuildRequires: %{py3_dist pip}
|
||||
BuildRequires: %{py3_dist pytest}
|
||||
BuildRequires: %{py3_dist setuptools}
|
||||
BuildRequires: %{py3_dist tomli}
|
||||
BuildRequires: %{py3_dist wheel}
|
||||
|
||||
%if %{with doc}
|
||||
@ -61,7 +62,7 @@ Documentation for python3-pyproject-metadata.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%pyproject_wheel
|
||||
@ -92,5 +93,8 @@ rm -rf html/{.buildinfo,.doctrees}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jan 17 2023 Jerry James <loganjerry@gmail.com> - 0.7.0-1
|
||||
- Version 0.7.0
|
||||
|
||||
* Tue Jul 26 2022 Jerry James <loganjerry@gmail.com> - 0.6.1-1
|
||||
- Initial RPM, obsoleting python-pep621
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (python-pyproject-metadata-0.6.1.tar.gz) = 4af84f9534a5c71e192e1355e1e99f99e82b97d01411c011ed2f1dff579a7420a0f5d982eea5a032de8549c14191b64334c8e2aeea22fe767837e662e8d8b588
|
||||
SHA512 (python-pyproject-metadata-0.7.0.tar.gz) = aef8a340cc2b581b6bae763c1e7d6a800c7a1b6c9cf08b722e21b8e0a23fb753ec602db21710935aa9245f3044ea3b6a8e8dc52eea88f608d2eab0ae29871c79
|
||||
|
Loading…
Reference in New Issue
Block a user