Replace whole repo with latest content from branch stream-2.2.0-rhel-8.8.0
Content corresponds with RHEL dist-git commit 9a17717
This commit is contained in:
parent
9b82446169
commit
15bc468c36
@ -1 +0,0 @@
|
|||||||
1
|
|
8
.gitignore
vendored
8
.gitignore
vendored
@ -1,2 +1,8 @@
|
|||||||
SOURCES/Pygments-2.2.0.tar.gz
|
Pygments-1.3.1.tar.gz
|
||||||
|
/Pygments-1.4.tar.gz
|
||||||
|
/Pygments-1.6.tar.gz
|
||||||
|
/Pygments-2.0.2.tar.gz
|
||||||
|
/fix-shell-injection-in-font-manager.patch
|
||||||
|
/Pygments-2.1.3.tar.gz
|
||||||
/Pygments-2.2.0.tar.gz
|
/Pygments-2.2.0.tar.gz
|
||||||
|
/import-directive.patch
|
||||||
|
@ -1,6 +0,0 @@
|
|||||||
--- !Policy
|
|
||||||
product_versions:
|
|
||||||
- rhel-9
|
|
||||||
decision_context: osci_compose_gate
|
|
||||||
rules:
|
|
||||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
|
@ -1,26 +0,0 @@
|
|||||||
#! /bin/bash -ex
|
|
||||||
|
|
||||||
# You can set the version as an argument to the script,
|
|
||||||
# default is taken from the specfile
|
|
||||||
if [ "$1" = "" ]; then
|
|
||||||
VERSION=$(
|
|
||||||
rpm -q --qf "%{VERSION}\n" --specfile python-pygments.spec | head -n1
|
|
||||||
)
|
|
||||||
else
|
|
||||||
VERSION=$1
|
|
||||||
fi
|
|
||||||
|
|
||||||
SRCURL=https://files.pythonhosted.org/packages/source/P/Pygments/Pygments-$VERSION.tar.gz
|
|
||||||
BADFILE=Pygments-$VERSION/tests/examplefiles/Intro.java
|
|
||||||
OUT=Pygments-$VERSION-clean.tar.xz
|
|
||||||
|
|
||||||
curl -L $SRCURL |
|
|
||||||
gunzip |
|
|
||||||
tar --delete $BADFILE --delete $BADFILE.output |
|
|
||||||
xz > $OUT
|
|
||||||
|
|
||||||
if tar tJf $OUT | grep 'Intro.java'; then
|
|
||||||
>&2 echo "Intro.java left in!"
|
|
||||||
mv $OUT $OUT.bad
|
|
||||||
exit 1
|
|
||||||
fi
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -ur Pygments-2.2.0/pygments/sphinxext.py Pygments-2.2.0.patch/pygments/sphinxext.py
|
|
||||||
--- Pygments-2.2.0/pygments/sphinxext.py 2017-01-22 16:01:32.000000000 -0500
|
|
||||||
+++ Pygments-2.2.0.patch/pygments/sphinxext.py 2018-03-19 12:57:52.099927570 -0400
|
|
||||||
@@ -16,7 +16,7 @@
|
|
||||||
|
|
||||||
from docutils import nodes
|
|
||||||
from docutils.statemachine import ViewList
|
|
||||||
-from sphinx.util.compat import Directive
|
|
||||||
+from docutils.parsers.rst import Directive
|
|
||||||
from sphinx.util.nodes import nested_parse_with_titles
|
|
||||||
|
|
||||||
|
|
1
sources
1
sources
@ -1 +1,2 @@
|
|||||||
SHA512 (Pygments-2.2.0.tar.gz) = cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29
|
SHA512 (Pygments-2.2.0.tar.gz) = cc0a4f73e19fa6cbf46314de2e809460c807c631e39ba05cbe5edb5f40db1a687aafcd9715585a0ed45f791710eb6038305e273f282f8682df76f30e63710b29
|
||||||
|
SHA512 (import-directive.patch) = a0ee6528a0a4ceba43c271bee25605f09729765c0cfbda73e70db4df107281bc0f59dc204796ef0cdb1369f156c44b3cfd103d7c6512dc38bd288a84b452e564
|
||||||
|
@ -1,5 +0,0 @@
|
|||||||
framework: shell
|
|
||||||
require:
|
|
||||||
- python3-pygments
|
|
||||||
/version:
|
|
||||||
test: pygmentize -V
|
|
Loading…
Reference in New Issue
Block a user