python-pygit2/python-pygit2-cffiver.patch
Nils Philippsen 26717c853b Fix building with patched cffi on Fedora 39
Signed-off-by: Nils Philippsen <nils@redhat.com>
2023-11-11 00:18:07 +01:00

32 lines
1.3 KiB
Diff

diff -up pygit2-1.13.2/docs/install.rst.cffiver pygit2-1.13.2/docs/install.rst
--- pygit2-1.13.2/docs/install.rst.cffiver 2023-10-30 09:50:04.000000000 +0100
+++ pygit2-1.13.2/docs/install.rst 2023-11-11 00:01:15.551991748 +0100
@@ -55,7 +55,7 @@ Supported versions of Python:
Python requirements (these are specified in ``setup.py``):
-- cffi 1.16.0 or later
+- cffi 1.16.0 or later (or Fedora package >= 1.15.1-5)
Libgit2 **v1.7.1+**; binary wheels already include libgit2, so you only need to
worry about this if you install the source package.
diff -up pygit2-1.13.2/requirements.txt.cffiver pygit2-1.13.2/requirements.txt
--- pygit2-1.13.2/requirements.txt.cffiver 2023-10-30 09:50:04.000000000 +0100
+++ pygit2-1.13.2/requirements.txt 2023-11-10 23:58:49.756179131 +0100
@@ -1,2 +1,2 @@
-cffi>=1.16.0
+cffi>=1.9.1
setuptools ; python_version >= "3.12"
diff -up pygit2-1.13.2/setup.py.cffiver pygit2-1.13.2/setup.py
--- pygit2-1.13.2/setup.py.cffiver 2023-10-30 09:50:04.000000000 +0100
+++ pygit2-1.13.2/setup.py 2023-11-10 23:59:47.350500138 +0100
@@ -153,7 +153,7 @@ setup(
ext_modules=ext_modules,
# Requirements
python_requires='>=3.8',
- setup_requires=['cffi>=1.16.0'],
+ setup_requires=['cffi>=1.9.1'],
install_requires=install_requires,
# URLs
url='https://github.com/libgit2/pygit2',