Disable one more failing test that tries to do network access

This commit is contained in:
Pete Walter 2017-04-27 14:57:56 +01:00
parent 3f5ea63b18
commit 724078a63c
2 changed files with 53 additions and 6 deletions

View File

@ -1,4 +1,4 @@
From f1f5d489da6c0a710563d517b11c116ea41d90ec Mon Sep 17 00:00:00 2001 From a36d3bebba08471caafe3e976a74afd040e90480 Mon Sep 17 00:00:00 2001
From: Mathieu Bridon <bochecha@daitauha.fr> From: Mathieu Bridon <bochecha@daitauha.fr>
Date: Wed, 21 Jan 2015 09:33:46 +0100 Date: Wed, 21 Jan 2015 09:33:46 +0100
Subject: [PATCH] Remove remote-calling unit tests Subject: [PATCH] Remove remote-calling unit tests
@ -8,10 +8,11 @@ the Internet.
--- ---
test/test_credentials.py | 21 --------------------- test/test_credentials.py | 21 ---------------------
test/test_repository.py | 7 ------- test/test_repository.py | 7 -------
2 files changed, 28 deletions(-) test/test_submodule.py | 28 ----------------------------
3 files changed, 56 deletions(-)
diff --git a/test/test_credentials.py b/test/test_credentials.py diff --git a/test/test_credentials.py b/test/test_credentials.py
index 92482d9..36263c0 100644 index ff014c6..019f420 100644
--- a/test/test_credentials.py --- a/test/test_credentials.py
+++ b/test/test_credentials.py +++ b/test/test_credentials.py
@@ -81,26 +81,5 @@ class CredentialCallback(utils.RepoTestCase): @@ -81,26 +81,5 @@ class CredentialCallback(utils.RepoTestCase):
@ -42,10 +43,10 @@ index 92482d9..36263c0 100644
if __name__ == '__main__': if __name__ == '__main__':
unittest.main() unittest.main()
diff --git a/test/test_repository.py b/test/test_repository.py diff --git a/test/test_repository.py b/test/test_repository.py
index 5590ea2..a2f16ca 100644 index 0969fc0..033a1de 100644
--- a/test/test_repository.py --- a/test/test_repository.py
+++ b/test/test_repository.py +++ b/test/test_repository.py
@@ -527,13 +527,6 @@ class CloneRepositoryTest(utils.NoRepoTestCase): @@ -551,13 +551,6 @@ class CloneRepositoryTest(utils.NoRepoTestCase):
self.assertTrue('refs/remotes/custom_remote/master' in repo.listall_references()) self.assertTrue('refs/remotes/custom_remote/master' in repo.listall_references())
self.assertIsNotNone(repo.remotes["custom_remote"]) self.assertIsNotNone(repo.remotes["custom_remote"])
@ -59,6 +60,51 @@ index 5590ea2..a2f16ca 100644
def test_clone_with_checkout_branch(self): def test_clone_with_checkout_branch(self):
# create a test case which isolates the remote # create a test case which isolates the remote
test_repo = clone_repository('./test/data/testrepo.git', test_repo = clone_repository('./test/data/testrepo.git',
-- diff --git a/test/test_submodule.py b/test/test_submodule.py
2.9.0 index f123b8b..a42736a 100644
--- a/test/test_submodule.py
+++ b/test/test_submodule.py
@@ -53,14 +53,6 @@ class SubmoduleTest(utils.SubmoduleRepoTestCase):
self.assertEqual(len(submodules), 1)
self.assertEqual(submodules[0], SUBM_PATH)
- def test_submodule_open(self):
- s = self.repo.lookup_submodule(SUBM_PATH)
- self.repo.init_submodules()
- self.repo.update_submodules()
- r = s.open()
- self.assertIsNotNone(r)
- self.assertEqual(str(r.head.target), SUBM_HEAD_SHA)
-
def test_name(self):
s = self.repo.lookup_submodule(SUBM_PATH)
self.assertEqual(SUBM_NAME, s.name)
@@ -73,25 +65,5 @@ class SubmoduleTest(utils.SubmoduleRepoTestCase):
s = self.repo.lookup_submodule(SUBM_PATH)
self.assertEqual(SUBM_URL, s.url)
- def test_init_and_update(self):
- subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
- self.assertFalse(os.path.exists(subrepo_file_path))
- self.repo.init_submodules()
- self.repo.update_submodules()
- self.assertTrue(os.path.exists(subrepo_file_path))
-
- def test_specified_update(self):
- subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
- self.assertFalse(os.path.exists(subrepo_file_path))
- self.repo.init_submodules(submodules=['submodule'])
- self.repo.update_submodules(submodules=['submodule'])
- self.assertTrue(os.path.exists(subrepo_file_path))
-
- def test_oneshot_update(self):
- subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
- self.assertFalse(os.path.exists(subrepo_file_path))
- self.repo.update_submodules(init=True)
- self.assertTrue(os.path.exists(subrepo_file_path))
-
if __name__ == '__main__':
unittest.main()
--
2.12.2

View File

@ -128,6 +128,7 @@ find %{buildroot} -name '*.so' -exec chmod 755 {} ';'
%changelog %changelog
* Thu Apr 27 2017 Pete Walter <pwalter@fedoraproject.org> - 0.25.1-1 * Thu Apr 27 2017 Pete Walter <pwalter@fedoraproject.org> - 0.25.1-1
- Update to 0.25.1 - Update to 0.25.1
- Disable one more failing test that tries to do network access
* Mon Apr 10 2017 Pete Walter <pwalter@fedoraproject.org> - 0.25.0-3 * Mon Apr 10 2017 Pete Walter <pwalter@fedoraproject.org> - 0.25.0-3
- Trivial spec file fixes - Trivial spec file fixes