Update to 0.26.2
This commit is contained in:
parent
271f11d173
commit
4500c3b340
1
.gitignore
vendored
1
.gitignore
vendored
@ -16,3 +16,4 @@
|
||||
/pygit2-0.25.1.tar.gz
|
||||
/pygit2-0.26.0.tar.gz
|
||||
/pygit2-0.26.1.tar.gz
|
||||
/pygit2-0.26.2.tar.gz
|
||||
|
@ -1,110 +0,0 @@
|
||||
From a36d3bebba08471caafe3e976a74afd040e90480 Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Bridon <bochecha@daitauha.fr>
|
||||
Date: Wed, 21 Jan 2015 09:33:46 +0100
|
||||
Subject: [PATCH] Remove remote-calling unit tests
|
||||
|
||||
These can only fail when building in Koji, as the builder can't access
|
||||
the Internet.
|
||||
---
|
||||
test/test_credentials.py | 21 ---------------------
|
||||
test/test_repository.py | 7 -------
|
||||
test/test_submodule.py | 28 ----------------------------
|
||||
3 files changed, 56 deletions(-)
|
||||
|
||||
diff --git a/test/test_credentials.py b/test/test_credentials.py
|
||||
index ff014c6..019f420 100644
|
||||
--- a/test/test_credentials.py
|
||||
+++ b/test/test_credentials.py
|
||||
@@ -81,26 +81,5 @@ class CredentialCallback(utils.RepoTestCase):
|
||||
|
||||
self.assertRaises(Exception, lambda: remote.fetch(callbacks=MyCallbacks()))
|
||||
|
||||
- def test_bad_cred_type(self):
|
||||
- class MyCallbacks(pygit2.RemoteCallbacks):
|
||||
- @staticmethod
|
||||
- def credentials(url, username, allowed):
|
||||
- self.assertTrue(allowed & GIT_CREDTYPE_USERPASS_PLAINTEXT)
|
||||
- return Keypair("git", "foo.pub", "foo", "sekkrit")
|
||||
-
|
||||
- url = "https://github.com/github/github"
|
||||
- remote = self.repo.create_remote("github", url)
|
||||
- self.assertRaises(TypeError, lambda: remote.fetch(callbacks=MyCallbacks()))
|
||||
-
|
||||
-class CallableCredentialTest(utils.RepoTestCase):
|
||||
-
|
||||
- def test_user_pass(self):
|
||||
- credentials = UserPass("libgit2", "libgit2")
|
||||
- callbacks = pygit2.RemoteCallbacks(credentials=credentials)
|
||||
-
|
||||
- url = "https://bitbucket.org/libgit2/testgitrepository.git"
|
||||
- remote = self.repo.create_remote("bb", url)
|
||||
- remote.fetch(callbacks=callbacks)
|
||||
-
|
||||
if __name__ == '__main__':
|
||||
unittest.main()
|
||||
diff --git a/test/test_repository.py b/test/test_repository.py
|
||||
index 0969fc0..033a1de 100644
|
||||
--- a/test/test_repository.py
|
||||
+++ b/test/test_repository.py
|
||||
@@ -551,13 +551,6 @@ class CloneRepositoryTest(utils.NoRepoTestCase):
|
||||
self.assertTrue('refs/remotes/custom_remote/master' in repo.listall_references())
|
||||
self.assertIsNotNone(repo.remotes["custom_remote"])
|
||||
|
||||
- def test_clone_with_credentials(self):
|
||||
- repo = clone_repository(
|
||||
- "https://bitbucket.org/libgit2/testgitrepository.git",
|
||||
- self._temp_dir, callbacks=pygit2.RemoteCallbacks(credentials=pygit2.UserPass("libgit2", "libgit2")))
|
||||
-
|
||||
- self.assertFalse(repo.is_empty)
|
||||
-
|
||||
def test_clone_with_checkout_branch(self):
|
||||
# create a test case which isolates the remote
|
||||
test_repo = clone_repository('./test/data/testrepo.git',
|
||||
diff --git a/test/test_submodule.py b/test/test_submodule.py
|
||||
index f123b8b..a42736a 100644
|
||||
--- a/test/test_submodule.py
|
||||
+++ b/test/test_submodule.py
|
||||
@@ -53,14 +53,6 @@ class SubmoduleTest(utils.SubmoduleRepoTestCase):
|
||||
self.assertEqual(len(submodules), 1)
|
||||
self.assertEqual(submodules[0], SUBM_PATH)
|
||||
|
||||
- def test_submodule_open(self):
|
||||
- s = self.repo.lookup_submodule(SUBM_PATH)
|
||||
- self.repo.init_submodules()
|
||||
- self.repo.update_submodules()
|
||||
- r = s.open()
|
||||
- self.assertIsNotNone(r)
|
||||
- self.assertEqual(str(r.head.target), SUBM_HEAD_SHA)
|
||||
-
|
||||
def test_name(self):
|
||||
s = self.repo.lookup_submodule(SUBM_PATH)
|
||||
self.assertEqual(SUBM_NAME, s.name)
|
||||
@@ -73,25 +65,5 @@ class SubmoduleTest(utils.SubmoduleRepoTestCase):
|
||||
s = self.repo.lookup_submodule(SUBM_PATH)
|
||||
self.assertEqual(SUBM_URL, s.url)
|
||||
|
||||
- def test_init_and_update(self):
|
||||
- subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
|
||||
- self.assertFalse(os.path.exists(subrepo_file_path))
|
||||
- self.repo.init_submodules()
|
||||
- self.repo.update_submodules()
|
||||
- self.assertTrue(os.path.exists(subrepo_file_path))
|
||||
-
|
||||
- def test_specified_update(self):
|
||||
- subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
|
||||
- self.assertFalse(os.path.exists(subrepo_file_path))
|
||||
- self.repo.init_submodules(submodules=['submodule'])
|
||||
- self.repo.update_submodules(submodules=['submodule'])
|
||||
- self.assertTrue(os.path.exists(subrepo_file_path))
|
||||
-
|
||||
- def test_oneshot_update(self):
|
||||
- subrepo_file_path = os.path.join(self.repo_path, 'submodule', 'setup.py')
|
||||
- self.assertFalse(os.path.exists(subrepo_file_path))
|
||||
- self.repo.update_submodules(init=True)
|
||||
- self.assertTrue(os.path.exists(subrepo_file_path))
|
||||
-
|
||||
if __name__ == '__main__':
|
||||
unittest.main()
|
||||
--
|
||||
2.12.2
|
||||
|
@ -5,16 +5,14 @@
|
||||
%global pkgname pygit2
|
||||
|
||||
Name: python-%{pkgname}
|
||||
Version: 0.26.1
|
||||
Release: 3%{?dist}
|
||||
Version: 0.26.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Python bindings for libgit2
|
||||
|
||||
License: GPLv2 with linking exception
|
||||
URL: http://www.pygit2.org
|
||||
Source0: https://github.com/libgit2/%{pkgname}/archive/v%{version}/%{pkgname}-%{version}.tar.gz
|
||||
|
||||
Patch0: 0001-Remove-remote-calling-unit-tests.patch
|
||||
|
||||
BuildRequires: libgit2-devel
|
||||
BuildRequires: openssl-devel
|
||||
|
||||
@ -126,6 +124,9 @@ find %{buildroot} -name '*.so' -exec chmod 755 {} ';'
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 01 2017 Pete Walter <pwalter@fedoraproject.org> - 0.26.2-1
|
||||
- Update to 0.26.2
|
||||
|
||||
* Mon Nov 20 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.26.1-3
|
||||
- Fixup python3 conditionals
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pygit2-0.26.1.tar.gz) = 6935ca2008109ddb8ae6568420499656625bfed12430abe1e513c5a8d34c9d4653103679a29ed91fbfe9bb4dc76648175bfd97ec4e7b143a0e0c24899f98555e
|
||||
SHA512 (pygit2-0.26.2.tar.gz) = c77a29ffa71cb4ac9ffcd5f890b810c4b4dc93515fc8ba7043975bf4d5318bce2ad5aeae677c93d674d313a3ecce4c0a332b0773337a63909011fa9995e08743
|
||||
|
Loading…
Reference in New Issue
Block a user