Update to 1.14.0 (rhbz#2260506)
This commit is contained in:
parent
1f3ba93c23
commit
11976244b0
1
.gitignore
vendored
1
.gitignore
vendored
@ -43,3 +43,4 @@
|
|||||||
/pygit2-1.13.0.tar.gz
|
/pygit2-1.13.0.tar.gz
|
||||||
/pygit2-1.13.2.tar.gz
|
/pygit2-1.13.2.tar.gz
|
||||||
/pygit2-1.13.3.tar.gz
|
/pygit2-1.13.3.tar.gz
|
||||||
|
/pygit2-1.14.0.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up pygit2-1.13.2/docs/install.rst.cffiver pygit2-1.13.2/docs/install.rst
|
diff -up pygit2-1.14.0/docs/install.rst.cffiver pygit2-1.14.0/docs/install.rst
|
||||||
--- pygit2-1.13.2/docs/install.rst.cffiver 2023-10-30 09:50:04.000000000 +0100
|
--- pygit2-1.14.0/docs/install.rst.cffiver 2024-01-26 11:05:11.000000000 +0000
|
||||||
+++ pygit2-1.13.2/docs/install.rst 2023-11-11 00:01:15.551991748 +0100
|
+++ pygit2-1.14.0/docs/install.rst 2024-02-08 13:09:35.537097921 +0000
|
||||||
@@ -55,7 +55,7 @@ Supported versions of Python:
|
@@ -55,7 +55,7 @@ Supported versions of Python:
|
||||||
|
|
||||||
Python requirements (these are specified in ``setup.py``):
|
Python requirements (these are specified in ``setup.py``):
|
||||||
@ -10,20 +10,20 @@ diff -up pygit2-1.13.2/docs/install.rst.cffiver pygit2-1.13.2/docs/install.rst
|
|||||||
|
|
||||||
Libgit2 **v1.7.1+**; binary wheels already include libgit2, so you only need to
|
Libgit2 **v1.7.1+**; binary wheels already include libgit2, so you only need to
|
||||||
worry about this if you install the source package.
|
worry about this if you install the source package.
|
||||||
diff -up pygit2-1.13.2/requirements.txt.cffiver pygit2-1.13.2/requirements.txt
|
diff -up pygit2-1.14.0/requirements.txt.cffiver pygit2-1.14.0/requirements.txt
|
||||||
--- pygit2-1.13.2/requirements.txt.cffiver 2023-10-30 09:50:04.000000000 +0100
|
--- pygit2-1.14.0/requirements.txt.cffiver 2024-01-26 11:05:11.000000000 +0000
|
||||||
+++ pygit2-1.13.2/requirements.txt 2023-11-10 23:58:49.756179131 +0100
|
+++ pygit2-1.14.0/requirements.txt 2024-02-08 13:09:35.538097421 +0000
|
||||||
@@ -1,2 +1,2 @@
|
@@ -1,2 +1,2 @@
|
||||||
-cffi>=1.16.0
|
-cffi>=1.16.0
|
||||||
+cffi>=1.9.1
|
+cffi>=1.9.1
|
||||||
setuptools ; python_version >= "3.12"
|
setuptools ; python_version >= "3.12"
|
||||||
diff -up pygit2-1.13.2/setup.py.cffiver pygit2-1.13.2/setup.py
|
diff -up pygit2-1.14.0/setup.py.cffiver pygit2-1.14.0/setup.py
|
||||||
--- pygit2-1.13.2/setup.py.cffiver 2023-10-30 09:50:04.000000000 +0100
|
--- pygit2-1.14.0/setup.py.cffiver 2024-01-26 11:05:11.000000000 +0000
|
||||||
+++ pygit2-1.13.2/setup.py 2023-11-10 23:59:47.350500138 +0100
|
+++ pygit2-1.14.0/setup.py 2024-02-08 13:09:35.539096921 +0000
|
||||||
@@ -153,7 +153,7 @@ setup(
|
@@ -152,7 +152,7 @@ setup(
|
||||||
ext_modules=ext_modules,
|
ext_modules=ext_modules,
|
||||||
# Requirements
|
# Requirements
|
||||||
python_requires='>=3.8',
|
python_requires='>=3.9',
|
||||||
- setup_requires=['cffi>=1.16.0'],
|
- setup_requires=['cffi>=1.16.0'],
|
||||||
+ setup_requires=['cffi>=1.9.1'],
|
+ setup_requires=['cffi>=1.9.1'],
|
||||||
install_requires=install_requires,
|
install_requires=install_requires,
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
%global pkgname pygit2
|
%global pkgname pygit2
|
||||||
|
|
||||||
Name: python-%{pkgname}
|
Name: python-%{pkgname}
|
||||||
Version: 1.13.3
|
Version: 1.14.0
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
Summary: Python bindings for libgit2
|
Summary: Python bindings for libgit2
|
||||||
|
|
||||||
@ -77,7 +77,7 @@ rm -f pygit2/__init__.py
|
|||||||
|
|
||||||
%files -n python3-%{pkgname}
|
%files -n python3-%{pkgname}
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%doc README.rst
|
%doc README.md
|
||||||
%{python3_sitearch}/%{pkgname}-*.dist-info/
|
%{python3_sitearch}/%{pkgname}-*.dist-info/
|
||||||
%{python3_sitearch}/%{pkgname}/
|
%{python3_sitearch}/%{pkgname}/
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pygit2-1.13.3.tar.gz) = 4b480c0553fa52202351a9d0bfa649e5c6eca31679835f982e54201cabf1e4d66144c28ac492cbe7180e6b9fb452ff5ea353f72049a88e73606c6843ffbde934
|
SHA512 (pygit2-1.14.0.tar.gz) = 677190b0781986f39ada178bbbda622206692c000526c67aa68e5058aa864ccbef61c0263042bb0e5c4acf83e24cfabfa7e163a0b0bbad71c8832b24cc8082be
|
||||||
|
Loading…
Reference in New Issue
Block a user