39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
diff -Naur eliben-pycparser-82ace14bb612/pycparser/c_lexer.py eliben-pycparser-82ace14bb612.modified/pycparser/c_lexer.py
|
|
--- eliben-pycparser-82ace14bb612/pycparser/c_lexer.py 2012-12-29 14:22:23.000000000 +0100
|
|
+++ eliben-pycparser-82ace14bb612.modified/pycparser/c_lexer.py 2013-03-19 23:15:05.074797841 +0100
|
|
@@ -9,8 +9,8 @@
|
|
import re
|
|
import sys
|
|
|
|
-from .ply import lex
|
|
-from .ply.lex import TOKEN
|
|
+from ply import lex
|
|
+from ply.lex import TOKEN
|
|
|
|
|
|
class CLexer(object):
|
|
diff -Naur eliben-pycparser-82ace14bb612/pycparser/c_parser.py eliben-pycparser-82ace14bb612.modified/pycparser/c_parser.py
|
|
--- eliben-pycparser-82ace14bb612/pycparser/c_parser.py 2012-12-29 14:22:23.000000000 +0100
|
|
+++ eliben-pycparser-82ace14bb612.modified/pycparser/c_parser.py 2013-03-19 23:15:20.338751658 +0100
|
|
@@ -8,7 +8,7 @@
|
|
#------------------------------------------------------------------------------
|
|
import re
|
|
|
|
-from .ply import yacc
|
|
+from ply import yacc
|
|
|
|
from . import c_ast
|
|
from .c_lexer import CLexer
|
|
diff -Naur eliben-pycparser-82ace14bb612/setup.py eliben-pycparser-82ace14bb612.modified/setup.py
|
|
--- eliben-pycparser-82ace14bb612/setup.py 2012-12-29 14:22:23.000000000 +0100
|
|
+++ eliben-pycparser-82ace14bb612.modified/setup.py 2013-03-19 23:14:48.861850227 +0100
|
|
@@ -22,7 +22,7 @@
|
|
classifiers = [
|
|
'Programming Language :: Python :: 2',
|
|
'Programming Language :: Python :: 3',],
|
|
- packages=['pycparser', 'pycparser.ply'],
|
|
+ packages=['pycparser'],
|
|
package_data={'pycparser': ['*.cfg']},
|
|
)
|
|
|