Update to 1.0.0b8.

This commit is contained in:
Thomas Moschny 2009-07-22 22:54:57 +00:00
parent e7add50a34
commit 327ed58927
6 changed files with 44 additions and 141 deletions

View File

@ -1 +1 @@
py-0.9.2.tar.gz
py-1.0.0b8.tar.gz

View File

@ -1 +1,2 @@
python-py-0_9_2-6_fc10:HEAD:python-py-0.9.2-6.fc10.src.rpm:1232104910
python-py-1_0_0-0_b8_fc11:HEAD:python-py-1.0.0-0.b8.fc11.src.rpm:1248303215

View File

@ -1,31 +0,0 @@
Index: trunk/py/misc/cache.py
===================================================================
--- trunk/py/misc/cache.py (revision 58575)
+++ trunk/py/misc/cache.py (revision 58576)
@@ -107,9 +107,6 @@
# time function to use for measuring build-times
_time = gettime
- def __init__(self, maxentries=64):
- super(BuildcostAccessCache, self).__init__(maxentries)
-
def build(self, key, builder, *args, **kwargs):
start = self._time()
val = builder(*args, **kwargs)
Index: trunk/py/misc/testing/test_cache.py
===================================================================
--- trunk/py/misc/testing/test_cache.py (revision 58575)
+++ trunk/py/misc/testing/test_cache.py (revision 58576)
@@ -27,6 +27,12 @@
def test_cache_works_somewhat_simple(self):
cache = BuildcostAccessCache()
+ # the default ._time() call used by
+ # BuildcostAccessCache.build can
+ # result into time()-time() == 0 which makes the below
+ # test fail randomly. Let's rather use incrementing
+ # numbers instead.
+ cache._time = py.std.itertools.count().next
for x in range(cache.maxentries):
y = cache.getorbuild(x, lambda: x)
assert x == y

View File

@ -1,44 +0,0 @@
Index: py/path/svn/wccommand.py
===================================================================
--- py/path/svn/wccommand.py (Revision 60276)
+++ py/path/svn/wccommand.py (Revision 60277)
@@ -389,6 +389,8 @@
except py.process.cmdexec.Error, e:
if e.err.find('Path is not a working copy directory') != -1:
raise py.error.ENOENT(self, e.err)
+ elif e.err.find("is not under version control") != -1:
+ raise py.error.ENOENT(self, e.err)
raise
# XXX SVN 1.3 has output on stderr instead of stdout (while it does
# return 0!), so a bit nasty, but we assume no output is output
Index: py/path/svn/testing/test_wccommand.py
===================================================================
--- py/path/svn/testing/test_wccommand.py (Revision 60276)
+++ py/path/svn/testing/test_wccommand.py (Revision 60277)
@@ -366,22 +366,21 @@
def test_commit_nonrecursive(self):
root = self.root
somedir = root.join('sampledir')
- somefile = somedir.join('otherfile')
- somefile.write('foo')
+ somedir.mkdir("subsubdir")
somedir.propset('foo', 'bar')
status = somedir.status()
assert len(status.prop_modified) == 1
- assert len(status.modified) == 1
+ assert len(status.added) == 1
somedir.commit('non-recursive commit', rec=0)
status = somedir.status()
assert len(status.prop_modified) == 0
- assert len(status.modified) == 1
+ assert len(status.added) == 1
somedir.commit('recursive commit')
status = somedir.status()
assert len(status.prop_modified) == 0
- assert len(status.modified) == 0
+ assert len(status.added) == 0
def test_commit_return_value(self):
root = self.root

View File

@ -1,8 +1,10 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%define prerelease b8
Name: python-py
Version: 0.9.2
Release: 7%{?dist}
Version: 1.0.0
Release: 0%{?prerelease:.%{prerelease}}%{?dist}
Summary: Innovative python library containing py.test, greenlets and other niceties
Group: Development/Languages
License: MIT and LGPLv2+ and Public Domain and BSD and Python
@ -18,25 +20,20 @@ License: MIT and LGPLv2+ and Public Domain and BSD and Python
# Note that all but the doctest compat files are removed
# in the prep stage.
URL: http://codespeak.net/py/dist/
Source: http://pypi.python.org/packages/source/p/py/py-%{version}.tar.gz
# r58576 from trunk
Patch0: py-0.9.2-fix-test-cache.patch
# r60277 from trunk
Patch1: py-0.9.2-svn15.patch
Source: http://pypi.python.org/packages/source/p/py/py-%{version}%{?prerelease}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: python-devel
BuildRequires: python-setuptools-devel
# needed by the testsuite
# needed by the testsuite:
BuildRequires: subversion
BuildRequires: python-docutils
BuildRequires: python-pygments
BuildRequires: pylint
BuildRequires: pexpect
%define doctarget %{buildroot}%{_docdir}/%{name}-%{version}
%ifarch ppc ppc64
# until the greenlet issue can be fixed
%define debug_package %{nil}
%endif
%description
The py lib aims at supporting a decent development process addressing
@ -44,9 +41,7 @@ deployment, versioning, testing and documentation perspectives.
%prep
%setup -q -n py-%{version}
%patch0 -p1 -b .test-cache
%patch1 -p0 -b .svn
%setup -q -n py-%{version}%{?prerelease}
# remove the compatibility modules, and use system modules instead
for module in doctest optparse textwrap subprocess ; do
@ -65,62 +60,34 @@ rm -rf %{buildroot}
%{__python} setup.py install -O1 --skip-build --root %{buildroot}
# remove shebangs and fix permissions
find %{buildroot}%{python_sitearch} \( -name '*.py' -o -name 'py.*' \) \
find %{buildroot}%{python_sitelib} \( -name '*.py' -o -name 'py.*' \) \
-exec sed -i '1{/^#!/d}' {} \; \
-exec chmod u=rw,go=r {} \;
# move and cleanup docs
# move some txt files to the doc directory
mkdir -p %{doctarget}
mv %{buildroot}%{python_sitearch}/py/LICENSE %{doctarget}
mv %{buildroot}%{python_sitearch}/py/doc/* %{doctarget}
rm %{doctarget}/*.py*
rmdir %{buildroot}%{python_sitearch}/py/doc
mv %{buildroot}%{python_sitearch}/py/apigen/todo.txt %{doctarget}/todo_apigen.txt
mv %{buildroot}%{python_sitearch}/py/apigen/todo-apigen.txt %{doctarget}/todo-apigen_apigen.txt
mv %{buildroot}%{python_sitearch}/py/compat/LICENSE %{doctarget}/LICENSE_compat
mv %{buildroot}%{python_sitearch}/py/execnet/NOTES %{doctarget}/NOTES_execnet
mv %{buildroot}%{python_sitearch}/py/path/gateway/TODO.txt %{doctarget}/TODO_path_gateway.txt
mv %{buildroot}%{python_sitearch}/py/path/svn/quoting.txt %{doctarget}/quoting_path_svn.txt
mv %{buildroot}%{python_sitearch}/py/c-extension/greenlet/README.txt %{doctarget}/RADME_greenlet.txt
# remove (most) files only used by the testsuite
find %{buildroot}%{python_sitearch} -type d -name testing -prune -exec rm -r {} \;
find %{buildroot}%{python_sitearch} -name 'conftest.py*' -exec rm {} \;
rm -r %{buildroot}%{python_sitearch}/py/io/test
mv %{buildroot}%{python_sitelib}/py/LICENSE %{doctarget}
mv %{buildroot}%{python_sitelib}/py/compat/LICENSE %{doctarget}/compat_LICENSE
mv %{buildroot}%{python_sitelib}/py/execnet/NOTES %{doctarget}/execnet_NOTES
mv %{buildroot}%{python_sitelib}/py/execnet/improve-remote-tracebacks.txt \
%{doctarget}/execnet_improve-remote-tracebacks.txt
mv %{buildroot}%{python_sitelib}/py/path/gateway/TODO.txt %{doctarget}/path_gateway_TODO.txt
mv %{buildroot}%{python_sitelib}/py/path/svn/quoting.txt %{doctarget}/svn_quoting_path.txt
cp -pr doc example contrib %{doctarget}
# remove this and that
rm %{buildroot}%{python_sitearch}/py/env.cmd
rm -r %{buildroot}%{python_sitearch}/py/bin
rm %{buildroot}%{python_sitearch}/py/c-extension/greenlet/*.h
rm %{buildroot}%{python_sitearch}/py/c-extension/greenlet/*.c
rm %{buildroot}%{python_sitearch}/py/c-extension/greenlet/setup.*
rm %{buildroot}%{python_sitearch}/py/c-extension/greenlet/test_*
find %{buildroot}%{python_sitelib} -name '*.cmd' -exec rm {} \;
%ifarch ppc ppc64
cp -p py/c-extension/greenlet/dummy_greenlet.py \
%{buildroot}%{python_sitearch}/py/c-extension/greenlet/greenlet.py
rm %{buildroot}%{python_sitearch}/py/c-extension/greenlet/greenlet.so
cat << \EOF > %{doctarget}/README.greenlet.fedora
The native py.magic.greenlet code has been replaced by
dummy_greenlet.py on ppc and ppc64 for this package because it
reproducibly segfaults.
%endif
# remove (most) files only used by the testsuite
#find %{buildroot}%{python_sitelib} -type d -name testing -prune -exec rm -r {} \;
#find %{buildroot}%{python_sitelib} -name 'conftest.py*' -exec rm {} \;
%check
# on ppc, use dummy greenlets also for the tests
%ifarch ppc ppc64
cp -p py/c-extension/greenlet/dummy_greenlet.py \
py/c-extension/greenlet/greenlet.py
rm py/c-extension/greenlet/*.{c,h}
%endif
# see pylib issue67
rm py/doc/apigen.txt
sed -i '/apigen/d' py/doc/index.txt
PYTHONPATH=$(pwd)/py %{__python} py/bin/py.test py
# some tests need to be skipped currently
PYTHONPATH=$(pwd)/py %{__python} py/bin/py.test \
'-k-test_make_sdist_and_run_it -TestWCSvnCommandPath.test_not_versioned -TestWCSvnCommandPath.test_versioned' \
py
%clean
@ -130,11 +97,21 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%{_bindir}/py.*
%{python_sitearch}/*
%{python_sitelib}/*
%{_docdir}/%{name}-%{version}
%changelog
* Wed Jul 22 2009 Thomas Moschny <thomas.moschny@gmx.de> - 1.0.0-0.b8
- Update to 1.0.0b8.
- Remove patches applied upstream.
- Greenlets have been removed upstream. So, package is noarch and
- installs to %%{python_sitelib} again
- %%ifarch sections have been removed.
- Don't remove files used by the testsuite for now.
- Add dependency on python-pygments, pylint and pexpect (for the
testsuite).
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

View File

@ -1 +1 @@
2c996d78867f6ad64dc5aabf1185aaf7 py-0.9.2.tar.gz
96a466614c3002431f735dc34088ce0f py-1.0.0b8.tar.gz