diff --git a/python-pip.spec b/python-pip.spec
index ec7f00a..530ea14 100644
--- a/python-pip.spec
+++ b/python-pip.spec
@@ -22,7 +22,7 @@
 
 Name:           python-%{srcname}
 Version:        %{base_version}%{?prerel:~%{prerel}}
-Release:        3%{?dist}
+Release:        4%{?dist}
 Summary:        A tool for installing and managing Python packages
 
 # We bundle a lot of libraries with pip, which itself is under MIT license.
@@ -263,6 +263,9 @@ ln -s %{python_wheeldir} tests/data/common_wheels
 # Remove shebang from files in bundled chardet
 grep -lr "^#\!/usr/bin/env python" src/pip/_vendor/chardet/ | xargs sed -i "1d"
 
+# Remove windows executable binaries
+rm -v src/pip/_vendor/distlib/*.exe
+sed -i '/\.exe/d' setup.py
 
 %build
 %py3_build_wheel
@@ -398,6 +401,10 @@ pytest_k='not completion and
 %{python_wheeldir}/%{python_wheelname}
 
 %changelog
+* Wed Oct 06 2021 Charalampos Stratakis <cstratak@redhat.com> - 21.2.3-4
+- Remove bundled windows executables
+- Resolves: rhbz#2005453
+
 * Thu Sep 23 2021 Miro HronĨok <mhroncok@redhat.com> - 21.2.3-3
 - Detect paths not to uninstall from via sysconfig's rpm_prefix install scheme