Update to 8.3.1
This commit is contained in:
parent
80d800409b
commit
fd301b7bed
1
.gitignore
vendored
1
.gitignore
vendored
@ -56,3 +56,4 @@
|
|||||||
/Pillow-8.1.1.tar.gz
|
/Pillow-8.1.1.tar.gz
|
||||||
/Pillow-8.1.2.tar.gz
|
/Pillow-8.1.2.tar.gz
|
||||||
/Pillow-8.2.0.tar.gz
|
/Pillow-8.2.0.tar.gz
|
||||||
|
/Pillow-8.3.1.tar.gz
|
||||||
|
@ -7,8 +7,8 @@
|
|||||||
%global with_docs 1
|
%global with_docs 1
|
||||||
|
|
||||||
Name: python-%{srcname}
|
Name: python-%{srcname}
|
||||||
Version: 8.2.0
|
Version: 8.3.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python image processing library
|
Summary: Python image processing library
|
||||||
|
|
||||||
# License: see http://www.pythonware.com/products/pil/license.htm
|
# License: see http://www.pythonware.com/products/pil/license.htm
|
||||||
@ -18,8 +18,8 @@ Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillo
|
|||||||
|
|
||||||
# Don't error out if sphinx warnings occur
|
# Don't error out if sphinx warnings occur
|
||||||
Patch0: python-pillow_spinxwarn.patch
|
Patch0: python-pillow_spinxwarn.patch
|
||||||
# Drop sphinx-issues requirement, it's not packaged for Fedora
|
# Drop sphinx plugin requirements which are not packaged for Fedora
|
||||||
Patch1: python-pillow_sphinx-issues.patch
|
Patch1: python-pillow_sphinx.patch
|
||||||
|
|
||||||
BuildRequires: freetype-devel
|
BuildRequires: freetype-devel
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -44,6 +44,7 @@ BuildRequires: python%{python3_pkgversion}-setuptools
|
|||||||
%if 0%{?with_docs}
|
%if 0%{?with_docs}
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: python%{python3_pkgversion}-sphinx
|
BuildRequires: python%{python3_pkgversion}-sphinx
|
||||||
|
BuildRequires: python%{python3_pkgversion}-sphinx-copybutton
|
||||||
BuildRequires: python%{python3_pkgversion}-sphinx_rtd_theme
|
BuildRequires: python%{python3_pkgversion}-sphinx_rtd_theme
|
||||||
BuildRequires: python%{python3_pkgversion}-sphinx-removed-in
|
BuildRequires: python%{python3_pkgversion}-sphinx-removed-in
|
||||||
%endif
|
%endif
|
||||||
@ -196,6 +197,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 07 2021 Sandro Mani <manisandro@gmail.com> - 8.3.1-1
|
||||||
|
- Update to 8.3.1
|
||||||
|
|
||||||
* Thu Jun 03 2021 Python Maint <python-maint@redhat.com> - 8.2.0-3
|
* Thu Jun 03 2021 Python Maint <python-maint@redhat.com> - 8.2.0-3
|
||||||
- Rebuilt for Python 3.10
|
- Rebuilt for Python 3.10
|
||||||
|
|
||||||
|
@ -1,11 +1,11 @@
|
|||||||
diff -rupN --no-dereference Pillow-8.2.0/docs/conf.py Pillow-8.2.0-new/docs/conf.py
|
diff -rupN --no-dereference Pillow-8.3.1/docs/conf.py Pillow-8.3.1-new/docs/conf.py
|
||||||
--- Pillow-8.2.0/docs/conf.py 2021-04-01 19:58:27.000000000 +0200
|
--- Pillow-8.3.1/docs/conf.py 2021-07-06 16:05:28.000000000 +0200
|
||||||
+++ Pillow-8.2.0-new/docs/conf.py 2021-04-02 07:41:32.879022927 +0200
|
+++ Pillow-8.3.1-new/docs/conf.py 2021-07-07 10:44:44.716870622 +0200
|
||||||
@@ -32,7 +32,6 @@ extensions = [
|
@@ -30,7 +30,6 @@ needs_sphinx = "2.4"
|
||||||
"sphinx.ext.autodoc",
|
# ones.
|
||||||
"sphinx.ext.intersphinx",
|
extensions = [
|
||||||
"sphinx.ext.viewcode",
|
"sphinx_copybutton",
|
||||||
- "sphinx_issues",
|
- "sphinx_issues",
|
||||||
"sphinx_removed_in",
|
"sphinx_removed_in",
|
||||||
]
|
"sphinx.ext.autodoc",
|
||||||
|
"sphinx.ext.intersphinx",
|
||||||
|
17
python-pillow_sphinx.patch
Normal file
17
python-pillow_sphinx.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -rupN Pillow-8.3.1/docs/conf.py Pillow-8.3.1-new/docs/conf.py
|
||||||
|
--- Pillow-8.3.1/docs/conf.py 2021-07-07 10:45:16.614845303 +0200
|
||||||
|
+++ Pillow-8.3.1-new/docs/conf.py 2021-07-07 10:45:02.533856396 +0200
|
||||||
|
@@ -30,12 +30,10 @@ needs_sphinx = "2.4"
|
||||||
|
# ones.
|
||||||
|
extensions = [
|
||||||
|
"sphinx_copybutton",
|
||||||
|
- "sphinx_issues",
|
||||||
|
"sphinx_removed_in",
|
||||||
|
"sphinx.ext.autodoc",
|
||||||
|
"sphinx.ext.intersphinx",
|
||||||
|
- "sphinx.ext.viewcode",
|
||||||
|
- "sphinxext.opengraph",
|
||||||
|
+ "sphinx.ext.viewcode"
|
||||||
|
]
|
||||||
|
|
||||||
|
intersphinx_mapping = {"python": ("https://docs.python.org/3", None)}
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN --no-dereference Pillow-8.2.0/docs/Makefile Pillow-8.2.0-new/docs/Makefile
|
diff -rupN --no-dereference Pillow-8.3.1/docs/Makefile Pillow-8.3.1-new/docs/Makefile
|
||||||
--- Pillow-8.2.0/docs/Makefile 2021-04-01 19:58:27.000000000 +0200
|
--- Pillow-8.3.1/docs/Makefile 2021-07-06 16:05:28.000000000 +0200
|
||||||
+++ Pillow-8.2.0-new/docs/Makefile 2021-04-02 07:41:32.797022925 +0200
|
+++ Pillow-8.3.1-new/docs/Makefile 2021-07-07 10:44:44.471870820 +0200
|
||||||
@@ -42,7 +42,7 @@ clean:
|
@@ -42,7 +42,7 @@ clean:
|
||||||
-rm -rf $(BUILDDIR)/*
|
-rm -rf $(BUILDDIR)/*
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (Pillow-8.2.0.tar.gz) = 40e97a54689ca04349d17b69b0e95bb3ef4fde0b60c6c55a2ec76034a5c2a9ebee0b310f68de1636db08786d9b2ad444bf10ac3b42a31404847cc165aa8392ac
|
SHA512 (Pillow-8.3.1.tar.gz) = 22a85a5510c8ec13928af571ec7f329f4728c46ebaadfe338d837f6d3718eedb57b7548fd9a3260a3bb0c0f97b3f3c911e730af01f90ca70c967d44b1e5d3606
|
||||||
|
Loading…
Reference in New Issue
Block a user