Update to 9.4.0
This commit is contained in:
parent
0ec02f6add
commit
e194019151
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@
|
||||
/Pillow-9.1.1.tar.gz
|
||||
/Pillow-9.2.0.tar.gz
|
||||
/Pillow-9.3.0.tar.gz
|
||||
/Pillow-9.4.0.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
--- Pillow-9.3.0/setup.py 2022-10-29 14:25:53.000000000 +0200
|
||||
+++ Pillow-9.3.0-new/setup.py 2022-10-30 11:05:22.595017453 +0100
|
||||
diff -rupN --no-dereference Pillow-9.4.0/setup.py Pillow-9.4.0-new/setup.py
|
||||
--- Pillow-9.4.0/setup.py 2023-01-02 00:29:07.000000000 +0100
|
||||
+++ Pillow-9.4.0-new/setup.py 2023-01-02 10:44:32.109518818 +0100
|
||||
@@ -135,7 +135,7 @@ class RequiredDependencyException(Except
|
||||
pass
|
||||
|
||||
@ -10,7 +10,7 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
PLATFORM_PYPY = hasattr(sys, "pypy_version_info")
|
||||
|
||||
|
||||
@@ -503,7 +503,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -501,7 +501,7 @@ class pil_build_ext(build_ext):
|
||||
#
|
||||
# add platform directories
|
||||
|
||||
@ -19,7 +19,7 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
pass
|
||||
|
||||
elif sys.platform == "cygwin":
|
||||
@@ -595,7 +595,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -593,7 +593,7 @@ class pil_build_ext(build_ext):
|
||||
# FIXME: check /opt/stuff directories here?
|
||||
|
||||
# standard locations
|
||||
@ -28,7 +28,7 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
_add_directory(library_dirs, "/usr/local/lib")
|
||||
_add_directory(include_dirs, "/usr/local/include")
|
||||
|
||||
@@ -841,7 +841,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -839,7 +839,7 @@ class pil_build_ext(build_ext):
|
||||
if feature.xcb:
|
||||
libs.append(feature.xcb)
|
||||
defs.append(("HAVE_XCB", None))
|
||||
@ -37,7 +37,7 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
libs.extend(["kernel32", "user32", "gdi32"])
|
||||
if struct.unpack("h", b"\0\1")[0] == 1:
|
||||
defs.append(("WORDS_BIGENDIAN", None))
|
||||
@@ -863,6 +863,8 @@ class pil_build_ext(build_ext):
|
||||
@@ -861,6 +861,8 @@ class pil_build_ext(build_ext):
|
||||
if feature.freetype:
|
||||
srcs = []
|
||||
libs = ["freetype"]
|
||||
@ -46,7 +46,7 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
defs = []
|
||||
if feature.raqm:
|
||||
if not feature.want_vendor("raqm"): # using system Raqm
|
||||
@@ -885,7 +887,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -883,7 +885,7 @@ class pil_build_ext(build_ext):
|
||||
|
||||
if feature.lcms:
|
||||
extra = []
|
||||
@ -55,7 +55,7 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
extra.extend(["user32", "gdi32"])
|
||||
self._update_extension("PIL._imagingcms", [feature.lcms] + extra)
|
||||
else:
|
||||
@@ -904,7 +906,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -902,7 +904,7 @@ class pil_build_ext(build_ext):
|
||||
else:
|
||||
self._remove_extension("PIL._webp")
|
||||
|
||||
@ -64,9 +64,9 @@ diff -rupN --no-dereference Pillow-9.3.0/setup.py Pillow-9.3.0-new/setup.py
|
||||
self._update_extension("PIL._imagingtk", tk_libs)
|
||||
|
||||
build_ext.build_extensions(self)
|
||||
diff -rupN --no-dereference Pillow-9.3.0/src/libImaging/ImPlatform.h Pillow-9.3.0-new/src/libImaging/ImPlatform.h
|
||||
--- Pillow-9.3.0/src/libImaging/ImPlatform.h 2022-10-29 14:25:53.000000000 +0200
|
||||
+++ Pillow-9.3.0-new/src/libImaging/ImPlatform.h 2022-10-30 11:05:22.596017453 +0100
|
||||
diff -rupN --no-dereference Pillow-9.4.0/src/libImaging/ImPlatform.h Pillow-9.4.0-new/src/libImaging/ImPlatform.h
|
||||
--- Pillow-9.4.0/src/libImaging/ImPlatform.h 2023-01-02 00:29:07.000000000 +0100
|
||||
+++ Pillow-9.4.0-new/src/libImaging/ImPlatform.h 2023-01-02 10:44:32.109518818 +0100
|
||||
@@ -28,7 +28,7 @@
|
||||
#if defined(_WIN32) || defined(__CYGWIN__)
|
||||
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,18 +1,19 @@
|
||||
%global py3_incdir %(RPM_BUILD_ROOT= %{python3} -Ic 'import sysconfig; print(sysconfig.get_path("include"))')
|
||||
|
||||
%global srcname pillow
|
||||
# EPEL9 is missing some dependencies to build the documentation
|
||||
%if 0%{?el9}
|
||||
|
||||
# Dependencies are missing to build the documentation
|
||||
%bcond_with doc
|
||||
|
||||
%if 0%{?el9}
|
||||
%bcond_with mingw
|
||||
%else
|
||||
%bcond_without doc
|
||||
%bcond_without mingw
|
||||
%endif
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 9.3.0
|
||||
Release: 2%{?dist}
|
||||
Version: 9.4.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Python image processing library
|
||||
|
||||
# License: see http://www.pythonware.com/products/pil/license.htm
|
||||
@ -20,14 +21,8 @@ License: MIT
|
||||
URL: http://python-pillow.github.io/
|
||||
Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
|
||||
|
||||
# Don't error out if sphinx warnings occur
|
||||
Patch0: python-pillow_spinxwarn.patch
|
||||
# Drop sphinx plugin requirements which are not packaged for Fedora
|
||||
Patch1: python-pillow_sphinx.patch
|
||||
# MinGW build fixes
|
||||
Patch2: pillow_mingw.patch
|
||||
# Revert back to using sphinx_rtd_theme
|
||||
Patch3: python-pillow-revert-furo-theme.patch
|
||||
Patch0: pillow_mingw.patch
|
||||
|
||||
BuildRequires: freetype-devel
|
||||
BuildRequires: gcc
|
||||
@ -300,6 +295,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 02 2023 Sandro Mani <manisandro@gmail.com> - 9.4.0-1
|
||||
- Update to 9.4.0
|
||||
|
||||
* Mon Oct 31 2022 Sandro Mani <manisandro@gmail.com> - 9.3.0-2
|
||||
- Rebuild (mingw-python-3.11)
|
||||
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff -rupN --no-dereference Pillow-9.3.0/docs/conf.py Pillow-9.3.0-new/docs/conf.py
|
||||
--- Pillow-9.3.0/docs/conf.py 2022-10-29 14:25:53.000000000 +0200
|
||||
+++ Pillow-9.3.0-new/docs/conf.py 2022-10-30 11:05:22.465017452 +0100
|
||||
@@ -28,12 +28,10 @@ needs_sphinx = "2.4"
|
||||
# ones.
|
||||
extensions = [
|
||||
"sphinx_copybutton",
|
||||
- "sphinx_issues",
|
||||
"sphinx_removed_in",
|
||||
"sphinx.ext.autodoc",
|
||||
"sphinx.ext.intersphinx",
|
||||
- "sphinx.ext.viewcode",
|
||||
- "sphinxext.opengraph",
|
||||
+ "sphinx.ext.viewcode"
|
||||
]
|
||||
|
||||
intersphinx_mapping = {"python": ("https://docs.python.org/3", None)}
|
@ -1,12 +0,0 @@
|
||||
diff -rupN --no-dereference Pillow-9.3.0/docs/Makefile Pillow-9.3.0-new/docs/Makefile
|
||||
--- Pillow-9.3.0/docs/Makefile 2022-10-29 14:25:53.000000000 +0200
|
||||
+++ Pillow-9.3.0-new/docs/Makefile 2022-10-30 11:05:22.304017451 +0100
|
||||
@@ -47,7 +47,7 @@ install-sphinx:
|
||||
|
||||
html:
|
||||
$(MAKE) install-sphinx
|
||||
- $(SPHINXBUILD) -b html -W --keep-going $(ALLSPHINXOPTS) $(BUILDDIR)/html
|
||||
+ $(SPHINXBUILD) -b html --keep-going $(ALLSPHINXOPTS) $(BUILDDIR)/html
|
||||
@echo
|
||||
@echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Pillow-9.3.0.tar.gz) = 60c529d8a222a521a0c3f4254917aa3f6c5a47c7cb8930b4b9a05ef442d1a7e776018dc4ac834a9effc1342f8457898cae79820531ff430728f6c39d6297b2d7
|
||||
SHA512 (Pillow-9.4.0.tar.gz) = 6c08336e5ca1e652bb3237ae092be61b78dc1cf65603d6b23369eb8e0554786114a8f87ab092a5fb9577e02cd0bb381353fa657e03090baeb91b4b8e3c740d51
|
||||
|
Loading…
Reference in New Issue
Block a user