Update to 10.0.1
This commit is contained in:
parent
25d6a388d4
commit
b830e6c078
1
.gitignore
vendored
1
.gitignore
vendored
@ -68,3 +68,4 @@
|
|||||||
/Pillow-9.4.0.tar.gz
|
/Pillow-9.4.0.tar.gz
|
||||||
/Pillow-9.5.0.tar.gz
|
/Pillow-9.5.0.tar.gz
|
||||||
/Pillow-10.0.0.tar.gz
|
/Pillow-10.0.0.tar.gz
|
||||||
|
/Pillow-10.0.1.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -rupN Pillow-10.0.0/setup.py Pillow-10.0.0-new/setup.py
|
diff -rupN --no-dereference Pillow-10.0.1/setup.py Pillow-10.0.1-new/setup.py
|
||||||
--- Pillow-10.0.0/setup.py 2023-07-01 14:08:11.000000000 +0200
|
--- Pillow-10.0.1/setup.py 2023-09-15 13:55:25.000000000 +0200
|
||||||
+++ Pillow-10.0.0-new/setup.py 2023-07-05 20:54:06.603404501 +0200
|
+++ Pillow-10.0.1-new/setup.py 2023-09-18 09:36:57.608297698 +0200
|
||||||
@@ -136,7 +136,7 @@ class RequiredDependencyException(Except
|
@@ -136,7 +136,7 @@ class RequiredDependencyException(Except
|
||||||
pass
|
pass
|
||||||
|
|
||||||
@ -64,9 +64,9 @@ diff -rupN Pillow-10.0.0/setup.py Pillow-10.0.0-new/setup.py
|
|||||||
self._update_extension("PIL._imagingtk", tk_libs)
|
self._update_extension("PIL._imagingtk", tk_libs)
|
||||||
|
|
||||||
build_ext.build_extensions(self)
|
build_ext.build_extensions(self)
|
||||||
diff -rupN Pillow-10.0.0/src/libImaging/ImPlatform.h Pillow-10.0.0-new/src/libImaging/ImPlatform.h
|
diff -rupN --no-dereference Pillow-10.0.1/src/libImaging/ImPlatform.h Pillow-10.0.1-new/src/libImaging/ImPlatform.h
|
||||||
--- Pillow-10.0.0/src/libImaging/ImPlatform.h 2023-07-01 14:08:11.000000000 +0200
|
--- Pillow-10.0.1/src/libImaging/ImPlatform.h 2023-09-15 13:55:25.000000000 +0200
|
||||||
+++ Pillow-10.0.0-new/src/libImaging/ImPlatform.h 2023-07-05 20:05:24.129483278 +0200
|
+++ Pillow-10.0.1-new/src/libImaging/ImPlatform.h 2023-09-18 09:36:57.608297698 +0200
|
||||||
@@ -28,7 +28,7 @@
|
@@ -28,7 +28,7 @@
|
||||||
#if defined(_WIN32) || defined(__CYGWIN__) /* WIN */
|
#if defined(_WIN32) || defined(__CYGWIN__) /* WIN */
|
||||||
|
|
||||||
@ -76,105 +76,3 @@ diff -rupN Pillow-10.0.0/src/libImaging/ImPlatform.h Pillow-10.0.0-new/src/libIm
|
|||||||
|
|
||||||
#ifdef __CYGWIN__
|
#ifdef __CYGWIN__
|
||||||
#undef _WIN64
|
#undef _WIN64
|
||||||
diff -rupN Pillow-10.0.0/src/libImaging/ImPlatform.h.orig Pillow-10.0.0-new/src/libImaging/ImPlatform.h.orig
|
|
||||||
--- Pillow-10.0.0/src/libImaging/ImPlatform.h.orig 1970-01-01 01:00:00.000000000 +0100
|
|
||||||
+++ Pillow-10.0.0-new/src/libImaging/ImPlatform.h.orig 2023-07-01 14:08:11.000000000 +0200
|
|
||||||
@@ -0,0 +1,98 @@
|
|
||||||
+/*
|
|
||||||
+ * The Python Imaging Library
|
|
||||||
+ * $Id$
|
|
||||||
+ *
|
|
||||||
+ * platform declarations for the imaging core library
|
|
||||||
+ *
|
|
||||||
+ * Copyright (c) Fredrik Lundh 1995-2003.
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+#include "Python.h"
|
|
||||||
+
|
|
||||||
+/* Check that we have an ANSI compliant compiler */
|
|
||||||
+#ifndef HAVE_PROTOTYPES
|
|
||||||
+#error Sorry, this library requires support for ANSI prototypes.
|
|
||||||
+#endif
|
|
||||||
+#ifndef STDC_HEADERS
|
|
||||||
+#error Sorry, this library requires ANSI header files.
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#if defined(PIL_NO_INLINE)
|
|
||||||
+#define inline
|
|
||||||
+#else
|
|
||||||
+#if defined(_MSC_VER) && !defined(__GNUC__)
|
|
||||||
+#define inline __inline
|
|
||||||
+#endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#if defined(_WIN32) || defined(__CYGWIN__) /* WIN */
|
|
||||||
+
|
|
||||||
+#define WIN32_LEAN_AND_MEAN
|
|
||||||
+#include <Windows.h>
|
|
||||||
+
|
|
||||||
+#ifdef __CYGWIN__
|
|
||||||
+#undef _WIN64
|
|
||||||
+#undef _WIN32
|
|
||||||
+#undef __WIN32__
|
|
||||||
+#undef WIN32
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#else /* not WIN */
|
|
||||||
+/* For System that are not Windows, we'll need to define these. */
|
|
||||||
+/* We have to define them instead of using typedef because the JPEG lib also
|
|
||||||
+ defines their own types with the same names, so we need to be able to undef
|
|
||||||
+ ours before including the JPEG code. */
|
|
||||||
+
|
|
||||||
+#if __STDC_VERSION__ >= 199901L /* C99+ */
|
|
||||||
+
|
|
||||||
+#include <stdint.h>
|
|
||||||
+
|
|
||||||
+#define INT8 int8_t
|
|
||||||
+#define UINT8 uint8_t
|
|
||||||
+#define INT16 int16_t
|
|
||||||
+#define UINT16 uint16_t
|
|
||||||
+#define INT32 int32_t
|
|
||||||
+#define UINT32 uint32_t
|
|
||||||
+
|
|
||||||
+#else /* < C99 */
|
|
||||||
+
|
|
||||||
+#define INT8 signed char
|
|
||||||
+
|
|
||||||
+#if SIZEOF_SHORT == 2
|
|
||||||
+#define INT16 short
|
|
||||||
+#elif SIZEOF_INT == 2
|
|
||||||
+#define INT16 int
|
|
||||||
+#else
|
|
||||||
+#error Cannot find required 16-bit integer type
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#if SIZEOF_SHORT == 4
|
|
||||||
+#define INT32 short
|
|
||||||
+#elif SIZEOF_INT == 4
|
|
||||||
+#define INT32 int
|
|
||||||
+#elif SIZEOF_LONG == 4
|
|
||||||
+#define INT32 long
|
|
||||||
+#else
|
|
||||||
+#error Cannot find required 32-bit integer type
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#define UINT8 unsigned char
|
|
||||||
+#define UINT16 unsigned INT16
|
|
||||||
+#define UINT32 unsigned INT32
|
|
||||||
+
|
|
||||||
+#endif /* < C99 */
|
|
||||||
+
|
|
||||||
+#endif /* not WIN */
|
|
||||||
+
|
|
||||||
+/* assume IEEE; tweak if necessary (patches are welcome) */
|
|
||||||
+#define FLOAT16 UINT16
|
|
||||||
+#define FLOAT32 float
|
|
||||||
+#define FLOAT64 double
|
|
||||||
+
|
|
||||||
+#ifdef _MSC_VER
|
|
||||||
+typedef signed __int64 int64_t;
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
+#ifdef __GNUC__
|
|
||||||
+#define GCC_VERSION (__GNUC__ * 10000 + __GNUC_MINOR__ * 100 + __GNUC_PATCHLEVEL__)
|
|
||||||
+#endif
|
|
||||||
|
@ -12,8 +12,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: python-%{srcname}
|
Name: python-%{srcname}
|
||||||
Version: 10.0.0
|
Version: 10.0.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python image processing library
|
Summary: Python image processing library
|
||||||
|
|
||||||
# License: see http://www.pythonware.com/products/pil/license.htm
|
# License: see http://www.pythonware.com/products/pil/license.htm
|
||||||
@ -295,6 +295,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 18 2023 Sandro Mani <manisandro@gmail.com> - 10.0.1-1
|
||||||
|
- Update to 10.0.1
|
||||||
|
|
||||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-2
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (Pillow-10.0.0.tar.gz) = a963ae8398c609569e1b23d2362f6382cd888698492ba2349f9c931a04c463fbdc27a43e53d1dee8bbb1b5e88c0d5eb655f6f5e9df7d489c206b6acda0adec3a
|
SHA512 (Pillow-10.0.1.tar.gz) = 27e2f0d86563c3b7f5a2e0ba2bbe98fc2cb2fa5871d0b6cbb5a0014e9d9eb03dde9969301419d806d1a22cd4881e624465a355ba9bc42b95746226e1f95712a9
|
||||||
|
Loading…
Reference in New Issue
Block a user