Update to 5.0.0
This commit is contained in:
parent
906fa4bb85
commit
b7d12452da
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
|||||||
/Pillow-4.2.0.tar.gz
|
/Pillow-4.2.0.tar.gz
|
||||||
/Pillow-4.2.1.tar.gz
|
/Pillow-4.2.1.tar.gz
|
||||||
/Pillow-4.3.0.tar.gz
|
/Pillow-4.3.0.tar.gz
|
||||||
|
/Pillow-5.0.0.tar.gz
|
||||||
|
@ -13,7 +13,7 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: python-%{srcname}
|
Name: python-%{srcname}
|
||||||
Version: 4.3.0
|
Version: 5.0.0
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python image processing library
|
Summary: Python image processing library
|
||||||
|
|
||||||
@ -22,6 +22,10 @@ License: MIT
|
|||||||
URL: http://python-pillow.github.io/
|
URL: http://python-pillow.github.io/
|
||||||
Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
|
Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
|
||||||
|
|
||||||
|
# Add libdirs for ppc64le and armv7hl
|
||||||
|
Patch0: python-pillow_libdirs.patch
|
||||||
|
|
||||||
|
|
||||||
BuildRequires: tk-devel
|
BuildRequires: tk-devel
|
||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
@ -62,9 +66,8 @@ BuildRequires: python3-cffi
|
|||||||
# For EpsImagePlugin.py
|
# For EpsImagePlugin.py
|
||||||
Requires: ghostscript
|
Requires: ghostscript
|
||||||
|
|
||||||
%filter_provides_in %{python2_sitearch}
|
%global __provides_exclude_from ^%{python2_sitearch}/PIL/.*\\.so$
|
||||||
%filter_provides_in %{python3_sitearch}
|
%global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
|
||||||
%filter_setup
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Python image processing library, fork of the Python Imaging Library (PIL)
|
Python image processing library, fork of the Python Imaging Library (PIL)
|
||||||
@ -206,10 +209,7 @@ Qt %{srcname} image wrapper.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n Pillow-%{version}
|
%autosetup -p1 -n Pillow-%{version}
|
||||||
|
|
||||||
# Strip shebang on non-executable file
|
|
||||||
sed -i 1d PIL/OleFileIO.py
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -235,35 +235,16 @@ rm -f docs/_build_py3/html/.buildinfo
|
|||||||
%install
|
%install
|
||||||
# Install Python 2 modules
|
# Install Python 2 modules
|
||||||
install -d %{buildroot}/%{py2_incdir}/Imaging
|
install -d %{buildroot}/%{py2_incdir}/Imaging
|
||||||
install -m 644 libImaging/*.h %{buildroot}/%{py2_incdir}/Imaging
|
install -m 644 src/libImaging/*.h %{buildroot}/%{py2_incdir}/Imaging
|
||||||
install -d %{buildroot}%{_defaultdocdir}/python2-%{srcname}-doc/Scripts
|
|
||||||
install -m 644 Scripts/* %{buildroot}%{_defaultdocdir}/python2-%{srcname}-doc/Scripts
|
|
||||||
%py2_install
|
%py2_install
|
||||||
|
|
||||||
# Fix non-standard-executable-perm
|
|
||||||
chmod 0755 %{buildroot}%{python2_sitearch}/PIL/*.so
|
|
||||||
|
|
||||||
# Hardcode interpreter for example scripts
|
|
||||||
find %{buildroot}%{_defaultdocdir}/python2-%{srcname}-doc/Scripts -name '*.py' | xargs sed -i '1s|^#!.*python|#!%{__python2}|'
|
|
||||||
|
|
||||||
%if %{with_python3}
|
%if %{with_python3}
|
||||||
# Install Python 3 modules
|
# Install Python 3 modules
|
||||||
install -d %{buildroot}/%{py3_incdir}/Imaging
|
install -d %{buildroot}/%{py3_incdir}/Imaging
|
||||||
install -m 644 libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
|
install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
|
||||||
install -d %{buildroot}%{_defaultdocdir}/python3-%{srcname}-doc/Scripts
|
|
||||||
install -m 644 Scripts/* %{buildroot}%{_defaultdocdir}/python3-%{srcname}-doc/Scripts
|
|
||||||
%py3_install
|
%py3_install
|
||||||
|
|
||||||
# Fix non-standard-executable-perm
|
|
||||||
chmod 0755 %{buildroot}%{python3_sitearch}/PIL/*.so
|
|
||||||
|
|
||||||
# Hardcode interpreter for example scripts
|
|
||||||
find %{buildroot}%{_defaultdocdir}/python3-%{srcname}-doc/Scripts -name '*.py' | xargs sed -i '1s|^#!.*python|#!%{__python3}|'
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# The scripts are packaged in %%doc
|
|
||||||
rm -rf %{buildroot}%{_bindir}
|
|
||||||
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
# Check Python 2 modules
|
# Check Python 2 modules
|
||||||
@ -299,7 +280,6 @@ popd
|
|||||||
%{py2_incdir}/Imaging/
|
%{py2_incdir}/Imaging/
|
||||||
|
|
||||||
%files -n python2-%{srcname}-doc
|
%files -n python2-%{srcname}-doc
|
||||||
%doc %{_defaultdocdir}/python2-%{srcname}-doc/Scripts
|
|
||||||
%if 0%{?with_docs}
|
%if 0%{?with_docs}
|
||||||
%doc docs/_build_py2/html
|
%doc docs/_build_py2/html
|
||||||
%endif # with_docs
|
%endif # with_docs
|
||||||
@ -330,7 +310,6 @@ popd
|
|||||||
%{py3_incdir}/Imaging/
|
%{py3_incdir}/Imaging/
|
||||||
|
|
||||||
%files -n python3-%{srcname}-doc
|
%files -n python3-%{srcname}-doc
|
||||||
%doc %{_defaultdocdir}/python3-%{srcname}-doc/Scripts
|
|
||||||
%if 0%{?with_docs}
|
%if 0%{?with_docs}
|
||||||
%doc docs/_build_py3/html
|
%doc docs/_build_py3/html
|
||||||
%endif # with_docs
|
%endif # with_docs
|
||||||
@ -349,6 +328,9 @@ popd
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
|
||||||
|
- Update to 5.0.0
|
||||||
|
|
||||||
* Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
|
* Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
|
||||||
- Update to 4.3.0
|
- Update to 4.3.0
|
||||||
|
|
||||||
|
14
python-pillow_libdirs.patch
Normal file
14
python-pillow_libdirs.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -rupN Pillow-5.0.0/setup.py Pillow-5.0.0-new/setup.py
|
||||||
|
--- Pillow-5.0.0/setup.py 2018-01-01 16:03:06.000000000 +0100
|
||||||
|
+++ Pillow-5.0.0-new/setup.py 2018-01-03 11:27:55.608667037 +0100
|
||||||
|
@@ -358,8 +358,10 @@ class pil_build_ext(build_ext):
|
||||||
|
'aarch64': ["/usr/lib64", "/usr/lib/aarch64-linux-gnu"],
|
||||||
|
'arm': ["/usr/lib/arm-linux-gnueabi"],
|
||||||
|
'armv71': ["/usr/lib/arm-linux-gnueabi"],
|
||||||
|
+ 'armv7l': ["/usr/lib"],
|
||||||
|
'ppc64': ["/usr/lib64", "/usr/lib/ppc64-linux-gnu",
|
||||||
|
"/usr/lib/powerpc64-linux-gnu"],
|
||||||
|
+ 'ppc64le': ["/usr/lib64"],
|
||||||
|
'ppc': ["/usr/lib/ppc-linux-gnu",
|
||||||
|
"/usr/lib/powerpc-linux-gnu"],
|
||||||
|
's390x': ["/usr/lib64", "/usr/lib/s390x-linux-gnu"],
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (Pillow-4.3.0.tar.gz) = 05e544061a18b592530ab20c98142d7de5cea3627c19f100e67e10d05cb3d549d96f6a446607e392358c2a87d84cf2c17caeac2de7130be58e45af0b7dec1492
|
SHA512 (Pillow-5.0.0.tar.gz) = e615d1ad68c79c6045e4910b1c7cfdca6f3cf3512dbe185bad87e0a57649b82c979670db2ce27767b6d2f1b5aa95df44ec1ee91bea0df98ffab7d4852f7b314b
|
||||||
|
Loading…
Reference in New Issue
Block a user