diff --git a/fix-sphinx3-html-failure.patch b/fix-sphinx3-html-failure.patch
new file mode 100644
index 0000000..6b5701b
--- /dev/null
+++ b/fix-sphinx3-html-failure.patch
@@ -0,0 +1,13 @@
+diff --git a/docs/reference/plugins.rst b/docs/reference/plugins.rst
+index 46f657f..cc0742f 100644
+--- a/docs/reference/plugins.rst
++++ b/docs/reference/plugins.rst
+@@ -229,7 +229,7 @@ Plugin reference
+ ----------------------------
+
+ .. automodule:: PIL.PngImagePlugin
+- :members: ChunkStream, PngImageFile, PngStream, getchunks, is_cid, putchunk
++ :members: ChunkStream, PngStream, getchunks, is_cid, putchunk
+ :show-inheritance:
+ .. autoclass:: PIL.PngImagePlugin.ChunkStream
+ :members:
diff --git a/python-pillow.spec b/python-pillow.spec
index c014838..519e951 100644
--- a/python-pillow.spec
+++ b/python-pillow.spec
@@ -8,7 +8,7 @@
Name: python-%{srcname}
Version: 7.1.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Python image processing library
# License: see http://www.pythonware.com/products/pil/license.htm
@@ -16,6 +16,10 @@ License: MIT
URL: http://python-pillow.github.io/
Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
+# Fix build failure with Sphinx 3 when creating html docs.
+# Resolved upstream: https://github.com/python-pillow/Pillow/commit/f1f177ce800c5be7d06b0119b979c661c1bfbbb9
+Patch0: fix-sphinx3-html-failure.patch
+
BuildRequires: freetype-devel
BuildRequires: gcc
BuildRequires: ghostscript
@@ -182,6 +186,9 @@ popd
%changelog
+* Tue Apr 21 2020 Charalampos Stratakis - 7.1.1-2
+- Fix html docs build failure with Sphinx3 (rhbz#1823884)
+
* Thu Apr 02 2020 Sandro Mani - 7.1.1-1
- Update to 7.1.1