Update to 9.2.0
This commit is contained in:
parent
d649e264ff
commit
6e7564f12d
1
.gitignore
vendored
1
.gitignore
vendored
@ -63,3 +63,4 @@
|
||||
/Pillow-9.0.1.tar.gz
|
||||
/Pillow-9.1.0.tar.gz
|
||||
/Pillow-9.1.1.tar.gz
|
||||
/Pillow-9.2.0.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
--- Pillow-9.1.1/setup.py 2022-05-17 12:33:52.000000000 +0200
|
||||
+++ Pillow-9.1.1-new/setup.py 2022-05-20 23:52:00.467965674 +0200
|
||||
diff -rupN --no-dereference Pillow-9.2.0/setup.py Pillow-9.2.0-new/setup.py
|
||||
--- Pillow-9.2.0/setup.py 2022-07-01 15:19:51.000000000 +0200
|
||||
+++ Pillow-9.2.0-new/setup.py 2022-07-20 16:40:23.805366371 +0200
|
||||
@@ -135,7 +135,7 @@ class RequiredDependencyException(Except
|
||||
pass
|
||||
|
||||
@ -10,7 +10,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
PLATFORM_PYPY = hasattr(sys, "pypy_version_info")
|
||||
|
||||
|
||||
@@ -497,7 +497,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -503,7 +503,7 @@ class pil_build_ext(build_ext):
|
||||
#
|
||||
# add platform directories
|
||||
|
||||
@ -19,7 +19,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
pass
|
||||
|
||||
elif sys.platform == "cygwin":
|
||||
@@ -589,7 +589,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -595,7 +595,7 @@ class pil_build_ext(build_ext):
|
||||
# FIXME: check /opt/stuff directories here?
|
||||
|
||||
# standard locations
|
||||
@ -28,7 +28,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
_add_directory(library_dirs, "/usr/local/lib")
|
||||
_add_directory(include_dirs, "/usr/local/include")
|
||||
|
||||
@@ -835,7 +835,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -841,7 +841,7 @@ class pil_build_ext(build_ext):
|
||||
if feature.xcb:
|
||||
libs.append(feature.xcb)
|
||||
defs.append(("HAVE_XCB", None))
|
||||
@ -37,7 +37,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
libs.extend(["kernel32", "user32", "gdi32"])
|
||||
if struct.unpack("h", b"\0\1")[0] == 1:
|
||||
defs.append(("WORDS_BIGENDIAN", None))
|
||||
@@ -857,6 +857,8 @@ class pil_build_ext(build_ext):
|
||||
@@ -863,6 +863,8 @@ class pil_build_ext(build_ext):
|
||||
if feature.freetype:
|
||||
srcs = []
|
||||
libs = ["freetype"]
|
||||
@ -46,7 +46,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
defs = []
|
||||
if feature.raqm:
|
||||
if not feature.want_vendor("raqm"): # using system Raqm
|
||||
@@ -879,7 +881,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -885,7 +887,7 @@ class pil_build_ext(build_ext):
|
||||
|
||||
if feature.lcms:
|
||||
extra = []
|
||||
@ -55,7 +55,7 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
extra.extend(["user32", "gdi32"])
|
||||
self._update_extension("PIL._imagingcms", [feature.lcms] + extra)
|
||||
else:
|
||||
@@ -898,7 +900,7 @@ class pil_build_ext(build_ext):
|
||||
@@ -904,7 +906,7 @@ class pil_build_ext(build_ext):
|
||||
else:
|
||||
self._remove_extension("PIL._webp")
|
||||
|
||||
@ -64,9 +64,9 @@ diff -rupN --no-dereference Pillow-9.1.1/setup.py Pillow-9.1.1-new/setup.py
|
||||
self._update_extension("PIL._imagingtk", tk_libs)
|
||||
|
||||
build_ext.build_extensions(self)
|
||||
diff -rupN --no-dereference Pillow-9.1.1/src/libImaging/ImPlatform.h Pillow-9.1.1-new/src/libImaging/ImPlatform.h
|
||||
--- Pillow-9.1.1/src/libImaging/ImPlatform.h 2022-05-17 12:33:52.000000000 +0200
|
||||
+++ Pillow-9.1.1-new/src/libImaging/ImPlatform.h 2022-05-20 23:52:00.468965741 +0200
|
||||
diff -rupN --no-dereference Pillow-9.2.0/src/libImaging/ImPlatform.h Pillow-9.2.0-new/src/libImaging/ImPlatform.h
|
||||
--- Pillow-9.2.0/src/libImaging/ImPlatform.h 2022-07-01 15:19:51.000000000 +0200
|
||||
+++ Pillow-9.2.0-new/src/libImaging/ImPlatform.h 2022-07-20 16:40:23.806366371 +0200
|
||||
@@ -28,7 +28,7 @@
|
||||
#if defined(_WIN32) || defined(__CYGWIN__)
|
||||
|
||||
|
2164
python-pillow-revert-furo-theme.patch
Normal file
2164
python-pillow-revert-furo-theme.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -11,8 +11,8 @@
|
||||
%endif
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 9.1.1
|
||||
Release: 4%{?dist}
|
||||
Version: 9.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Python image processing library
|
||||
|
||||
# License: see http://www.pythonware.com/products/pil/license.htm
|
||||
@ -26,6 +26,8 @@ Patch0: python-pillow_spinxwarn.patch
|
||||
Patch1: python-pillow_sphinx.patch
|
||||
# MinGW build fixes
|
||||
Patch2: pillow_mingw.patch
|
||||
# Revert back to using sphinx_rtd_theme
|
||||
Patch3: python-pillow-revert-furo-theme.patch
|
||||
|
||||
BuildRequires: freetype-devel
|
||||
BuildRequires: gcc
|
||||
@ -298,6 +300,9 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Jul 03 2022 Sandro Mani <manisandro@gmail.com> - 9.2.0-1
|
||||
- Update to 9.2.0
|
||||
|
||||
* Wed Jun 22 2022 Charalampos Stratakis <cstratak@redhat.com> - 9.1.1-4
|
||||
- Fix FTBFS with setuptools >= 62.1
|
||||
Resolves: rhbz#2097095
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -rupN --no-dereference Pillow-9.1.1/docs/conf.py Pillow-9.1.1-new/docs/conf.py
|
||||
--- Pillow-9.1.1/docs/conf.py 2022-05-17 12:33:52.000000000 +0200
|
||||
+++ Pillow-9.1.1-new/docs/conf.py 2022-05-20 23:52:00.377959658 +0200
|
||||
@@ -30,12 +30,10 @@ needs_sphinx = "2.4"
|
||||
diff -rupN --no-dereference Pillow-9.2.0/docs/conf.py Pillow-9.2.0-new/docs/conf.py
|
||||
--- Pillow-9.2.0/docs/conf.py 2022-07-01 15:19:51.000000000 +0200
|
||||
+++ Pillow-9.2.0-new/docs/conf.py 2022-07-20 16:40:23.626366367 +0200
|
||||
@@ -28,12 +28,10 @@ needs_sphinx = "2.4"
|
||||
# ones.
|
||||
extensions = [
|
||||
"sphinx_copybutton",
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -rupN --no-dereference Pillow-9.1.1/docs/Makefile Pillow-9.1.1-new/docs/Makefile
|
||||
--- Pillow-9.1.1/docs/Makefile 2022-05-17 12:33:52.000000000 +0200
|
||||
+++ Pillow-9.1.1-new/docs/Makefile 2022-05-20 23:52:00.287953642 +0200
|
||||
@@ -46,7 +46,7 @@ install-sphinx:
|
||||
diff -rupN --no-dereference Pillow-9.2.0/docs/Makefile Pillow-9.2.0-new/docs/Makefile
|
||||
--- Pillow-9.2.0/docs/Makefile 2022-07-01 15:19:51.000000000 +0200
|
||||
+++ Pillow-9.2.0-new/docs/Makefile 2022-07-20 16:40:23.456366364 +0200
|
||||
@@ -47,7 +47,7 @@ install-sphinx:
|
||||
|
||||
html:
|
||||
$(MAKE) install-sphinx
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (Pillow-9.1.1.tar.gz) = 8c05c0af6be992667d764046c6d7c189e1486d6ab987474c15e3bc8a64b9955d4c91d94b94ea46ef6d1c6f343ba424240dfa7d758c666bec40fa580728206a5f
|
||||
SHA512 (Pillow-9.2.0.tar.gz) = 02926d6c88aa8bc0df05b0ecd04b9852821a6400a24c6e70b66d4092eb3174139dee116adfa94ba8b7f3df8f6725cc68b32705f308f4347153e0112d987fc5f2
|
||||
|
Loading…
Reference in New Issue
Block a user