Update to 8.1.1

This commit is contained in:
Sandro Mani 2021-03-02 15:26:38 +01:00
parent 1b954dd159
commit 5b5d7558a6
6 changed files with 13 additions and 116 deletions

1
.gitignore vendored
View File

@ -53,3 +53,4 @@
/Pillow-8.0.0.tar.gz
/Pillow-8.0.1.tar.gz
/Pillow-8.1.0.tar.gz
/Pillow-8.1.1.tar.gz

View File

@ -1,104 +0,0 @@
From cf190a3c2f166cf0a7dd004fee4b242ea29bf1f4 Mon Sep 17 00:00:00 2001
From: Andrew Murray <radarhere@users.noreply.github.com>
Date: Sat, 9 Jan 2021 11:33:26 +1100
Subject: [PATCH 2/2] PyModule_AddObject fix for Python 3.10
---
src/_imaging.c | 21 +++++++++++++++------
src/_webp.c | 14 ++++++++++----
2 files changed, 25 insertions(+), 10 deletions(-)
diff --git a/src/_imaging.c b/src/_imaging.c
index a8741f6ad3..01dd22486e 100644
--- a/src/_imaging.c
+++ b/src/_imaging.c
@@ -4172,26 +4172,32 @@ setup_module(PyObject* m) {
}
#endif
+ PyObject *have_libjpegturbo;
#ifdef LIBJPEG_TURBO_VERSION
- PyModule_AddObject(m, "HAVE_LIBJPEGTURBO", Py_True);
+ have_libjpegturbo = Py_True;
#define tostr1(a) #a
#define tostr(a) tostr1(a)
PyDict_SetItemString(d, "libjpeg_turbo_version", PyUnicode_FromString(tostr(LIBJPEG_TURBO_VERSION)));
#undef tostr
#undef tostr1
#else
- PyModule_AddObject(m, "HAVE_LIBJPEGTURBO", Py_False);
-#endif
+ have_libjpegturbo = Py_False;
+ #endif
+ Py_INCREF(have_libjpegturbo);
+ PyModule_AddObject(m, "HAVE_LIBJPEGTURBO", have_libjpegturbo);
+ PyObject *have_libimagequant;
#ifdef HAVE_LIBIMAGEQUANT
- PyModule_AddObject(m, "HAVE_LIBIMAGEQUANT", Py_True);
+ have_libimagequant = Py_True;
{
extern const char* ImagingImageQuantVersion(void);
PyDict_SetItemString(d, "imagequant_version", PyUnicode_FromString(ImagingImageQuantVersion()));
}
#else
- PyModule_AddObject(m, "HAVE_LIBIMAGEQUANT", Py_False);
+ have_libimagequant = Py_False;
#endif
+ Py_INCREF(have_libimagequant);
+ PyModule_AddObject(m, "HAVE_LIBIMAGEQUANT", have_libimagequant);
#ifdef HAVE_LIBZ
/* zip encoding strategies */
@@ -4222,11 +4228,14 @@ setup_module(PyObject* m) {
}
#endif
+ PyObject *have_xcb;
#ifdef HAVE_XCB
- PyModule_AddObject(m, "HAVE_XCB", Py_True);
+ have_xcb = Py_True;
#else
- PyModule_AddObject(m, "HAVE_XCB", Py_False);
+ have_xcb = Py_False;
#endif
+ Py_INCREF(have_xcb);
+ PyModule_AddObject(m, "HAVE_XCB", have_xcb);
PyDict_SetItemString(d, "PILLOW_VERSION", PyUnicode_FromString(version));
diff --git a/src/_webp.c b/src/_webp.c
index c7875fa368..4d51d99dfa 100644
--- a/src/_webp.c
+++ b/src/_webp.c
@@ -861,19 +861,25 @@ static PyMethodDef webpMethods[] =
};
void addMuxFlagToModule(PyObject* m) {
+ PyObject *have_webpmux;
#ifdef HAVE_WEBPMUX
- PyModule_AddObject(m, "HAVE_WEBPMUX", Py_True);
+ have_webpmux = Py_True;
#else
- PyModule_AddObject(m, "HAVE_WEBPMUX", Py_False);
+ have_webpmux = Py_False;
#endif
+ Py_INCREF(have_webpmux);
+ PyModule_AddObject(m, "HAVE_WEBPMUX", have_webpmux);
}
void addAnimFlagToModule(PyObject* m) {
+ PyObject *have_webpanim;
#ifdef HAVE_WEBPANIM
- PyModule_AddObject(m, "HAVE_WEBPANIM", Py_True);
+ have_webpanim = Py_True;
#else
- PyModule_AddObject(m, "HAVE_WEBPANIM", Py_False);
+ have_webpanim = Py_False;
#endif
+ Py_INCREF(have_webpanim);
+ PyModule_AddObject(m, "HAVE_WEBPANIM", have_webpanim);
}
void addTransparencyFlagToModule(PyObject* m) {

View File

@ -7,8 +7,8 @@
%global with_docs 1
Name: python-%{srcname}
Version: 8.1.0
Release: 3%{?dist}
Version: 8.1.1
Release: 1%{?dist}
Summary: Python image processing library
# License: see http://www.pythonware.com/products/pil/license.htm
@ -20,9 +20,6 @@ Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillo
Patch0: python-pillow_spinxwarn.patch
# Drop sphinx-issues requirement, it's not packaged for Fedora
Patch1: python-pillow_sphinx-issues.patch
# PyModule_AddObject fix for Python 3.10
# https://github.com/python-pillow/Pillow/pull/5194
Patch2: 0001-PyModule_AddObject-fix-for-Python-3.10.patch
BuildRequires: freetype-devel
BuildRequires: gcc
@ -192,6 +189,9 @@ popd
%changelog
* Tue Mar 02 2021 Sandro Mani <manisandro@gmail.com> - 8.1.1-1
- Update to 8.1.1
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 8.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

View File

@ -1,6 +1,6 @@
diff -rupN Pillow-8.1.0/docs/conf.py Pillow-8.1.0-new/docs/conf.py
--- Pillow-8.1.0/docs/conf.py 2021-01-02 12:39:02.000000000 +0100
+++ Pillow-8.1.0-new/docs/conf.py 2021-01-03 11:03:45.488353823 +0100
diff -rupN --no-dereference Pillow-8.1.1/docs/conf.py Pillow-8.1.1-new/docs/conf.py
--- Pillow-8.1.1/docs/conf.py 2021-03-01 09:24:03.000000000 +0100
+++ Pillow-8.1.1-new/docs/conf.py 2021-03-02 15:10:49.599033773 +0100
@@ -32,7 +32,6 @@ extensions = [
"sphinx.ext.autodoc",
"sphinx.ext.intersphinx",

View File

@ -1,6 +1,6 @@
diff -rupN --no-dereference Pillow-8.1.0/docs/Makefile Pillow-8.1.0-new/docs/Makefile
--- Pillow-8.1.0/docs/Makefile 2021-01-02 12:39:02.000000000 +0100
+++ Pillow-8.1.0-new/docs/Makefile 2021-01-03 10:55:47.317076044 +0100
diff -rupN --no-dereference Pillow-8.1.1/docs/Makefile Pillow-8.1.1-new/docs/Makefile
--- Pillow-8.1.1/docs/Makefile 2021-03-01 09:24:03.000000000 +0100
+++ Pillow-8.1.1-new/docs/Makefile 2021-03-02 15:10:49.514033779 +0100
@@ -42,7 +42,7 @@ clean:
-rm -rf $(BUILDDIR)/*

View File

@ -1 +1 @@
SHA512 (Pillow-8.1.0.tar.gz) = 1014271d29e98c465e6882ed3f2f915f8955f5ada2a762c671a1f79389b25576ead2d144c6eaf42b4777f14438d15979d78d34dc32d984fd7defb53f0d209957
SHA512 (Pillow-8.1.1.tar.gz) = d04300442ac33e946bea186d6293516b615059b0f4b1b6ac7a48ce3a2e4e22bce5bc403331be697c022a4c81cb30f943cc33bfda649873c734af7db23afd6b69