Add ARM support

This commit is contained in:
Peter Robinson 2013-03-17 12:35:57 +00:00
parent 5a7afeafff
commit 1e23b47890
2 changed files with 13 additions and 5 deletions

View File

@ -1,10 +1,15 @@
diff -up python-imaging-Pillow-7866759/setup.py.archs python-imaging-Pillow-7866759/setup.py
--- python-imaging-Pillow-7866759/setup.py.archs 2013-03-12 13:33:42.992470031 +0100
+++ python-imaging-Pillow-7866759/setup.py 2013-03-12 14:25:25.558010720 +0100
@@ -137,6 +137,18 @@ class pil_build_ext(build_ext):
--- python-imaging-Pillow-7866759/setup.py.orig 2013-03-13 10:57:49.090756034 +0000
+++ python-imaging-Pillow-7866759/setup.py 2013-03-13 21:32:11.859488252 +0000
@@ -137,6 +137,24 @@
_add_directory(library_dirs, "/usr/lib/x86_64-linux-gnu")
elif platform_ in ["i386", "i686", "32bit"]:
_add_directory(library_dirs, "/usr/lib/i386-linux-gnu")
+ elif platform_ in ["aarch64", "64bit"]:
+ _add_directory(library_dirs, "/lib64")
+ _add_directory(library_dirs, "/usr/lib64")
+ _add_directory(library_dirs, "/usr/lib/aarch64-linux-gnu")
+ elif platform_ in ["arm", "armv7l", "32bit"]:
+ _add_directory(library_dirs, "/usr/lib/arm-linux-gnueabi")
+ elif platform_ in ["ppc64", "64bit"]:
+ _add_directory(library_dirs, "/lib64")
+ _add_directory(library_dirs, "/usr/lib64")

View File

@ -12,7 +12,7 @@
Name: python-pillow
Version: 1.7.8
Release: 5.20130305git%{shortcommit}%{?dist}
Release: 6.20130305git%{shortcommit}%{?dist}
Summary: Python 2 image processing library
# License: see http://www.pythonware.com/products/pil/license.htm
@ -299,6 +299,9 @@ popd
%endif
%changelog
* Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
- Add ARM support
* Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
- add s390* and ppc* to arch detection