Fix setup.py to not require python-unittest2 (retired in favor of stdlib module)
This commit is contained in:
parent
a71494c506
commit
e19254787a
11
python-oauthlib-dont-require-unittest2.patch
Normal file
11
python-oauthlib-dont-require-unittest2.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- setup.py.orig 2014-05-16 13:11:38.534023056 +0200
|
||||||
|
+++ setup.py 2014-05-16 13:11:48.046011144 +0200
|
||||||
|
@@ -19,7 +19,7 @@
|
||||||
|
if sys.version_info[0] == 3:
|
||||||
|
tests_require = ['nose', 'pycrypto']
|
||||||
|
else:
|
||||||
|
- tests_require = ['nose', 'unittest2', 'pycrypto', 'mock']
|
||||||
|
+ tests_require = ['nose', 'pycrypto', 'mock']
|
||||||
|
rsa_require = ['pycrypto']
|
||||||
|
|
||||||
|
requires = []
|
@ -20,6 +20,9 @@ Group: Development/Libraries
|
|||||||
License: BSD
|
License: BSD
|
||||||
URL: http://pypi.python.org/pypi/oauthlib
|
URL: http://pypi.python.org/pypi/oauthlib
|
||||||
Source0: http://pypi.python.org/packages/source/o/%{modname}/%{modname}-%{version}.tar.gz
|
Source0: http://pypi.python.org/packages/source/o/%{modname}/%{modname}-%{version}.tar.gz
|
||||||
|
# python-unittest2 is now provided by "python" package and python-unittest is retired
|
||||||
|
# adapt setup.py to reflect this fact downstream
|
||||||
|
Patch0: python-oauthlib-dont-require-unittest2.patch
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -74,6 +77,8 @@ very little effort.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{modname}-%{version}
|
%setup -q -n %{modname}-%{version}
|
||||||
|
|
||||||
|
%patch0 -p0
|
||||||
|
|
||||||
# Remove bundled egg-info in case it exists
|
# Remove bundled egg-info in case it exists
|
||||||
rm -rf %{modname}.egg-info
|
rm -rf %{modname}.egg-info
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user