Latest upstream.
This commit is contained in:
parent
22c7d90bb7
commit
4e63a2da2c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/oauthlib-0.6.0.tar.gz
|
/oauthlib-0.6.0.tar.gz
|
||||||
|
/oauthlib-514cad74bde4cd7781b496155058a79507245798.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- setup.py.orig 2014-05-16 13:11:38.534023056 +0200
|
|
||||||
+++ setup.py 2014-05-16 13:11:48.046011144 +0200
|
|
||||||
@@ -19,7 +19,7 @@
|
|
||||||
if sys.version_info[0] == 3:
|
|
||||||
tests_require = ['nose', 'pycrypto']
|
|
||||||
else:
|
|
||||||
- tests_require = ['nose', 'unittest2', 'pycrypto', 'mock']
|
|
||||||
+ tests_require = ['nose', 'pycrypto', 'mock']
|
|
||||||
rsa_require = ['pycrypto']
|
|
||||||
|
|
||||||
requires = []
|
|
@ -8,21 +8,25 @@
|
|||||||
%{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
%{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%global commit 514cad74bde4cd7781b496155058a79507245798
|
||||||
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
|
%global checkout 20150520git%{shortcommit}
|
||||||
|
|
||||||
|
%global gh_owner idan
|
||||||
|
%global gh_project oauthlib
|
||||||
|
|
||||||
%global modname oauthlib
|
%global modname oauthlib
|
||||||
|
|
||||||
Name: python-oauthlib
|
Name: python-oauthlib
|
||||||
Version: 0.6.0
|
Version: 0.7.2
|
||||||
Release: 6%{?dist}
|
Release: 2.%{checkout}%{?dist}
|
||||||
Summary: An implementation of the OAuth request-signing logic
|
Summary: An implementation of the OAuth request-signing logic
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://pypi.python.org/pypi/oauthlib
|
URL: http://pypi.python.org/pypi/oauthlib
|
||||||
Source0: http://pypi.python.org/packages/source/o/%{modname}/%{modname}-%{version}.tar.gz
|
#Source0: http://pypi.python.org/packages/source/o/%{modname}/%{modname}-%{version}.tar.gz
|
||||||
# python-unittest2 is now provided by "python" package and python-unittest is retired
|
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{commit}/%{gh_project}-%{commit}.tar.gz
|
||||||
# adapt setup.py to reflect this fact downstream
|
|
||||||
Patch0: python-oauthlib-dont-require-unittest2.patch
|
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -32,6 +36,8 @@ BuildRequires: python-setuptools
|
|||||||
BuildRequires: python-nose
|
BuildRequires: python-nose
|
||||||
BuildRequires: python-unittest2
|
BuildRequires: python-unittest2
|
||||||
BuildRequires: python-mock
|
BuildRequires: python-mock
|
||||||
|
BuildRequires: python-blinker
|
||||||
|
BuildRequires: python-jwt >= 1.0
|
||||||
|
|
||||||
%if 0%{?rhel} && 0%{?rhel} <= 6
|
%if 0%{?rhel} && 0%{?rhel} <= 6
|
||||||
BuildRequires: python-crypto2.6
|
BuildRequires: python-crypto2.6
|
||||||
@ -48,6 +54,8 @@ BuildRequires: python3-setuptools
|
|||||||
BuildRequires: python3-nose
|
BuildRequires: python3-nose
|
||||||
BuildRequires: python3-crypto >= 2.6
|
BuildRequires: python3-crypto >= 2.6
|
||||||
BuildRequires: python3-mock
|
BuildRequires: python3-mock
|
||||||
|
BuildRequires: python3-blinker
|
||||||
|
BuildRequires: python3-jwt >= 1.0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -75,9 +83,12 @@ very little effort.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{modname}-%{version}
|
#%%setup -q -n %{modname}-%{version}
|
||||||
|
%setup -q -n %{gh_project}-%{commit}
|
||||||
|
|
||||||
%patch0 -p0
|
# python-unittest2 is now provided by "python" package and python-unittest is retired
|
||||||
|
# adapt setup.py to reflect this fact downstream
|
||||||
|
sed -i "s/'unittest2', //" setup.py
|
||||||
|
|
||||||
# Remove bundled egg-info in case it exists
|
# Remove bundled egg-info in case it exists
|
||||||
rm -rf %{modname}.egg-info
|
rm -rf %{modname}.egg-info
|
||||||
@ -129,6 +140,10 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 0.7.2-2.20150520git514cad7
|
||||||
|
- new version, from a git checkout
|
||||||
|
- Replace our patch with a sed statement.
|
||||||
|
|
||||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-6
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user