Fix shebang mangling for python3 (RHBZ#1546800)
This commit is contained in:
parent
beb63a2a3f
commit
60759c9b58
29
0001-Do-not-override-executable-path.patch
Normal file
29
0001-Do-not-override-executable-path.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 8b08c463a49bdcca455cdfbefa971c89bd309ddf Mon Sep 17 00:00:00 2001
|
||||||
|
From: John Eckersberg <jeckersb@redhat.com>
|
||||||
|
Date: Mon, 19 Feb 2018 15:20:54 -0500
|
||||||
|
Subject: [PATCH] Do not override executable path
|
||||||
|
|
||||||
|
Resolves: RHBZ#1546800
|
||||||
|
---
|
||||||
|
setup.py | 5 -----
|
||||||
|
1 file changed, 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index 2bd2a08..4cd2780 100644
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -177,11 +177,6 @@ def main():
|
||||||
|
scripts=['netaddr/tools/netaddr'],
|
||||||
|
url='https://github.com/drkjam/netaddr/',
|
||||||
|
version=netaddr.__version__,
|
||||||
|
- options={
|
||||||
|
- 'build_scripts': {
|
||||||
|
- 'executable': '/usr/bin/env python',
|
||||||
|
- },
|
||||||
|
- },
|
||||||
|
)
|
||||||
|
|
||||||
|
setup(**setup_options)
|
||||||
|
--
|
||||||
|
2.14.3
|
||||||
|
|
@ -4,7 +4,7 @@
|
|||||||
|
|
||||||
Name: python-netaddr
|
Name: python-netaddr
|
||||||
Version: 0.7.19
|
Version: 0.7.19
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
Summary: A pure Python network address representation and manipulation library
|
Summary: A pure Python network address representation and manipulation library
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -18,6 +18,7 @@ BuildRequires: python-sphinx
|
|||||||
BuildRequires: pytest
|
BuildRequires: pytest
|
||||||
|
|
||||||
Patch0: 0001-fixed-broken-tests-in-issue-149-python-3-regression-.patch
|
Patch0: 0001-fixed-broken-tests-in-issue-149-python-3-regression-.patch
|
||||||
|
Patch1: 0001-Do-not-override-executable-path.patch
|
||||||
|
|
||||||
%global desc A network address manipulation library for Python\
|
%global desc A network address manipulation library for Python\
|
||||||
\
|
\
|
||||||
@ -67,6 +68,7 @@ BuildRequires: python3-pytest
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n netaddr-%{version}
|
%setup -q -n netaddr-%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
# Make rpmlint happy, get rid of DOS line endings
|
# Make rpmlint happy, get rid of DOS line endings
|
||||||
sed -i 's/\r//' netaddr/*.py netaddr/ip/*.py netaddr/eui/*.idx
|
sed -i 's/\r//' netaddr/*.py netaddr/ip/*.py netaddr/eui/*.idx
|
||||||
@ -129,6 +131,9 @@ LANG=en_US.UTF-8 py.test-%{python3_version}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 19 2018 John Eckersberg <eck@redhat.com> - 0.7.19-7
|
||||||
|
- Fix shebang mangling for python3 (RHBZ#1546800)
|
||||||
|
|
||||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.19-6
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.19-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user