Update to 3.4.2
Resolves: rhbz#2104650
This commit is contained in:
parent
5725872a85
commit
c883b3122c
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ python-ldap-2.3.10.tar.gz
|
|||||||
/python-ldap-3.1.0.tar.gz
|
/python-ldap-3.1.0.tar.gz
|
||||||
/python-ldap-3.3.1.tar.gz
|
/python-ldap-3.3.1.tar.gz
|
||||||
/python-ldap-3.4.0.tar.gz
|
/python-ldap-3.4.0.tar.gz
|
||||||
|
/python-ldap-3.4.2.tar.gz
|
||||||
|
@ -1,34 +0,0 @@
|
|||||||
From 536a7671151e3070481736e5d6159987df920d8b Mon Sep 17 00:00:00 2001
|
|
||||||
From: Simon Pichugin <spichugi@redhat.com>
|
|
||||||
Date: Wed, 9 Feb 2022 16:06:14 -0800
|
|
||||||
Subject: [PATCH] Always use 'ldap' library
|
|
||||||
|
|
||||||
---
|
|
||||||
setup.py | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/setup.py b/setup.py
|
|
||||||
index 119b571..851223e 100644
|
|
||||||
--- a/setup.py
|
|
||||||
+++ b/setup.py
|
|
||||||
@@ -37,6 +37,8 @@ if cfg.has_section('_ldap'):
|
|
||||||
for name in dir(LDAP_CLASS):
|
|
||||||
if cfg.has_option('_ldap', name):
|
|
||||||
setattr(LDAP_CLASS, name, cfg.get('_ldap', name).split())
|
|
||||||
+#-- Overwrite it as 'ldap' is the always correct library we have in Fedora 34+
|
|
||||||
+LDAP_CLASS.libs = ['ldap', 'lber']
|
|
||||||
|
|
||||||
for i in range(len(LDAP_CLASS.defines)):
|
|
||||||
LDAP_CLASS.defines[i]=((LDAP_CLASS.defines[i],None))
|
|
||||||
@@ -132,7 +134,7 @@ setup(
|
|
||||||
extra_objects = LDAP_CLASS.extra_objects,
|
|
||||||
runtime_library_dirs = (not sys.platform.startswith("win"))*LDAP_CLASS.library_dirs,
|
|
||||||
define_macros = LDAP_CLASS.defines + \
|
|
||||||
- ('ldap_r' in LDAP_CLASS.libs or 'oldap_r' in LDAP_CLASS.libs)*[('HAVE_LIBLDAP_R',None)] + \
|
|
||||||
+ ('ldap' in LDAP_CLASS.libs or 'oldap' in LDAP_CLASS.libs)*[('HAVE_LIBLDAP_R',None)] + \
|
|
||||||
('sasl' in LDAP_CLASS.libs or 'sasl2' in LDAP_CLASS.libs or 'libsasl' in LDAP_CLASS.libs)*[('HAVE_SASL',None)] + \
|
|
||||||
('ssl' in LDAP_CLASS.libs and 'crypto' in LDAP_CLASS.libs)*[('HAVE_TLS',None)] + \
|
|
||||||
[
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
@ -5,13 +5,12 @@
|
|||||||
%global pypi_name python-ldap
|
%global pypi_name python-ldap
|
||||||
|
|
||||||
Name: python-ldap
|
Name: python-ldap
|
||||||
Version: 3.4.0
|
Version: 3.4.2
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
License: Python
|
License: Python
|
||||||
Summary: An object-oriented API to access LDAP directory servers
|
Summary: An object-oriented API to access LDAP directory servers
|
||||||
URL: https://python-ldap.org/
|
URL: https://python-ldap.org/
|
||||||
Source0: %{pypi_source}
|
Source0: %{pypi_source}
|
||||||
Patch0: python-ldap-always-use-ldap-library.patch
|
|
||||||
|
|
||||||
|
|
||||||
### Build Dependencies ###
|
### Build Dependencies ###
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (python-ldap-3.4.0.tar.gz) = d10c10f1d416a0f67e7669c6c0b5460a3484bc31f4af471d581a9207689e5687c08d1ad78ba8d47e0ce0c35d24d79e4b848b4c503534f211a36c1b882bee3605
|
SHA512 (python-ldap-3.4.2.tar.gz) = 59eae835cd0e337c5f7d237ab40cefb374b780fb1c8ef8fbd39fb5aea63c6cab10e7efebc2013eebc05a3146bf5300616536cf7fedfa157b38fc6e4b923cbb1e
|
||||||
|
Loading…
Reference in New Issue
Block a user