import python-kdcproxy-1.0.0-7.el9
This commit is contained in:
commit
14472b464a
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/kdcproxy-1.0.0.tar.gz
|
1
.python-kdcproxy.metadata
Normal file
1
.python-kdcproxy.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
4b2da76684ff66ad28d5d5104a23a41d5413cc11 SOURCES/kdcproxy-1.0.0.tar.gz
|
100
SOURCES/Drop-coverage-from-tests.patch
Normal file
100
SOURCES/Drop-coverage-from-tests.patch
Normal file
@ -0,0 +1,100 @@
|
|||||||
|
From 7b7aee01d72be5a310678cdad189cb7382f28549 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Robbie Harwood <rharwood@redhat.com>
|
||||||
|
Date: Tue, 19 Jan 2021 11:41:40 -0500
|
||||||
|
Subject: [PATCH] Drop coverage from tests
|
||||||
|
|
||||||
|
To my knowledge, we've never looked at or done anything with this
|
||||||
|
output. Test coverage is a noble goal, but this project is mostly
|
||||||
|
complete, so we don't expect heavy development soon.
|
||||||
|
|
||||||
|
Requested-by: Petr Viktorin <pviktori@redhat.com>
|
||||||
|
Signed-off-by: Robbie Harwood <rharwood@redhat.com>
|
||||||
|
(cherry picked from commit 86c3da13d5d6cdb5822d194f2b820da1fd31dddb)
|
||||||
|
[rharwood@redhat.com: .gitignore]
|
||||||
|
---
|
||||||
|
.coveragerc | 23 -----------------------
|
||||||
|
MANIFEST.in | 1 -
|
||||||
|
setup.py | 2 +-
|
||||||
|
tox.ini | 12 ++----------
|
||||||
|
4 files changed, 3 insertions(+), 35 deletions(-)
|
||||||
|
delete mode 100644 .coveragerc
|
||||||
|
|
||||||
|
diff --git a/.coveragerc b/.coveragerc
|
||||||
|
deleted file mode 100644
|
||||||
|
index 4038562..0000000
|
||||||
|
--- a/.coveragerc
|
||||||
|
+++ /dev/null
|
||||||
|
@@ -1,23 +0,0 @@
|
||||||
|
-[run]
|
||||||
|
-branch = True
|
||||||
|
-source =
|
||||||
|
- kdcproxy
|
||||||
|
- tests.py
|
||||||
|
-
|
||||||
|
-[paths]
|
||||||
|
-source =
|
||||||
|
- kdcproxy
|
||||||
|
- .tox/*/lib/python*/site-packages/kdcproxy
|
||||||
|
-
|
||||||
|
-[report]
|
||||||
|
-ignore_errors = False
|
||||||
|
-precision = 1
|
||||||
|
-exclude_lines =
|
||||||
|
- pragma: no cover
|
||||||
|
- raise AssertionError
|
||||||
|
- raise NotImplementedError
|
||||||
|
- if 0:
|
||||||
|
- if False:
|
||||||
|
- if __name__ == .__main__.:
|
||||||
|
- if PY3
|
||||||
|
- if not PY3
|
||||||
|
diff --git a/MANIFEST.in b/MANIFEST.in
|
||||||
|
index 362f840..ff6b9a7 100644
|
||||||
|
--- a/MANIFEST.in
|
||||||
|
+++ b/MANIFEST.in
|
||||||
|
@@ -2,4 +2,3 @@ include README COPYING
|
||||||
|
include tox.ini
|
||||||
|
include setup.cfg
|
||||||
|
include tests.py tests.krb5.conf
|
||||||
|
-include .coveragerc
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index 20b335e..4b34fcc 100644
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -29,7 +29,7 @@ install_requires = [
|
||||||
|
]
|
||||||
|
|
||||||
|
extras_require = {
|
||||||
|
- "tests": ["pytest", "coverage", "WebTest"],
|
||||||
|
+ "tests": ["pytest", "WebTest"],
|
||||||
|
"test_pep8": ['flake8', 'flake8-import-order', 'pep8-naming']
|
||||||
|
}
|
||||||
|
|
||||||
|
diff --git a/tox.ini b/tox.ini
|
||||||
|
index 038d996..9672cee 100644
|
||||||
|
--- a/tox.ini
|
||||||
|
+++ b/tox.ini
|
||||||
|
@@ -1,21 +1,13 @@
|
||||||
|
[tox]
|
||||||
|
minversion = 2.3.1
|
||||||
|
-envlist = py36,py37,py38,py39,pep8,py3pep8,doc,coverage-report
|
||||||
|
+envlist = py36,py37,py38,py39,pep8,py3pep8,doc
|
||||||
|
skip_missing_interpreters = true
|
||||||
|
|
||||||
|
[testenv]
|
||||||
|
deps =
|
||||||
|
.[tests]
|
||||||
|
commands =
|
||||||
|
- {envpython} -m coverage run --parallel \
|
||||||
|
- -m pytest --capture=no --strict {posargs}
|
||||||
|
-
|
||||||
|
-[testenv:coverage-report]
|
||||||
|
-deps = coverage
|
||||||
|
-skip_install = true
|
||||||
|
-commands =
|
||||||
|
- {envpython} -m coverage combine
|
||||||
|
- {envpython} -m coverage report --show-missing
|
||||||
|
+ {envpython} -m pytest --capture=no --strict {posargs}
|
||||||
|
|
||||||
|
[testenv:pep8]
|
||||||
|
basepython = python3
|
193
SPECS/python-kdcproxy.spec
Normal file
193
SPECS/python-kdcproxy.spec
Normal file
@ -0,0 +1,193 @@
|
|||||||
|
%global realname kdcproxy
|
||||||
|
|
||||||
|
Name: python-%{realname}
|
||||||
|
Version: 1.0.0
|
||||||
|
Release: 7%{?dist}
|
||||||
|
Summary: MS-KKDCP (kerberos proxy) WSGI module
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://github.com/latchset/%{realname}
|
||||||
|
Source0: https://github.com/latchset/%{realname}/archive/%{realname}-%{version}.tar.gz
|
||||||
|
|
||||||
|
Patch0: Drop-coverage-from-tests.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRequires: git
|
||||||
|
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: python3-dns
|
||||||
|
BuildRequires: python3-pyasn1
|
||||||
|
BuildRequires: python3-pytest
|
||||||
|
BuildRequires: python3-setuptools
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package contains a Python WSGI module for proxying KDC requests over
|
||||||
|
HTTP by following the MS-KKDCP protocol. It aims to be simple to deploy, with
|
||||||
|
minimal configuration.
|
||||||
|
|
||||||
|
%package -n python3-%{realname}
|
||||||
|
Summary: MS-KKDCP (kerberos proxy) WSGI module
|
||||||
|
Requires: python3-dns
|
||||||
|
Requires: python3-pyasn1
|
||||||
|
|
||||||
|
%{?python_provide:%python_provide python3-%{realname}}
|
||||||
|
|
||||||
|
%description -n python3-%{realname}
|
||||||
|
This package contains a Python 3.x WSGI module for proxying KDC requests over
|
||||||
|
HTTP by following the MS-KKDCP protocol. It aims to be simple to deploy, with
|
||||||
|
minimal configuration.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -S git -n %{realname}-%{version}
|
||||||
|
|
||||||
|
%build
|
||||||
|
%py3_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%py3_install
|
||||||
|
|
||||||
|
%check
|
||||||
|
%{__python3} -m pytest
|
||||||
|
|
||||||
|
%files -n python3-%{realname}
|
||||||
|
%doc README
|
||||||
|
%license COPYING
|
||||||
|
%{python3_sitelib}/%{realname}/
|
||||||
|
%{python3_sitelib}/%{realname}-%{version}-*.egg-info
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1.0.0-7
|
||||||
|
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||||
|
Related: rhbz#1991688
|
||||||
|
|
||||||
|
* Mon Apr 19 2021 Robbie Harwood <rharwood@redhat.com> - 1.0.0-6
|
||||||
|
- Actually drop coverage dependency
|
||||||
|
- Resolves: #1916739
|
||||||
|
|
||||||
|
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.0.0-5
|
||||||
|
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||||
|
|
||||||
|
* Fri Jan 29 2021 Robbie Harwood <rharwood@redhat.com> - 1.0.0-4
|
||||||
|
- Drop unused dependency on python3-mock
|
||||||
|
- Resolves: #1922344
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 20 2021 Robbie Harwood <rharwood@redhat.com> - 1.0.0-2
|
||||||
|
- Drop coverage from tests
|
||||||
|
- Resolves: #1916739
|
||||||
|
|
||||||
|
* Tue Dec 08 2020 Robbie Harwood <rharwood@redhat.com> - 1.0.0-1
|
||||||
|
- New upstream version (1.0.0)
|
||||||
|
- Drop asn1crypto in favor of pyasn1
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jun 25 2020 Robbie Harwood <rharwood@redhat.com> - 0.4.2-5
|
||||||
|
- Explicitly depend on python3-setuptools
|
||||||
|
|
||||||
|
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 0.4.2-4
|
||||||
|
- Rebuilt for Python 3.9
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.2-2
|
||||||
|
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||||
|
|
||||||
|
* Thu Aug 29 2019 Robbie Harwood <rharwood@redhat.com> - 0.4.2-1
|
||||||
|
- New upstream version (0.4.2)
|
||||||
|
|
||||||
|
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.4.1-3
|
||||||
|
- Rebuilt for Python 3.8
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 11 2019 Robbie Harwood <rharwood@redhdat.com> 0.4.1-1
|
||||||
|
- New upstream release - 0.4.1
|
||||||
|
- Fixes build with rawhide (dnspython/dnspython3)
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Sep 17 2018 Robbie Harwood <rharwood@redhat.com> - 0.4-3
|
||||||
|
- Drop python2 subpackage
|
||||||
|
- Resolves: #1629775
|
||||||
|
|
||||||
|
* Thu Aug 09 2018 Robbie Harwood <rharwood@redhat.com> - 0.4-2
|
||||||
|
- Update dependencies in test suite
|
||||||
|
|
||||||
|
* Thu Aug 09 2018 Robbie Harwood <rharwood@redhat.com> - 0.4-1
|
||||||
|
- New upstream release - 0.4
|
||||||
|
- Port to autosetup
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.3.2-13
|
||||||
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
* Thu Mar 22 2018 Troy Dawson <tdawson@redhat.com> - 0.3.2-12
|
||||||
|
- Update conditionals.
|
||||||
|
- Make preperations for non-python2 builds
|
||||||
|
|
||||||
|
* Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.3.2-11
|
||||||
|
- Update Python 2 dependency declarations to new packaging standards
|
||||||
|
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-10
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Sep 05 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.3.2-9
|
||||||
|
- Ignore test results
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jan 16 2017 Charalampos Stratakis <cstratak@redhat.com> - 0.3.2-6
|
||||||
|
- Fix failing tests
|
||||||
|
- Modernize the SPEC file
|
||||||
|
|
||||||
|
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.3.2-5
|
||||||
|
- Rebuild for Python 3.6
|
||||||
|
- BR /usr/bin/tox instead of python-tox
|
||||||
|
- Use %%{python3_version_nodots} instead of hardcoded 35
|
||||||
|
|
||||||
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-4
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||||
|
|
||||||
|
* Mon Aug 03 2015 Nathaniel McCallum <npmccallum@fedoraproject.org> - 0.3.2-1
|
||||||
|
- Update to 0.3.2
|
||||||
|
- Fixes CVE-2015-5159
|
||||||
|
|
||||||
|
* Wed Jul 22 2015 Nathaniel McCallum <npmccallum@fedoraproject.org> - 0.3.1-1
|
||||||
|
- Update to 0.3.1
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 10 2015 Nathaniel McCallum <npmccallum@fedoraproject.org> - 0.3-1
|
||||||
|
- Update to 0.3
|
||||||
|
- Run tests in Fedora (not RHEL due to python-tox)
|
||||||
|
|
||||||
|
* Fri Oct 24 2014 Nathaniel McCallum <npmccallum@fedoraproject.org> - 0.2.1-1
|
||||||
|
- Update to 0.2.1
|
||||||
|
|
||||||
|
* Thu Oct 23 2014 Nathaniel McCallum <npmccallum@fedoraproject.org> - 0.2-1
|
||||||
|
- Update to 0.2
|
||||||
|
- Fix EPEL7 build
|
||||||
|
|
||||||
|
* Tue Jan 21 2014 Nathaniel McCallum <npmccallum@fedoraproject.org> - 0.1.1-1
|
||||||
|
- Initial package
|
Loading…
Reference in New Issue
Block a user