Update to 1.5.0. Fixes bug #1443792
This commit is contained in:
parent
07454907d7
commit
dc50678922
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
||||
/PyJWT-1.3.0.tar.gz
|
||||
/PyJWT-1.4.0.tar.gz
|
||||
/PyJWT-1.4.2.tar.gz
|
||||
/1.5.0.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -Nur PyJWT-1.4.2.orig/setup.py PyJWT-1.4.2/setup.py
|
||||
--- PyJWT-1.4.2.orig/setup.py 2016-06-29 22:07:44.000000000 -0600
|
||||
+++ PyJWT-1.4.2/setup.py 2017-04-17 09:05:19.783324336 -0600
|
||||
@@ -30,7 +30,7 @@
|
||||
sys.exit()
|
||||
|
||||
tests_require = [
|
||||
- 'pytest==2.7.3',
|
||||
+ 'pytest',
|
||||
'pytest-cov',
|
||||
'pytest-runner',
|
||||
]
|
@ -6,19 +6,14 @@
|
||||
%global sum JSON Web Token implementation in Python
|
||||
|
||||
Name: python-jwt
|
||||
Version: 1.4.2
|
||||
Release: 4%{?dist}
|
||||
Version: 1.5.0
|
||||
Release: 1%{?dist}
|
||||
Summary: %{sum}
|
||||
|
||||
Group: Development/Libraries
|
||||
License: MIT
|
||||
URL: http://pypi.python.org/pypi/pyjwt
|
||||
Source0: https://pypi.python.org/packages/source/P/PyJWT/PyJWT-%{version}.tar.gz
|
||||
#
|
||||
# Upstream hard coded a specific version of pytest to avoid a bug
|
||||
# However, that bug is long since fixed upstream
|
||||
#
|
||||
Patch0: allow-newer-pytest.patch
|
||||
Source0: https://github.com/jpadilla/pyjwt/archive/%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
@ -70,7 +65,7 @@ encrypted JSON objects.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -n PyJWT-%{version}
|
||||
%autosetup -n pyjwt-%{version}
|
||||
|
||||
%build
|
||||
%py2_build
|
||||
@ -91,21 +86,24 @@ encrypted JSON objects.
|
||||
%endif
|
||||
|
||||
%files -n python2-jwt
|
||||
%doc README.md AUTHORS
|
||||
%doc README.rst AUTHORS
|
||||
%license LICENSE
|
||||
%{python2_sitelib}/%{srcname}/
|
||||
%{python2_sitelib}/PyJWT-%{version}*
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%files -n python3-jwt
|
||||
%doc README.md AUTHORS
|
||||
%doc README.rst AUTHORS
|
||||
%license LICENSE
|
||||
%{python3_sitelib}/%{srcname}/
|
||||
%{python3_sitelib}/PyJWT-%{version}*
|
||||
%{_bindir}/jwt
|
||||
%{_bindir}/pyjwt
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat May 27 2017 Kevin Fenzi <kevin@scrye.com> - 1.5.0-1
|
||||
- Update to 1.5.0. Fixes bug #1443792
|
||||
|
||||
* Mon Apr 17 2017 Kevin Fenzi <kevin@scrye.com> - 1.4.2-4
|
||||
- Modernize spec and make sure to provide python2-jwt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user