Import rpm: 7e9da63ebb7c845f703e2c5e55015555019e41d3
This commit is contained in:
commit
b17ecf36bd
1
.fmf/version
Normal file
1
.fmf/version
Normal file
@ -0,0 +1 @@
|
|||||||
|
1
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/Jinja2-2.10.tar.gz
|
@ -0,0 +1,27 @@
|
|||||||
|
From 9a99db929323f60553b391c80d0395821121d593 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Thomas Moschny <thomas.moschny@gmx.de>
|
||||||
|
Date: Tue, 19 Jan 2021 21:01:18 +0100
|
||||||
|
Subject: [PATCH] add 'linetable' to the preserved CodeType attributes (#1334)
|
||||||
|
|
||||||
|
add 'linetable' to the preserved CodeType attributes
|
||||||
|
|
||||||
|
co_linetable replaces co_lnotab as part of PEP 626 in Python 3.10.
|
||||||
|
---
|
||||||
|
src/jinja2/debug.py | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/jinja2/debug.py b/src/jinja2/debug.py
|
||||||
|
index 5d8aec3..e256617 100644
|
||||||
|
--- a/src/jinja2/debug.py
|
||||||
|
+++ b/src/jinja2/debug.py
|
||||||
|
@@ -137,6 +137,7 @@ def fake_traceback(exc_value, tb, filename, lineno):
|
||||||
|
"lnotab",
|
||||||
|
"freevars",
|
||||||
|
"cellvars",
|
||||||
|
+ "linetable", # Python 3.10
|
||||||
|
):
|
||||||
|
if isinstance(attr, tuple):
|
||||||
|
# Replace with given value.
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
49
0002-native_concat-pass-only-strings-to-literal_eval.patch
Normal file
49
0002-native_concat-pass-only-strings-to-literal_eval.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
From 58250a709532ccb3e6d92ca65b3d305d1464cb68 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Martin Krizek <martin.krizek@gmail.com>
|
||||||
|
Date: Thu, 28 Jan 2021 10:08:50 +0100
|
||||||
|
Subject: [PATCH] native_concat: pass only strings to literal_eval
|
||||||
|
|
||||||
|
If there is only single node and it is not a string, there is no point
|
||||||
|
in passing it into ``literal_eval``, just return it immediately.
|
||||||
|
|
||||||
|
One of the examples where passing a non-string node into
|
||||||
|
``literal_eval`` would actually cause problems is when the node is
|
||||||
|
``Undefined``. On Python 3.10 this would cause ``UndefinedError``
|
||||||
|
instead of just ``Undefined`` being returned.
|
||||||
|
|
||||||
|
Fixes #1335
|
||||||
|
---
|
||||||
|
CHANGES.rst | 3 +++
|
||||||
|
src/jinja2/nativetypes.py | 2 ++
|
||||||
|
2 files changed, 5 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/CHANGES.rst b/CHANGES.rst
|
||||||
|
index 511b22b..a8a66ea 100644
|
||||||
|
--- a/CHANGES.rst
|
||||||
|
+++ b/CHANGES.rst
|
||||||
|
@@ -8,6 +8,9 @@ Released 2021-01-31
|
||||||
|
- Improve the speed of the ``urlize`` filter by reducing regex
|
||||||
|
backtracking. Email matching requires a word character at the start
|
||||||
|
of the domain part, and only word characters in the TLD. :pr:`1343`
|
||||||
|
+- Fix UndefinedError incorrectly being thrown on an undefined variable
|
||||||
|
+ instead of ``Undefined`` being returned on
|
||||||
|
+ ``NativeEnvironment`` on Python 3.10. :issue:`1335`
|
||||||
|
|
||||||
|
|
||||||
|
Version 2.11.2
|
||||||
|
diff --git a/src/jinja2/nativetypes.py b/src/jinja2/nativetypes.py
|
||||||
|
index a9ead4e..2fee17f 100644
|
||||||
|
--- a/src/jinja2/nativetypes.py
|
||||||
|
+++ b/src/jinja2/nativetypes.py
|
||||||
|
@@ -26,6 +26,8 @@ def native_concat(nodes):
|
||||||
|
|
||||||
|
if len(head) == 1:
|
||||||
|
raw = head[0]
|
||||||
|
+ if not isinstance(raw, str):
|
||||||
|
+ return raw
|
||||||
|
else:
|
||||||
|
raw = u"".join([text_type(v) for v in chain(head, nodes)])
|
||||||
|
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
133
CVE-2020-28493.patch
Normal file
133
CVE-2020-28493.patch
Normal file
@ -0,0 +1,133 @@
|
|||||||
|
From 2b76a5a3aa898fd1621c72c6da935cddfb484424 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lumir Balhar <lbalhar@redhat.com>
|
||||||
|
Date: Fri, 12 Mar 2021 14:34:06 +0100
|
||||||
|
Subject: [PATCH] CVE-2020-28493
|
||||||
|
|
||||||
|
---
|
||||||
|
Jinja2-2.10.1/jinja2/utils.py | 94 +++++++++++++++++++++--------------
|
||||||
|
1 file changed, 56 insertions(+), 38 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Jinja2-2.10.1/jinja2/utils.py b/Jinja2-2.10.1/jinja2/utils.py
|
||||||
|
index 502a311..25dd78f 100644
|
||||||
|
--- a/Jinja2-2.10/jinja2/utils.py
|
||||||
|
+++ b/Jinja2-2.10/jinja2/utils.py
|
||||||
|
@@ -12,24 +12,12 @@ import re
|
||||||
|
import json
|
||||||
|
import errno
|
||||||
|
from collections import deque
|
||||||
|
+from string import ascii_letters as _letters
|
||||||
|
+from string import digits as _digits
|
||||||
|
from threading import Lock
|
||||||
|
from jinja2._compat import text_type, string_types, implements_iterator, \
|
||||||
|
url_quote
|
||||||
|
|
||||||
|
-
|
||||||
|
-_word_split_re = re.compile(r'(\s+)')
|
||||||
|
-_punctuation_re = re.compile(
|
||||||
|
- '^(?P<lead>(?:%s)*)(?P<middle>.*?)(?P<trail>(?:%s)*)$' % (
|
||||||
|
- '|'.join(map(re.escape, ('(', '<', '<'))),
|
||||||
|
- '|'.join(map(re.escape, ('.', ',', ')', '>', '\n', '>')))
|
||||||
|
- )
|
||||||
|
-)
|
||||||
|
-_simple_email_re = re.compile(r'^\S+@[a-zA-Z0-9._-]+\.[a-zA-Z0-9._-]+$')
|
||||||
|
-_striptags_re = re.compile(r'(<!--.*?-->|<[^>]*>)')
|
||||||
|
-_entity_re = re.compile(r'&([^;]+);')
|
||||||
|
-_letters = 'abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ'
|
||||||
|
-_digits = '0123456789'
|
||||||
|
-
|
||||||
|
# special singleton representing missing values for the runtime
|
||||||
|
missing = type('MissingType', (), {'__repr__': lambda x: 'missing'})()
|
||||||
|
|
||||||
|
@@ -203,35 +191,65 @@ def urlize(text, trim_url_limit=None, rel=None, target=None):
|
||||||
|
trim_url = lambda x, limit=trim_url_limit: limit is not None \
|
||||||
|
and (x[:limit] + (len(x) >=limit and '...'
|
||||||
|
or '')) or x
|
||||||
|
- words = _word_split_re.split(text_type(escape(text)))
|
||||||
|
+ words = re.split(r"(\s+)", text_type(escape(text)))
|
||||||
|
rel_attr = rel and ' rel="%s"' % text_type(escape(rel)) or ''
|
||||||
|
target_attr = target and ' target="%s"' % escape(target) or ''
|
||||||
|
|
||||||
|
for i, word in enumerate(words):
|
||||||
|
- match = _punctuation_re.match(word)
|
||||||
|
+ head, middle, tail = "", word, ""
|
||||||
|
+ match = re.match(r"^([(<]|<)+", middle)
|
||||||
|
+
|
||||||
|
if match:
|
||||||
|
- lead, middle, trail = match.groups()
|
||||||
|
- if middle.startswith('www.') or (
|
||||||
|
- '@' not in middle and
|
||||||
|
- not middle.startswith('http://') and
|
||||||
|
- not middle.startswith('https://') and
|
||||||
|
- len(middle) > 0 and
|
||||||
|
- middle[0] in _letters + _digits and (
|
||||||
|
- middle.endswith('.org') or
|
||||||
|
- middle.endswith('.net') or
|
||||||
|
- middle.endswith('.com')
|
||||||
|
- )):
|
||||||
|
- middle = '<a href="http://%s"%s%s>%s</a>' % (middle,
|
||||||
|
- rel_attr, target_attr, trim_url(middle))
|
||||||
|
- if middle.startswith('http://') or \
|
||||||
|
- middle.startswith('https://'):
|
||||||
|
- middle = '<a href="%s"%s%s>%s</a>' % (middle,
|
||||||
|
- rel_attr, target_attr, trim_url(middle))
|
||||||
|
- if '@' in middle and not middle.startswith('www.') and \
|
||||||
|
- not ':' in middle and _simple_email_re.match(middle):
|
||||||
|
- middle = '<a href="mailto:%s">%s</a>' % (middle, middle)
|
||||||
|
- if lead + middle + trail != word:
|
||||||
|
- words[i] = lead + middle + trail
|
||||||
|
+ head = match.group()
|
||||||
|
+ middle = middle[match.end() :]
|
||||||
|
+
|
||||||
|
+ # Unlike lead, which is anchored to the start of the string,
|
||||||
|
+ # need to check that the string ends with any of the characters
|
||||||
|
+ # before trying to match all of them, to avoid backtracking.
|
||||||
|
+ if middle.endswith((")", ">", ".", ",", "\n", ">")):
|
||||||
|
+ match = re.search(r"([)>.,\n]|>)+$", middle)
|
||||||
|
+
|
||||||
|
+ if match:
|
||||||
|
+ tail = match.group()
|
||||||
|
+ middle = middle[: match.start()]
|
||||||
|
+
|
||||||
|
+ if middle.startswith("www.") or (
|
||||||
|
+ "@" not in middle
|
||||||
|
+ and not middle.startswith("http://")
|
||||||
|
+ and not middle.startswith("https://")
|
||||||
|
+ and len(middle) > 0
|
||||||
|
+ and middle[0] in _letters + _digits
|
||||||
|
+ and (
|
||||||
|
+ middle.endswith(".org")
|
||||||
|
+ or middle.endswith(".net")
|
||||||
|
+ or middle.endswith(".com")
|
||||||
|
+ )
|
||||||
|
+ ):
|
||||||
|
+ middle = '<a href="http://%s"%s%s>%s</a>' % (
|
||||||
|
+ middle,
|
||||||
|
+ rel_attr,
|
||||||
|
+ target_attr,
|
||||||
|
+ trim_url(middle),
|
||||||
|
+ )
|
||||||
|
+
|
||||||
|
+ if middle.startswith("http://") or middle.startswith("https://"):
|
||||||
|
+ middle = '<a href="%s"%s%s>%s</a>' % (
|
||||||
|
+ middle,
|
||||||
|
+ rel_attr,
|
||||||
|
+ target_attr,
|
||||||
|
+ trim_url(middle),
|
||||||
|
+ )
|
||||||
|
+
|
||||||
|
+ if (
|
||||||
|
+ "@" in middle
|
||||||
|
+ and not middle.startswith("www.")
|
||||||
|
+ and ":" not in middle
|
||||||
|
+ and re.match(r"^\S@\w[\w.-]*\.\w$", middle)
|
||||||
|
+ ):
|
||||||
|
+ middle = '<a href="mailto:%s">%s</a>' % (middle, middle)
|
||||||
|
+
|
||||||
|
+ words[i] = head + middle + tail
|
||||||
|
+
|
||||||
|
return u''.join(words)
|
||||||
|
|
||||||
|
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
6
gating.yaml
Normal file
6
gating.yaml
Normal file
@ -0,0 +1,6 @@
|
|||||||
|
--- !Policy
|
||||||
|
product_versions:
|
||||||
|
- rhel-9
|
||||||
|
decision_context: osci_compose_gate
|
||||||
|
rules:
|
||||||
|
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
423
python-jinja2.spec
Normal file
423
python-jinja2.spec
Normal file
@ -0,0 +1,423 @@
|
|||||||
|
# python2X and python3X are built form the same module, so we need a conditional
|
||||||
|
# for python[23] bits the state of the conditional is not important in the spec,
|
||||||
|
# it is set in modulemd
|
||||||
|
%bcond_without python2
|
||||||
|
%bcond_without python3
|
||||||
|
%bcond_with python36_module
|
||||||
|
|
||||||
|
# Enable building without docs to avoid a circular dependency between this
|
||||||
|
# and python-sphinx:
|
||||||
|
%if %{with python3}
|
||||||
|
%bcond_without docs
|
||||||
|
%else
|
||||||
|
%bcond_with docs
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if 0%{?fedora} > 25 || 0%{?rhel} > 7
|
||||||
|
%bcond_without async
|
||||||
|
%else
|
||||||
|
%bcond_with async
|
||||||
|
%endif
|
||||||
|
|
||||||
|
Name: python-jinja2
|
||||||
|
Version: 2.10
|
||||||
|
Release: 9%{?dist}
|
||||||
|
Summary: General purpose template engine
|
||||||
|
Group: Development/Languages
|
||||||
|
License: BSD
|
||||||
|
URL: http://jinja.pocoo.org/
|
||||||
|
Source0: https://files.pythonhosted.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
|
||||||
|
|
||||||
|
# CVE-2020-28493: ReDOS vulnerability due to the sub-pattern
|
||||||
|
# The patch is rebased to the old project structure.
|
||||||
|
# Upstream commit: https://github.com/pallets/jinja/pull/1343/commits/ef658dc3b6389b091d608e710a810ce8b87995b3
|
||||||
|
# Tracking bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1928707
|
||||||
|
Patch0: CVE-2020-28493.patch
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
Jinja2 is a template engine written in pure Python. It provides a
|
||||||
|
Django inspired non-XML syntax but supports inline expressions and an
|
||||||
|
optional sandboxed environment.
|
||||||
|
|
||||||
|
If you have any exposure to other text-based template languages, such
|
||||||
|
as Smarty or Django, you should feel right at home with Jinja2. It's
|
||||||
|
both designer and developer friendly by sticking to Python's
|
||||||
|
principles and adding functionality useful for templating
|
||||||
|
environments.
|
||||||
|
|
||||||
|
|
||||||
|
%if %{with python2}
|
||||||
|
%package -n python2-jinja2
|
||||||
|
Summary: General purpose template engine for python2
|
||||||
|
BuildRequires: python2-devel
|
||||||
|
BuildRequires: python2-setuptools
|
||||||
|
BuildRequires: python2-markupsafe
|
||||||
|
BuildRequires: python2-pytest
|
||||||
|
%if %{with docs}
|
||||||
|
BuildRequires: %{_bindir}/sphinx-build-3
|
||||||
|
%endif
|
||||||
|
Requires: python2-babel >= 0.8
|
||||||
|
Requires: python2-markupsafe
|
||||||
|
Requires: python2-setuptools
|
||||||
|
%{?python_provide:%python_provide python2-jinja2}
|
||||||
|
|
||||||
|
%description -n python2-jinja2
|
||||||
|
Jinja2 is a template engine written in pure Python. It provides a
|
||||||
|
Django inspired non-XML syntax but supports inline expressions and an
|
||||||
|
optional sandboxed environment.
|
||||||
|
|
||||||
|
If you have any exposure to other text-based template languages, such
|
||||||
|
as Smarty or Django, you should feel right at home with Jinja2. It's
|
||||||
|
both designer and developer friendly by sticking to Python's
|
||||||
|
principles and adding functionality useful for templating
|
||||||
|
environments.
|
||||||
|
%endif # with python2
|
||||||
|
|
||||||
|
|
||||||
|
%if %{with python3}
|
||||||
|
%package -n python3-jinja2
|
||||||
|
Summary: General purpose template engine for python3
|
||||||
|
Group: Development/Languages
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: python3-setuptools
|
||||||
|
BuildRequires: python3-babel >= 0.8
|
||||||
|
BuildRequires: python3-markupsafe
|
||||||
|
BuildRequires: python3-pytest
|
||||||
|
%if %{with docs}
|
||||||
|
BuildRequires: %{_bindir}/sphinx-build-3
|
||||||
|
%endif
|
||||||
|
Requires: python3-babel >= 0.8
|
||||||
|
Requires: python3-markupsafe
|
||||||
|
Requires: python3-setuptools
|
||||||
|
%{?python_provide:%python_provide python3-jinja2}
|
||||||
|
|
||||||
|
%description -n python3-jinja2
|
||||||
|
Jinja2 is a template engine written in pure Python. It provides a
|
||||||
|
Django inspired non-XML syntax but supports inline expressions and an
|
||||||
|
optional sandboxed environment.
|
||||||
|
|
||||||
|
If you have any exposure to other text-based template languages, such
|
||||||
|
as Smarty or Django, you should feel right at home with Jinja2. It's
|
||||||
|
both designer and developer friendly by sticking to Python's
|
||||||
|
principles and adding functionality useful for templating
|
||||||
|
environments.
|
||||||
|
%endif # with python3
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -qc -n Jinja2-%{version}
|
||||||
|
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
# cleanup
|
||||||
|
find Jinja2-%{version} -name '*.pyo' -o -name '*.pyc' -delete
|
||||||
|
|
||||||
|
# fix EOL
|
||||||
|
sed -i 's|\r$||g' Jinja2-%{version}/LICENSE
|
||||||
|
|
||||||
|
mv Jinja2-%{version} python3
|
||||||
|
%if %{with python2}
|
||||||
|
cp -av python3 python2
|
||||||
|
%endif # with python2
|
||||||
|
|
||||||
|
%build
|
||||||
|
%if %{with python2}
|
||||||
|
pushd python2
|
||||||
|
%py2_build
|
||||||
|
|
||||||
|
popd
|
||||||
|
%endif # with python2
|
||||||
|
|
||||||
|
%if %{with python3}
|
||||||
|
pushd python3
|
||||||
|
%py3_build
|
||||||
|
%if %{with docs}
|
||||||
|
make -C docs html PYTHONPATH=$(pwd) SPHINXBUILD=sphinx-build-3
|
||||||
|
# remove hidden file
|
||||||
|
rm -rf docs/_build/html/.buildinfo
|
||||||
|
%endif # with docs
|
||||||
|
popd
|
||||||
|
%endif # with python3
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%if %{with python2}
|
||||||
|
pushd python2
|
||||||
|
%py2_install
|
||||||
|
|
||||||
|
# these files are valid only on Python 3.6+
|
||||||
|
rm %{buildroot}%{python2_sitelib}/jinja2/asyncsupport.py
|
||||||
|
rm %{buildroot}%{python2_sitelib}/jinja2/asyncfilters.py
|
||||||
|
popd
|
||||||
|
%endif # with python2
|
||||||
|
|
||||||
|
%if %{with python3}
|
||||||
|
pushd python3
|
||||||
|
%py3_install
|
||||||
|
|
||||||
|
%if ! %{with async}
|
||||||
|
# these files are valid only on Python 3.6+
|
||||||
|
rm %{buildroot}%{python3_sitelib}/jinja2/asyncsupport.py
|
||||||
|
rm %{buildroot}%{python3_sitelib}/jinja2/asyncfilters.py
|
||||||
|
%endif # ! with async
|
||||||
|
popd
|
||||||
|
%endif # with python3
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
%if %{with python2}
|
||||||
|
pushd python2
|
||||||
|
# there are currently no tests in the jinja2 tarball
|
||||||
|
# make test
|
||||||
|
popd
|
||||||
|
%endif # with python2
|
||||||
|
|
||||||
|
%if %{with python3}
|
||||||
|
pushd python3
|
||||||
|
# there are currently no tests in the jinja2 tarball
|
||||||
|
# make test
|
||||||
|
popd
|
||||||
|
%endif # with python3
|
||||||
|
|
||||||
|
|
||||||
|
%if %{with python2}
|
||||||
|
%files -n python2-jinja2
|
||||||
|
%doc python2/AUTHORS
|
||||||
|
%doc python2/CHANGES.rst
|
||||||
|
%doc python2/ext
|
||||||
|
%doc python2/examples
|
||||||
|
%license python2/LICENSE
|
||||||
|
%{python2_sitelib}/jinja2
|
||||||
|
%{python2_sitelib}/Jinja2-%{version}-py?.?.egg-info
|
||||||
|
%endif # with python2
|
||||||
|
|
||||||
|
|
||||||
|
%if %{with python3}
|
||||||
|
%files -n python3-jinja2
|
||||||
|
%doc python3/AUTHORS
|
||||||
|
%doc python3/CHANGES.rst
|
||||||
|
%doc python3/ext
|
||||||
|
%doc python3/examples
|
||||||
|
%license python3/LICENSE
|
||||||
|
%if %{with docs}
|
||||||
|
%doc python3/docs/_build/html
|
||||||
|
%endif
|
||||||
|
%{python3_sitelib}/jinja2
|
||||||
|
%{python3_sitelib}/Jinja2-%{version}-py?.?.egg-info
|
||||||
|
%endif # with python3
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 12 2021 Lumír Balhar <lbalhar@redhat.com> - 2.10-9
|
||||||
|
- Fix CVE-2020-28493: ReDOS vulnerability due to the sub-pattern
|
||||||
|
Resolves: rhbz#1928707
|
||||||
|
|
||||||
|
* Thu Apr 25 2019 Tomas Orsava <torsava@redhat.com> - 2.10-8
|
||||||
|
- Bumping due to problems with modular RPM upgrade path
|
||||||
|
- Resolves: rhbz#1695587
|
||||||
|
|
||||||
|
* Sat Aug 04 2018 Lumír Balhar <lbalhar@redhat.com> - 2.10-7
|
||||||
|
- Fix conditions
|
||||||
|
|
||||||
|
* Sat Aug 04 2018 Lumír Balhar <lbalhar@redhat.com> - 2.10-6
|
||||||
|
- Specfile cleanup and fixes
|
||||||
|
|
||||||
|
* Mon Jun 25 2018 Lumír Balhar <Lbalhar@redhat.com> - 2.10-5
|
||||||
|
- Disable Python 2 build by default
|
||||||
|
|
||||||
|
* Mon Jun 25 2018 Lumír Balhar <Lbalhar@redhat.com> - 2.10-4
|
||||||
|
- Allow build with Python 2
|
||||||
|
|
||||||
|
* Mon May 28 2018 Petr Viktorin <pviktori@redhat.com> - 2.10-3
|
||||||
|
- Remove docs from Python 2 package
|
||||||
|
- Remove dependency on python2-babel and python2-sphinx
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.10-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 16 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.10-1
|
||||||
|
- Update to 2.10.
|
||||||
|
- Use %%bcond.
|
||||||
|
- Move BRs to their respective subpackages.
|
||||||
|
|
||||||
|
* Fri Oct 20 2017 Troy Dawson <tdawson@redhat.com> - 2.9.6-4
|
||||||
|
- Really cleanup spec file conditionals
|
||||||
|
|
||||||
|
* Fri Sep 29 2017 Troy Dawson <tdawson@redhat.com> - 2.9.6-3
|
||||||
|
- Cleanup spec file conditionals
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Apr 5 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.9.6-1
|
||||||
|
- Update to 2.9.6.
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jan 29 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.9.5-1
|
||||||
|
- Update to 2.9.5.
|
||||||
|
|
||||||
|
* Fri Jan 13 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.9.4-1
|
||||||
|
- Update to 2.9.4.
|
||||||
|
|
||||||
|
* Sat Dec 31 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.8.1-1
|
||||||
|
- Update to 2.8.1.
|
||||||
|
|
||||||
|
* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.8-8
|
||||||
|
- Rebuild for Python 3.6
|
||||||
|
|
||||||
|
* Thu Sep 22 2016 Orion Poplawski <orion@cora.nwra.com> - 2.8-7
|
||||||
|
- Ship python2-jinja2 (bug #1378519)
|
||||||
|
- Modernize spec
|
||||||
|
|
||||||
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8-6
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
* Fri Feb 5 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.8-5
|
||||||
|
- Do not call py.test, there are currently no tests in the tarball.
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.8-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> - 2.8-3
|
||||||
|
- Rebuilt for Python3.5 rebuild
|
||||||
|
|
||||||
|
* Mon Jul 27 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.8-2
|
||||||
|
- Apply updates Python packaging guidelines.
|
||||||
|
- Mark LICENSE with %%license.
|
||||||
|
|
||||||
|
* Sun Jul 26 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 2.8-1
|
||||||
|
- Upstream 2.8
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Dec 2 2014 Orion Poplawski <orion@cora.nwra.com> - 2.7.3-2
|
||||||
|
- Add Requires python(3)-setuptools (bug #1168774)
|
||||||
|
|
||||||
|
* Sat Jun 7 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.7.3-1
|
||||||
|
- Update to 2.7.3.
|
||||||
|
- Reenable docs.
|
||||||
|
|
||||||
|
* Sat May 10 2014 Orion Poplawski <orion@cora.nwra.com> - 2.7.2-2
|
||||||
|
- Bootstrap (without docs) build for Python 3.4
|
||||||
|
|
||||||
|
* Fri Jan 10 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.7.2-1
|
||||||
|
- Update to 2.7.2.
|
||||||
|
- Update python3 conditional.
|
||||||
|
|
||||||
|
* Fri Aug 16 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.7.1-1
|
||||||
|
- Update to 2.7.1.
|
||||||
|
|
||||||
|
* Thu Jul 25 2013 Orion Poplawski <orion@cora.nwra.com> - 2.7-1
|
||||||
|
- Update to 2.7
|
||||||
|
- spec cleanup
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 2.6-5
|
||||||
|
- rebuild for https://fedoraproject.org/wiki/Features/Python_3.3
|
||||||
|
|
||||||
|
* Fri Aug 3 2012 David Malcolm <dmalcolm@redhat.com> - 2.6-4
|
||||||
|
- remove rhel logic from with_python3 conditional
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Jul 25 2011 Thomas Moschny <thomas.moschny@gmx.de> - 2.6-1
|
||||||
|
- Update to 2.6.
|
||||||
|
|
||||||
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.5-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jan 18 2011 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.5-3
|
||||||
|
- Re-enable html doc generation.
|
||||||
|
- Remove conditional for F-12 and below.
|
||||||
|
- Do not silently fail the testsuite for with py3k.
|
||||||
|
|
||||||
|
* Mon Nov 1 2010 Michel Salim <salimma@fedoraproject.org> - 2.5.5-2
|
||||||
|
- Move python3 runtime requirements to python3 subpackage
|
||||||
|
|
||||||
|
* Wed Oct 27 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.5-1
|
||||||
|
- Update to 2.5.5.
|
||||||
|
|
||||||
|
* Wed Aug 25 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.2-4
|
||||||
|
- Revert to previous behavior: fail the build on failed test.
|
||||||
|
- Rebuild for Python 3.2.
|
||||||
|
|
||||||
|
* Wed Aug 25 2010 Dan Horák <dan[at]danny.cz> - 2.5.2-3
|
||||||
|
- %%ifnarch doesn't work on noarch package so don't fail the build on failed tests
|
||||||
|
|
||||||
|
* Wed Aug 25 2010 Dan Horák <dan[at]danny.cz> - 2.5.2-2
|
||||||
|
- disable the testsuite on s390(x)
|
||||||
|
|
||||||
|
* Thu Aug 19 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.2-1
|
||||||
|
- Update to upstream version 2.5.2.
|
||||||
|
- Package depends on python-markupsafe and is noarch now.
|
||||||
|
|
||||||
|
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.5-4
|
||||||
|
- add explicit build-requirement on python-setuptools
|
||||||
|
- fix doc disablement for python3 subpackage
|
||||||
|
|
||||||
|
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.5-3
|
||||||
|
- support disabling documentation in the build to break a circular build-time
|
||||||
|
dependency with python-sphinx; disable docs for now
|
||||||
|
|
||||||
|
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||||
|
|
||||||
|
* Tue Jul 13 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.5-1
|
||||||
|
- Update to upstream version 2.5.
|
||||||
|
- Create python3 subpackage.
|
||||||
|
- Minor specfile fixes.
|
||||||
|
- Add examples directory.
|
||||||
|
- Thanks to Gareth Armstrong for additional hints.
|
||||||
|
|
||||||
|
* Wed Apr 21 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.4.1-1
|
||||||
|
- Update to 2.4.1.
|
||||||
|
|
||||||
|
* Tue Apr 13 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.4-1
|
||||||
|
- Update to 2.4.
|
||||||
|
|
||||||
|
* Tue Feb 23 2010 Thomas Moschny <thomas.moschny@gmx.de> - 2.3.1-1
|
||||||
|
- Update to 2.3.1.
|
||||||
|
- Docs are built using Sphinx now.
|
||||||
|
- Run the testsuite.
|
||||||
|
|
||||||
|
* Sat Sep 19 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.1-1
|
||||||
|
- Update to 2.2.1, mainly a bugfix release.
|
||||||
|
- Remove patch no longer needed.
|
||||||
|
- Remove conditional for FC-8.
|
||||||
|
- Compilation of speedup module has to be explicitly requested now.
|
||||||
|
|
||||||
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 10 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.1-1
|
||||||
|
- Update to 2.1.1 (bugfix release).
|
||||||
|
|
||||||
|
* Thu Dec 18 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.1-1
|
||||||
|
- Update to 2.1, which fixes a number of bugs.
|
||||||
|
See http://jinja.pocoo.org/2/documentation/changelog#version-2-1.
|
||||||
|
|
||||||
|
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0-3
|
||||||
|
- Rebuild for Python 2.6
|
||||||
|
|
||||||
|
* Tue Jul 22 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-2
|
||||||
|
- Use rpm buildroot macro instead of RPM_BUILD_ROOT.
|
||||||
|
|
||||||
|
* Sun Jul 20 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-1
|
||||||
|
- Upstream released 2.0.
|
||||||
|
|
||||||
|
* Sun Jun 29 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-0.1.rc1
|
||||||
|
- Modified specfile from the existing python-jinja package.
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
|||||||
|
SHA1 (Jinja2-2.10.tar.gz) = 34b69e5caab12ee37b9df69df9018776c008b7b8
|
7
tests/smoke.fmf
Normal file
7
tests/smoke.fmf
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
description: |
|
||||||
|
Runs very simple jinja2 template which should always work
|
||||||
|
test: python3 smoke.py
|
||||||
|
framework: shell
|
||||||
|
require:
|
||||||
|
- python3
|
||||||
|
- python3-jinja2
|
9
tests/smoke.py
Normal file
9
tests/smoke.py
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
import jinja2
|
||||||
|
|
||||||
|
|
||||||
|
TEMPLATE = "Text {{ variable }}"
|
||||||
|
|
||||||
|
environment = jinja2.Environment()
|
||||||
|
template = environment.from_string(TEMPLATE)
|
||||||
|
output = template.render(variable="demo")
|
||||||
|
assert output == "Text demo", f"got: {output}"
|
Loading…
Reference in New Issue
Block a user