Update to 2.2.1.
This commit is contained in:
parent
aee38bb4f9
commit
80fe387f91
@ -1 +1 @@
|
|||||||
Jinja2-2.1.1.tar.gz
|
Jinja2-2.2.1.tar.gz
|
||||||
|
@ -1,3 +1,4 @@
|
|||||||
python-jinja2-2_0-2_fc9:HEAD:python-jinja2-2.0-2.fc9.src.rpm:1216886150
|
python-jinja2-2_0-2_fc9:HEAD:python-jinja2-2.0-2.fc9.src.rpm:1216886150
|
||||||
python-jinja2-2_1-1_fc10:HEAD:python-jinja2-2.1-1.fc10.src.rpm:1229610786
|
python-jinja2-2_1-1_fc10:HEAD:python-jinja2-2.1-1.fc10.src.rpm:1229610786
|
||||||
python-jinja2-2_1_1-1_fc10:HEAD:python-jinja2-2.1.1-1.fc10.src.rpm:1231601194
|
python-jinja2-2_1_1-1_fc10:HEAD:python-jinja2-2.1.1-1.fc10.src.rpm:1231601194
|
||||||
|
python-jinja2-2_2_1-1_fc11:HEAD:python-jinja2-2.2.1-1.fc11.src.rpm:1253462191
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up Jinja2-2.1/setup.py.orig Jinja2-2.1/setup.py
|
|
||||||
--- Jinja2-2.1/setup.py.orig 2008-11-23 13:08:17.000000000 +0100
|
|
||||||
+++ Jinja2-2.1/setup.py 2008-12-18 15:14:22.000000000 +0100
|
|
||||||
@@ -54,7 +54,7 @@ VERSION = '2.1'
|
|
||||||
|
|
||||||
data_files = []
|
|
||||||
documentation_path = 'docs/_build/html'
|
|
||||||
-if os.path.exists(documentation_path):
|
|
||||||
+if os.path.exists(documentation_path) and False:
|
|
||||||
documentation_files = []
|
|
||||||
for fn in os.listdir(documentation_path):
|
|
||||||
if not fn.startswith('.'):
|
|
@ -1,24 +1,16 @@
|
|||||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||||
|
|
||||||
Name: python-jinja2
|
Name: python-jinja2
|
||||||
Version: 2.1.1
|
Version: 2.2.1
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: General purpose template engine
|
Summary: General purpose template engine
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://jinja.pocoo.org/
|
URL: http://jinja.pocoo.org/
|
||||||
Source0: http://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
|
Source0: http://pypi.python.org/packages/source/J/Jinja2/Jinja2-%{version}.tar.gz
|
||||||
Patch0: %{name}-docs.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
|
BuildRequires: python-setuptools-devel
|
||||||
%if 0%{?fedora} >= 8
|
|
||||||
BuildRequires: python-setuptools-devel
|
|
||||||
%else
|
|
||||||
BuildRequires: python-setuptools
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Requires: python-babel >= 0.8
|
Requires: python-babel >= 0.8
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -35,22 +27,26 @@ environments.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n Jinja2-%{version}
|
%setup -q -n Jinja2-%{version}
|
||||||
%patch0 -p1 -b .docs
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
|
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py --with-speedups build
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
%{__python} setup.py install -O1 --skip-build --root %{buildroot}
|
%{__python} setup.py --with-speedups install -O1 --skip-build \
|
||||||
|
--root %{buildroot}
|
||||||
|
|
||||||
# fix EOL
|
# fix EOL
|
||||||
sed -i 's|\r$||g' LICENSE
|
sed -i 's|\r$||g' LICENSE
|
||||||
|
|
||||||
# fix wrong permission
|
# ensure correct permission
|
||||||
%{__chmod} 0755 %{buildroot}%{python_sitearch}/jinja2/_speedups.so
|
chmod 0755 %{buildroot}%{python_sitearch}/jinja2/_speedups.so
|
||||||
|
|
||||||
|
# remove hidden file
|
||||||
|
rm -rf docs/_build/html/.buildinfo
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
@ -64,6 +60,12 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 19 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.1-1
|
||||||
|
- Update to 2.2.1, mainly a bugfix release.
|
||||||
|
- Remove patch no longer needed.
|
||||||
|
- Remove conditional for FC-8.
|
||||||
|
- Compilation of speedup module has to be explicitly requested now.
|
||||||
|
|
||||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-3
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||||
|
|
||||||
@ -88,4 +90,3 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
* Sun Jun 29 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-0.1.rc1
|
* Sun Jun 29 2008 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-0.1.rc1
|
||||||
- Modified specfile from the existing python-jinja package.
|
- Modified specfile from the existing python-jinja package.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user