import UBI python-jinja2-2.10.1-5.el8_10
This commit is contained in:
parent
3e1948e4ce
commit
7c304a3591
77
SOURCES/CVE-2024-22195.patch
Normal file
77
SOURCES/CVE-2024-22195.patch
Normal file
@ -0,0 +1,77 @@
|
||||
From c4695c78dc41d206a6c79878dea177d6188896b4 Mon Sep 17 00:00:00 2001
|
||||
From: Calum Hutton <calum.hutton@snyk.io>
|
||||
Date: Thu, 26 Oct 2023 12:08:53 +0100
|
||||
Subject: [PATCH] xmlattr filter disallows keys with spaces
|
||||
|
||||
---
|
||||
Jinja2-2.10.1/jinja2/filters.py | 26 +++++++++++++++++++-------
|
||||
Jinja2-2.10.1/tests/test_filters.py | 6 ++++++
|
||||
2 files changed, 25 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/Jinja2-2.10.1/jinja2/filters.py b/Jinja2-2.10.1/jinja2/filters.py
|
||||
index 267dddd..d473058 100644
|
||||
--- a/Jinja2-2.10.1/jinja2/filters.py
|
||||
+++ b/Jinja2-2.10.1/jinja2/filters.py
|
||||
@@ -150,11 +150,15 @@ def do_lower(s):
|
||||
return soft_unicode(s).lower()
|
||||
|
||||
|
||||
+_space_re = re.compile(r"\s", flags=re.ASCII)
|
||||
+
|
||||
+
|
||||
@evalcontextfilter
|
||||
def do_xmlattr(_eval_ctx, d, autospace=True):
|
||||
"""Create an SGML/XML attribute string based on the items in a dict.
|
||||
- All values that are neither `none` nor `undefined` are automatically
|
||||
- escaped:
|
||||
+
|
||||
+ If any key contains a space, this fails with a ``ValueError``. Values that
|
||||
+ are neither ``none`` nor ``undefined`` are automatically escaped.
|
||||
|
||||
.. sourcecode:: html+jinja
|
||||
|
||||
@@ -174,11 +178,19 @@ def do_xmlattr(_eval_ctx, d, autospace=True):
|
||||
As you can see it automatically prepends a space in front of the item
|
||||
if the filter returned something unless the second parameter is false.
|
||||
"""
|
||||
- rv = u' '.join(
|
||||
- u'%s="%s"' % (escape(key), escape(value))
|
||||
- for key, value in iteritems(d)
|
||||
- if value is not None and not isinstance(value, Undefined)
|
||||
- )
|
||||
+ items = []
|
||||
+
|
||||
+ for key, value in d.items():
|
||||
+ if value is None or isinstance(value, Undefined):
|
||||
+ continue
|
||||
+
|
||||
+ if _space_re.search(key) is not None:
|
||||
+ raise ValueError(f"Spaces are not allowed in attributes: '{key}'")
|
||||
+
|
||||
+ items.append(f'{escape(key)}="{escape(value)}"')
|
||||
+
|
||||
+ rv = " ".join(items)
|
||||
+
|
||||
if autospace and rv:
|
||||
rv = u' ' + rv
|
||||
if _eval_ctx.autoescape:
|
||||
diff --git a/Jinja2-2.10.1/tests/test_filters.py b/Jinja2-2.10.1/tests/test_filters.py
|
||||
index 8962ced..911d10a 100644
|
||||
--- a/Jinja2-2.10.1/tests/test_filters.py
|
||||
+++ b/Jinja2-2.10.1/tests/test_filters.py
|
||||
@@ -389,6 +389,12 @@ class TestFilter(object):
|
||||
assert 'bar="23"' in out
|
||||
assert 'blub:blub="<?>"' in out
|
||||
|
||||
+ def test_xmlattr_key_with_spaces(self, env):
|
||||
+ with pytest.raises(ValueError, match="Spaces are not allowed"):
|
||||
+ env.from_string(
|
||||
+ "{{ {'src=1 onerror=alert(1)': 'my_class'}|xmlattr }}"
|
||||
+ ).render()
|
||||
+
|
||||
def test_sort1(self, env):
|
||||
tmpl = env.from_string(
|
||||
'{{ [2, 3, 1]|sort }}|{{ [2, 3, 1]|sort(true) }}')
|
||||
--
|
||||
2.43.0
|
||||
|
77
SOURCES/CVE-2024-34064.patch
Normal file
77
SOURCES/CVE-2024-34064.patch
Normal file
@ -0,0 +1,77 @@
|
||||
From 5d0b496b29214838494b1d65bd04718113911450 Mon Sep 17 00:00:00 2001
|
||||
From: David Lord <davidism@gmail.com>
|
||||
Date: Thu, 9 May 2024 13:43:38 +0200
|
||||
Subject: [PATCH] disallow invalid characters in keys to xmlattr filter
|
||||
|
||||
---
|
||||
Jinja2-2.10.1/jinja2/filters.py | 18 +++++++++++++-----
|
||||
Jinja2-2.10.1/tests/test_filters.py | 11 ++++++-----
|
||||
2 files changed, 19 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/Jinja2-2.10.1/jinja2/filters.py b/Jinja2-2.10.1/jinja2/filters.py
|
||||
index d473058..3e33f57 100644
|
||||
--- a/Jinja2-2.10.1/jinja2/filters.py
|
||||
+++ b/Jinja2-2.10.1/jinja2/filters.py
|
||||
@@ -150,15 +150,23 @@ def do_lower(s):
|
||||
return soft_unicode(s).lower()
|
||||
|
||||
|
||||
-_space_re = re.compile(r"\s", flags=re.ASCII)
|
||||
+# Check for characters that would move the parser state from key to value.
|
||||
+# https://html.spec.whatwg.org/#attribute-name-state
|
||||
+_attr_key_re = re.compile(r"[\s/>=]", flags=re.ASCII)
|
||||
|
||||
|
||||
@evalcontextfilter
|
||||
def do_xmlattr(_eval_ctx, d, autospace=True):
|
||||
"""Create an SGML/XML attribute string based on the items in a dict.
|
||||
|
||||
- If any key contains a space, this fails with a ``ValueError``. Values that
|
||||
- are neither ``none`` nor ``undefined`` are automatically escaped.
|
||||
+ **Values** that are neither ``none`` nor ``undefined`` are automatically
|
||||
+ escaped, safely allowing untrusted user input.
|
||||
+
|
||||
+ User input should not be used as **keys** to this filter. If any key
|
||||
+ contains a space, ``/`` solidus, ``>`` greater-than sign, or ``=`` equals
|
||||
+ sign, this fails with a ``ValueError``. Regardless of this, user input
|
||||
+ should never be used as keys to this filter, or must be separately validated
|
||||
+ first.
|
||||
|
||||
.. sourcecode:: html+jinja
|
||||
|
||||
@@ -184,8 +192,8 @@ def do_xmlattr(_eval_ctx, d, autospace=True):
|
||||
if value is None or isinstance(value, Undefined):
|
||||
continue
|
||||
|
||||
- if _space_re.search(key) is not None:
|
||||
- raise ValueError(f"Spaces are not allowed in attributes: '{key}'")
|
||||
+ if _attr_key_re.search(key) is not None:
|
||||
+ raise ValueError(f"Invalid character in attribute name: {key!r}")
|
||||
|
||||
items.append(f'{escape(key)}="{escape(value)}"')
|
||||
|
||||
diff --git a/Jinja2-2.10.1/tests/test_filters.py b/Jinja2-2.10.1/tests/test_filters.py
|
||||
index 911d10a..153356d 100644
|
||||
--- a/Jinja2-2.10.1/tests/test_filters.py
|
||||
+++ b/Jinja2-2.10.1/tests/test_filters.py
|
||||
@@ -389,11 +389,12 @@ class TestFilter(object):
|
||||
assert 'bar="23"' in out
|
||||
assert 'blub:blub="<?>"' in out
|
||||
|
||||
- def test_xmlattr_key_with_spaces(self, env):
|
||||
- with pytest.raises(ValueError, match="Spaces are not allowed"):
|
||||
- env.from_string(
|
||||
- "{{ {'src=1 onerror=alert(1)': 'my_class'}|xmlattr }}"
|
||||
- ).render()
|
||||
+ @pytest.mark.parametrize("sep", ("\t", "\n", "\f", " ", "/", ">", "="))
|
||||
+ def test_xmlattr_key_invalid(self, env: Environment, sep: str) -> None:
|
||||
+ with pytest.raises(ValueError, match="Invalid character"):
|
||||
+ env.from_string("{{ {key: 'my_class'}|xmlattr }}").render(
|
||||
+ key=f"class{sep}onclick=alert(1)"
|
||||
+ )
|
||||
|
||||
def test_sort1(self, env):
|
||||
tmpl = env.from_string(
|
||||
--
|
||||
2.45.0
|
||||
|
@ -27,7 +27,7 @@
|
||||
|
||||
Name: python-jinja2
|
||||
Version: 2.10.1
|
||||
Release: 3%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: General purpose template engine
|
||||
Group: Development/Languages
|
||||
License: BSD
|
||||
@ -40,6 +40,14 @@ Source0: https://files.pythonhosted.org/packages/source/J/Jinja2/Jinja2-%
|
||||
# Tracking bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1928707
|
||||
Patch0: CVE-2020-28493.patch
|
||||
|
||||
# Security fix for CVE-2024-22195
|
||||
# Resolved upstream: https://github.com/pallets/jinja/commit/7dd3680e6eea0d77fde024763657aa4d884ddb23
|
||||
Patch1: CVE-2024-22195.patch
|
||||
|
||||
# Security fix for CVE-2024-34064
|
||||
# Resolved upstream: https://github.com/pallets/jinja/commit/0668239dc6b44ef38e7a6c9f91f312fd4ca581cb
|
||||
Patch2: CVE-2024-34064.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
@ -116,6 +124,9 @@ environments.
|
||||
%setup -qc -n Jinja2-%{version}
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
|
||||
# cleanup
|
||||
find Jinja2-%{version} -name '*.pyo' -o -name '*.pyc' -delete
|
||||
@ -217,6 +228,14 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 07 2024 Lumír Balhar <lbalhar@redhat.com> - 2.10.1-5
|
||||
- Security fix for CVE-2024-34064
|
||||
Resolves: RHEL-35651
|
||||
|
||||
* Tue Jan 30 2024 Charalampos Stratakis <cstratak@redhat.com> - 2.10.1-4
|
||||
- Security fix for CVE-2024-22195
|
||||
Resolves: RHEL-21347
|
||||
|
||||
* Fri Mar 12 2021 Lumír Balhar <lbalhar@redhat.com> - 2.10.1-3
|
||||
- Fix CVE-2020-28493: ReDOS vulnerability due to the sub-pattern
|
||||
Resolves: rhbz#1928707
|
||||
|
Loading…
Reference in New Issue
Block a user