Release 0.3.0-2 : Added patch to fix upstream regrestion
This commit is contained in:
parent
4d36bada1f
commit
d8498c181f
27
iniparse.patch
Normal file
27
iniparse.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
Index: iniparse/ini.py
|
||||||
|
===================================================================
|
||||||
|
--- iniparse/ini.py (revision 111)
|
||||||
|
+++ iniparse/ini.py (working copy)
|
||||||
|
@@ -404,7 +404,7 @@
|
||||||
|
|
||||||
|
|
||||||
|
def make_comment(line):
|
||||||
|
- return CommentLine(line.rstrip())
|
||||||
|
+ return CommentLine(line.rstrip('\n'))
|
||||||
|
|
||||||
|
|
||||||
|
def readline_iterator(f):
|
||||||
|
@@ -578,11 +578,9 @@
|
||||||
|
|
||||||
|
if isinstance(lineobj, OptionLine):
|
||||||
|
if pending_lines:
|
||||||
|
- cur_option.extend(pending_lines)
|
||||||
|
+ cur_section.extend(pending_lines)
|
||||||
|
pending_lines = []
|
||||||
|
- if pending_empty_lines:
|
||||||
|
- optobj._compat_skip_empty_lines.add(cur_option_name)
|
||||||
|
- pending_empty_lines = False
|
||||||
|
+ pending_empty_lines = False
|
||||||
|
cur_option = LineContainer(lineobj)
|
||||||
|
cur_section.add(cur_option)
|
||||||
|
if self._optionxform:
|
@ -2,12 +2,14 @@
|
|||||||
|
|
||||||
Name: python-iniparse
|
Name: python-iniparse
|
||||||
Version: 0.3.0
|
Version: 0.3.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Summary: Python Module for Accessing and Modifying Configuration Data in INI files
|
Summary: Python Module for Accessing and Modifying Configuration Data in INI files
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://code.google.com/p/iniparse/
|
URL: http://code.google.com/p/iniparse/
|
||||||
Source0: http://iniparse.googlecode.com/files/iniparse-%{version}.tar.gz
|
Source0: http://iniparse.googlecode.com/files/iniparse-%{version}.tar.gz
|
||||||
|
Patch0: iniparse.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
%if 0%{?fedora} >= 8
|
%if 0%{?fedora} >= 8
|
||||||
@ -27,7 +29,8 @@ use.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n iniparse-%{version}
|
%setup -q -n iniparse-%{version}
|
||||||
|
%patch0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python} setup.py build
|
%{__python} setup.py build
|
||||||
|
|
||||||
@ -51,6 +54,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 2 2009 Tim Lauridsen <timlau@fedoraproject.org> - 0.3.0-2
|
||||||
|
- added patch from upstream to fix regrestion :
|
||||||
|
|
||||||
* Sat Feb 28 2009 Tim Lauridsen <timlau@fedoraproject.org> - 0.3.0-1
|
* Sat Feb 28 2009 Tim Lauridsen <timlau@fedoraproject.org> - 0.3.0-1
|
||||||
- Release 0.3.0
|
- Release 0.3.0
|
||||||
- Fix handling of continuation lines
|
- Fix handling of continuation lines
|
||||||
|
Loading…
Reference in New Issue
Block a user