Merged update from upstream sources

This is an automated DistroBaker update from upstream sources.
If you do not know what this is about or would like to opt out,
contact the OSCI team.

Source: https://src.fedoraproject.org/rpms/python-iniconfig.git#ec09ca9ec97a6dd6b260d455b846bc9a3c681b68
This commit is contained in:
DistroBaker 2020-10-27 18:28:44 +01:00 committed by Petr Šabata
parent d78dc2668e
commit 353d239688
3 changed files with 6 additions and 60 deletions

View File

@ -1,54 +0,0 @@
From 41076a67c333d96be14557ecbb29995f98744bd7 Mon Sep 17 00:00:00 2001
From: Stanislav Levin <slev@altlinux.org>
Date: Thu, 8 Aug 2019 19:43:12 +0300
Subject: [PATCH] Fix Pytest 5 errors
This fixes
"""
pytest.PytestDeprecationWarning: raises(..., 'code(as_a_string)')
is deprecated, use the context manager form or use `exec()` directly.
"""
Fixes: https://github.com/RonnyPfannschmidt/iniconfig/issues/6
Signed-off-by: Stanislav Levin <slev@altlinux.org>
---
test_iniconfig.py | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/test_iniconfig.py b/test_iniconfig.py
index 27fd53f..fe12421 100644
--- a/test_iniconfig.py
+++ b/test_iniconfig.py
@@ -150,27 +150,25 @@ def test_iniconfig_from_file(tmpdir):
assert list(config.sections) == ['metadata']
config = IniConfig(path, "[diff]")
assert list(config.sections) == ['diff']
- py.test.raises(TypeError, "IniConfig(data=path.read())")
+ with pytest.raises(TypeError):
+ IniConfig(data=path.read())
def test_iniconfig_section_first(tmpdir):
- excinfo = py.test.raises(ParseError, """
+ with pytest.raises(ParseError) as excinfo:
IniConfig("x", data='name=1')
- """)
assert excinfo.value.msg == "no section header defined"
def test_iniconig_section_duplicate_fails():
- excinfo = py.test.raises(ParseError, r"""
+ with pytest.raises(ParseError) as excinfo:
IniConfig("x", data='[section]\n[section]')
- """)
assert 'duplicate section' in str(excinfo.value)
def test_iniconfig_duplicate_key_fails():
- excinfo = py.test.raises(ParseError, r"""
+ with pytest.raises(ParseError) as excinfo:
IniConfig("x", data='[section]\nname = Alice\nname = bob')
- """)
assert 'duplicate name' in str(excinfo.value)

View File

@ -1,6 +1,6 @@
Name: python-iniconfig
Version: 1.0.0
Release: 2%{?dist}
Version: 1.1.1
Release: 1%{?dist}
Summary: Brain-dead simple parsing of ini files
License: MIT
URL: http://github.com/RonnyPfannschmidt/iniconfig
@ -10,9 +10,6 @@ BuildRequires: pyproject-rpm-macros
Source0: %{pypi_source iniconfig}
# Backport: Fix pytest 5+ compatibility
Patch1: %{url}/commit/41076a67.patch
# pytest 6+ needs this and this uses pytest for tests
%bcond_without tests
@ -64,6 +61,9 @@ Summary: %{summary}
%changelog
* Thu Oct 15 2020 Tomas Hrnciar <thrnciar@redhat.com> - 1.1.1-1
- Update to 1.1.1 (#1888157)
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (iniconfig-1.0.0.tar.gz) = 639a4e765637110f69627fb18a5e719b6d648e5549fd857168183d97da7880434d447c9af1e254dd2aa5d0e36cbd3f5c4ffabf8a949ed3d6294002e7e1b2f6e1
SHA512 (iniconfig-1.1.1.tar.gz) = c9341db7e3ec2204b6a674fca7824cbeb492e3576d5ac3f084b234c82842b28f2f6acbfdb812e183f4334a95b990551f942a4caf548f5ce7ef14885f931535ee