Upstream update to 0.7.4; Applied patch suggested in issue 208
Include the
This commit is contained in:
parent
7dad936925
commit
5c28c21bac
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
httplib2-0.4.0.tar.gz
|
httplib2-0.4.0.tar.gz
|
||||||
/httplib2-0.7.2.tar.gz
|
/httplib2-0.7.2.tar.gz
|
||||||
|
/httplib2-0.7.4.tar.gz
|
||||||
|
21
python-httplib2.getCertHost.patch
Normal file
21
python-httplib2.getCertHost.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up ./python2/httplib2/__init__.py.orig ./python2/httplib2/__init__.py
|
||||||
|
--- ./python2/httplib2/__init__.py.orig 2012-05-03 17:09:12.836155079 +1000
|
||||||
|
+++ ./python2/httplib2/__init__.py 2012-05-03 17:10:02.149780584 +1000
|
||||||
|
@@ -942,11 +942,12 @@ class HTTPSConnectionWithTimeout(httplib
|
||||||
|
list: A list of valid host globs.
|
||||||
|
"""
|
||||||
|
if 'subjectAltName' in cert:
|
||||||
|
- return [x[1] for x in cert['subjectAltName']
|
||||||
|
- if x[0].lower() == 'dns']
|
||||||
|
- else:
|
||||||
|
- return [x[0][1] for x in cert['subject']
|
||||||
|
- if x[0][0].lower() == 'commonname']
|
||||||
|
+ for x in cert['subjectAltName']:
|
||||||
|
+ if x[0].lower() == 'dns':
|
||||||
|
+ return x[1]
|
||||||
|
+
|
||||||
|
+ return [x[0][1] for x in cert['subject']
|
||||||
|
+ if x[0][0].lower() == 'commonname']
|
||||||
|
|
||||||
|
def _ValidateCertificateHostname(self, cert, hostname):
|
||||||
|
"""Validates that a given hostname is valid for an SSL certificate.
|
@ -1,6 +1,6 @@
|
|||||||
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||||
Name: python-httplib2
|
Name: python-httplib2
|
||||||
Version: 0.7.2
|
Version: 0.7.4
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A comprehensive HTTP client library
|
Summary: A comprehensive HTTP client library
|
||||||
|
|
||||||
@ -9,7 +9,8 @@ License: MIT
|
|||||||
URL: http://code.google.com/p/httplib2/
|
URL: http://code.google.com/p/httplib2/
|
||||||
Source0: http://httplib2.googlecode.com/files/httplib2-%{version}.tar.gz
|
Source0: http://httplib2.googlecode.com/files/httplib2-%{version}.tar.gz
|
||||||
#Patch0: httplib_py26.diff
|
#Patch0: httplib_py26.diff
|
||||||
Patch1: python-httplib2.certfile.patch
|
Patch1: %{name}.certfile.patch
|
||||||
|
Patch2: %{name}.getCertHost.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: python-setuptools-devel
|
BuildRequires: python-setuptools-devel
|
||||||
@ -24,6 +25,7 @@ other HTTP libraries.
|
|||||||
%setup -q -n httplib2-%{version}
|
%setup -q -n httplib2-%{version}
|
||||||
#%patch0 -p0 -b .issue39
|
#%patch0 -p0 -b .issue39
|
||||||
%patch1 -p0 -b .certfile
|
%patch1 -p0 -b .certfile
|
||||||
|
%patch2 -p0 -b .getCertHost
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS" python setup.py build
|
CFLAGS="$RPM_OPT_FLAGS" python setup.py build
|
||||||
@ -42,13 +44,17 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{python_sitelib}/*
|
%{python_sitelib}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu May 03 2012 Ding-Yi Chen <dchen at redhat.com> - 0.7.4-1
|
||||||
|
- Upstream update to 0.7.4
|
||||||
|
- Applied patch suggested in issue 208
|
||||||
|
|
||||||
* Fri Feb 24 2012 Ding-Yi Chen <dchen at redhat.com> - 0.7.2-1
|
* Fri Feb 24 2012 Ding-Yi Chen <dchen at redhat.com> - 0.7.2-1
|
||||||
- Upstream update to 0.7.2
|
- Upstream update to 0.7.2
|
||||||
Which may fixed http://code.google.com/p/httplib2/issues/detail?id=62
|
Which may fixed http://code.google.com/p/httplib2/issues/detail?id=62
|
||||||
Note this version uses fedora's cert file bundle instead of httplib2
|
Note this version uses fedora's cert file bundle instead of httplib2
|
||||||
default.
|
default.
|
||||||
|
|
||||||
* Fri Jul 29 2011 Ding-Yi Chen <dchen at redhat.com> - 0.4.0-5
|
* Fri Jul 29 2011 Ding-Yi Chen <dchen at redhat.com> - 0.4.0-5.el6
|
||||||
- Apply that address python-httplib2 (GoogleCode Hosted) issue 39
|
- Apply that address python-httplib2 (GoogleCode Hosted) issue 39
|
||||||
http://code.google.com/p/httplib2/issues/detail?id=39
|
http://code.google.com/p/httplib2/issues/detail?id=39
|
||||||
|
|
||||||
@ -66,8 +72,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
- minor spec cleanups
|
- minor spec cleanups
|
||||||
- enable python3 support
|
- enable python3 support
|
||||||
|
|
||||||
* Fri Apr 02 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
* Fri Apr 02 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> - 0.6.0-1
|
||||||
- 0.6.0-1
|
|
||||||
- version upgrade (#566721)
|
- version upgrade (#566721)
|
||||||
|
|
||||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-4
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-4
|
||||||
@ -79,6 +84,5 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.4.0-2
|
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.4.0-2
|
||||||
- Rebuild for Python 2.6
|
- Rebuild for Python 2.6
|
||||||
|
|
||||||
* Thu Dec 27 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
|
* Thu Dec 27 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de> - 0.4.0-1
|
||||||
- 0.4.0-1
|
|
||||||
- initial version
|
- initial version
|
||||||
|
Loading…
Reference in New Issue
Block a user