diff --git a/python-html5lib.spec b/python-html5lib.spec
index 6704802..a5bb994 100644
--- a/python-html5lib.spec
+++ b/python-html5lib.spec
@@ -1,12 +1,11 @@
-%global srcname html5lib
-Name: python-%{srcname}
+Name: python-html5lib
Summary: A python based HTML parser/tokenizer
Version: 1.1
Release: 8%{?dist}
Epoch: 1
License: MIT
URL: https://github.com/html5lib/html5lib-python
-Source: %pypi_source
+Source: %{pypi_source html5lib}
# Fix compatibility with pytest 6
Patch: %{url}/pull/506.patch
@@ -18,7 +17,7 @@ A python based HTML parser/tokenizer based on the WHATWG HTML5
specification for maximum compatibility with major desktop web browsers.
-%package -n python3-%{srcname}
+%package -n python3-html5lib
Summary: %summary
BuildRequires: python3-devel
BuildRequires: python3-setuptools
@@ -34,13 +33,13 @@ BuildRequires: python3dist(chardet)
BuildRequires: python3dist(genshi)
BuildRequires: python3dist(lxml)
-%description -n python3-%{srcname}
+%description -n python3-html5lib
A python based HTML parser/tokenizer based on the WHATWG HTML5
specification for maximum compatibility with major desktop web browsers.
%prep
-%autosetup -p1 -n %{srcname}-%{version}
+%autosetup -p1 -n html5lib-%{version}
# Use standard library unittest.mock instead of 3rd party mock
# From https://github.com/html5lib/html5lib-python/pull/536
@@ -58,11 +57,11 @@ sed -i 's/from mock import/from unittest.mock import/' html5lib/tests/test_meta.
%pytest
-%files -n python3-%{srcname}
+%files -n python3-html5lib
%license LICENSE
%doc CHANGES.rst README.rst
-%{python3_sitelib}/%{srcname}-*.egg-info/
-%{python3_sitelib}/%{srcname}/
+%{python3_sitelib}/html5lib-*.egg-info/
+%{python3_sitelib}/html5lib/
%changelog