Import rpm: 4f046bd71869fa9bc2c8bfd6dbd283a751e028af
This commit is contained in:
commit
107c6dc0da
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/funcsigs-1.0.2.tar.gz
|
88
no-unittest2.patch
Normal file
88
no-unittest2.patch
Normal file
@ -0,0 +1,88 @@
|
||||
diff -rU3 funcsigs-1.0.2.orig/setup.py funcsigs-1.0.2/setup.py
|
||||
--- funcsigs-1.0.2.orig/setup.py 2016-04-26 00:01:13.000000000 +0200
|
||||
+++ funcsigs-1.0.2/setup.py 2019-09-26 17:15:43.693886370 +0200
|
||||
@@ -47,6 +47,5 @@
|
||||
'Programming Language :: Python :: Implementation :: PyPy',
|
||||
'Topic :: Software Development :: Libraries :: Python Modules'
|
||||
],
|
||||
- tests_require = ['unittest2'],
|
||||
- test_suite = 'unittest2.collector',
|
||||
+ test_suite = 'tests',
|
||||
)
|
||||
diff -rU3 funcsigs-1.0.2.orig/tests/test_formatannotation.py funcsigs-1.0.2/tests/test_formatannotation.py
|
||||
--- funcsigs-1.0.2.orig/tests/test_formatannotation.py 2016-04-05 23:32:14.000000000 +0200
|
||||
+++ funcsigs-1.0.2/tests/test_formatannotation.py 2019-09-26 16:49:30.174351893 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
import funcsigs
|
||||
|
||||
-import unittest2 as unittest
|
||||
+import unittest
|
||||
|
||||
class TestFormatAnnotation(unittest.TestCase):
|
||||
def test_string (self):
|
||||
diff -rU3 funcsigs-1.0.2.orig/tests/test_funcsigs.py funcsigs-1.0.2/tests/test_funcsigs.py
|
||||
--- funcsigs-1.0.2.orig/tests/test_funcsigs.py 2016-04-05 23:32:14.000000000 +0200
|
||||
+++ funcsigs-1.0.2/tests/test_funcsigs.py 2019-09-26 16:49:26.315366071 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-import unittest2 as unittest
|
||||
+import unittest
|
||||
|
||||
import doctest
|
||||
import sys
|
||||
diff -rU3 funcsigs-1.0.2.orig/tests/test_inspect.py funcsigs-1.0.2/tests/test_inspect.py
|
||||
--- funcsigs-1.0.2.orig/tests/test_inspect.py 2016-04-05 23:32:14.000000000 +0200
|
||||
+++ funcsigs-1.0.2/tests/test_inspect.py 2019-09-26 17:05:25.946939291 +0200
|
||||
@@ -3,13 +3,24 @@
|
||||
import collections
|
||||
import functools
|
||||
import sys
|
||||
+import contextlib
|
||||
|
||||
-import unittest2 as unittest
|
||||
+import unittest
|
||||
|
||||
import funcsigs as inspect
|
||||
|
||||
+if not hasattr(unittest.TestCase, 'assertRaisesRegex'):
|
||||
+ class TestCase(unittest.TestCase):
|
||||
+ @contextlib.contextmanager
|
||||
+ def assertRaisesRegex(self, error, message):
|
||||
+ with self.assertRaises(error) as cm:
|
||||
+ yield cm
|
||||
+ self.assertRegexpMatches(str(cm.exception), message)
|
||||
+else:
|
||||
+ TestCase = unittest.TestCase
|
||||
|
||||
-class TestSignatureObject(unittest.TestCase):
|
||||
+
|
||||
+class TestSignatureObject(TestCase):
|
||||
@staticmethod
|
||||
def signature(func):
|
||||
sig = inspect.signature(func)
|
||||
@@ -647,7 +658,7 @@
|
||||
""")
|
||||
|
||||
|
||||
-class TestParameterObject(unittest.TestCase):
|
||||
+class TestParameterObject(TestCase):
|
||||
|
||||
def test_signature_parameter_kinds(self):
|
||||
P = inspect.Parameter
|
||||
@@ -761,7 +772,7 @@
|
||||
p.kind = 123
|
||||
|
||||
|
||||
-class TestSignatureBind(unittest.TestCase):
|
||||
+class TestSignatureBind(TestCase):
|
||||
@staticmethod
|
||||
def call(func, *args, **kwargs):
|
||||
sig = inspect.signature(func)
|
||||
@@ -975,7 +986,7 @@
|
||||
self.assertEqual((an_f, 10), partial_f(*ba.args, **ba.kwargs))
|
||||
|
||||
|
||||
-class TestBoundArguments(unittest.TestCase):
|
||||
+class TestBoundArguments(TestCase):
|
||||
|
||||
def test_signature_bound_arguments_unhashable(self):
|
||||
def foo(a): pass
|
150
python-funcsigs.spec
Normal file
150
python-funcsigs.spec
Normal file
@ -0,0 +1,150 @@
|
||||
%global pypi_name funcsigs
|
||||
|
||||
# funcsigs functionality is available in Python 3's inspect module
|
||||
# Nothing should use python3-funcsigs as an external library.
|
||||
%global with_python3 0
|
||||
|
||||
Name: python-%{pypi_name}
|
||||
Version: 1.0.2
|
||||
Release: 13%{?dist}
|
||||
Summary: Python function signatures from PEP362 for Python 2.6, 2.7 and 3.2+
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/testing-cabal/funcsigs?
|
||||
Source0: https://pypi.io/packages/source/f/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python2-setuptools
|
||||
|
||||
%description
|
||||
funcsigs is a backport of the PEP 362 function signature features from
|
||||
Python 3.3's inspect module. The backport is compatible with Python 2.6, 2.7
|
||||
as well as 3.2 and up.
|
||||
|
||||
|
||||
%package -n python2-%{pypi_name}
|
||||
Summary: Python function signatures from PEP362 for Python 2.6, 2.7 and 3.2+
|
||||
%{?python_provide:%python_provide python2-%{pypi_name}}
|
||||
|
||||
%description -n python2-%{pypi_name}
|
||||
funcsigs is a backport of the PEP 362 function signature features from
|
||||
Python 3.3's inspect module. The backport is compatible with Python 2.6, 2.7
|
||||
as well as 3.2 and up.
|
||||
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%package -n python3-%{pypi_name}
|
||||
Summary: Python function signatures from PEP362 for Python 2.6, 2.7 and 3.2+
|
||||
%{?python_provide:%python_provide python3-%{pypi_name}}
|
||||
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
BuildRequires: python3-sphinx
|
||||
BuildRequires: python3-unittest2
|
||||
|
||||
%description -n python3-%{pypi_name}
|
||||
funcsigs is a backport of the PEP 362 function signature features from
|
||||
Python 3.3's inspect module. The backport is compatible with Python 2.6, 2.7
|
||||
as well as 3.2 and up.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -n %{pypi_name}-%{version}
|
||||
# Remove bundled egg-info
|
||||
rm -rf %{pypi_name}.egg-info
|
||||
|
||||
%if 0%{?rhel} && 0%{?rhel} == 7
|
||||
sed -i '/extras_require/,+3d' setup.py
|
||||
%endif
|
||||
|
||||
%build
|
||||
%py2_build
|
||||
%if 0%{?with_python3}
|
||||
%py3_build
|
||||
%endif
|
||||
|
||||
%install
|
||||
# Must do the subpackages' install first because the scripts in /usr/bin are
|
||||
# overwritten with every setup.py install.
|
||||
%if 0%{?with_python3}
|
||||
%py3_install
|
||||
%endif
|
||||
|
||||
export RHEL_ALLOW_PYTHON2_FOR_BUILD=1
|
||||
%py2_install
|
||||
|
||||
|
||||
%check
|
||||
%if 0%{?with_python3}
|
||||
%{__python3} setup.py test
|
||||
%endif
|
||||
|
||||
%files -n python2-%{pypi_name}
|
||||
%doc README.rst
|
||||
%license LICENSE
|
||||
%{python2_sitelib}/%{pypi_name}
|
||||
%{python2_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
|
||||
|
||||
%if 0%{?with_python3}
|
||||
%files -n python3-%{pypi_name}
|
||||
%doc README.rst
|
||||
%license LICENSE
|
||||
%{python3_sitelib}/%{pypi_name}
|
||||
%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Apr 25 2019 Tomas Orsava <torsava@redhat.com> - 1.0.2-13
|
||||
- Bumping due to problems with modular RPM upgrade path
|
||||
- Resolves: rhbz#1695587
|
||||
|
||||
* Fri Jul 13 2018 Lumír Balhar <lbalhar@redhat.com> - 1.0.2-12
|
||||
- First version for python27 module
|
||||
|
||||
* Mon Jul 09 2018 Petr Viktorin <pviktori@redhat.com> - 1.0.2-11
|
||||
- Disable the python3 subpackage
|
||||
Functionality of funcsigs is available in Python 3's inspect module.
|
||||
|
||||
* Mon Jul 02 2018 Petr Viktorin <pviktori@redhat.com> - 1.0.2-10
|
||||
- Skip python2 tests to allow removing python2-unittest2 from the distribution
|
||||
- Fix workaround for allowing Python 2 for build
|
||||
|
||||
* Mon Jun 25 2018 Petr Viktorin <pviktori@redhat.com> - 1.0.2-9
|
||||
- Allow Python 2 for build
|
||||
see https://hurl.corp.redhat.com/rhel8-py2
|
||||
- Switch to python3-sphinx
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Fri Sep 29 2017 Troy Dawson <tdawson@redhat.com> - 1.0.2-7
|
||||
- Cleanup spec file conditionals
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Dec 13 2016 Stratakis Charalampos <cstratak@redhat.com> - 1.0.2-4
|
||||
- Enable tests
|
||||
|
||||
* Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.0.2-3
|
||||
- Rebuild for Python 3.6
|
||||
- Disable python3 tests for now
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Sat Jun 11 2016 Haïkel Guémar <hguemar@fedoraproject.org> - 1.0.2-1
|
||||
- Upstream 1.0.2 (RHBZ#1341262)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Dec 4 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 0.4-2
|
||||
- Add license file in doc subpackage
|
||||
|
||||
* Wed Dec 02 2015 Haïkel Guémar <hguemar@fedoraproject.org> - 0.4-1
|
||||
- Initial package.
|
Loading…
Reference in New Issue
Block a user