Import python-falcon-3.1.1
This commit is contained in:
commit
6c6df17f9f
1
.falcon.metadata
Normal file
1
.falcon.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
38834c5560bac853d92e7727cb43cc0c6f82d736 SOURCES/falcon-3.1.1.tar.gz
|
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/falcon-3.1.1.tar.gz
|
61
SOURCES/0001-Remove-vendored-mimeparse.patch
Normal file
61
SOURCES/0001-Remove-vendored-mimeparse.patch
Normal file
@ -0,0 +1,61 @@
|
|||||||
|
From de4b019a6e6d30b11dfc6b0d4033a33b2c28e5b4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Carl George <carl@george.computer>
|
||||||
|
Date: Tue, 12 Oct 2021 12:04:25 -0500
|
||||||
|
Subject: [PATCH] Remove vendored mimeparse
|
||||||
|
|
||||||
|
---
|
||||||
|
falcon/media/handlers.py | 2 +-
|
||||||
|
falcon/request.py | 2 +-
|
||||||
|
setup.py | 3 +--
|
||||||
|
3 files changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/falcon/media/handlers.py b/falcon/media/handlers.py
|
||||||
|
index 8ab8d58..899b83a 100644
|
||||||
|
--- a/falcon/media/handlers.py
|
||||||
|
+++ b/falcon/media/handlers.py
|
||||||
|
@@ -11,7 +11,7 @@ from falcon.media.multipart import MultipartParseOptions
|
||||||
|
from falcon.media.urlencoded import URLEncodedFormHandler
|
||||||
|
from falcon.util import deprecation
|
||||||
|
from falcon.util import misc
|
||||||
|
-from falcon.vendor import mimeparse
|
||||||
|
+import mimeparse
|
||||||
|
|
||||||
|
|
||||||
|
class MissingDependencyHandler:
|
||||||
|
diff --git a/falcon/request.py b/falcon/request.py
|
||||||
|
index 7282ace..1df06fa 100644
|
||||||
|
--- a/falcon/request.py
|
||||||
|
+++ b/falcon/request.py
|
||||||
|
@@ -32,7 +32,7 @@ from falcon.util import structures
|
||||||
|
from falcon.util.misc import isascii
|
||||||
|
from falcon.util.uri import parse_host
|
||||||
|
from falcon.util.uri import parse_query_string
|
||||||
|
-from falcon.vendor import mimeparse
|
||||||
|
+import mimeparse
|
||||||
|
|
||||||
|
DEFAULT_ERROR_LOG_FORMAT = ('{0:%Y-%m-%d %H:%M:%S} [FALCON] [ERROR]'
|
||||||
|
' {1} {2}{3} => ')
|
||||||
|
diff --git a/setup.py b/setup.py
|
||||||
|
index 3c8e979..a24646d 100644
|
||||||
|
--- a/setup.py
|
||||||
|
+++ b/setup.py
|
||||||
|
@@ -13,7 +13,7 @@ MYDIR = path.abspath(os.path.dirname(__file__))
|
||||||
|
VERSION = importlib.import_module('falcon.version')
|
||||||
|
VERSION = VERSION.__version__
|
||||||
|
|
||||||
|
-REQUIRES = []
|
||||||
|
+REQUIRES = ['python-mimeparse>=1.5.2']
|
||||||
|
|
||||||
|
try:
|
||||||
|
sys.pypy_version_info
|
||||||
|
@@ -48,7 +48,6 @@ if CYTHON:
|
||||||
|
'falcon.media',
|
||||||
|
'falcon.routing',
|
||||||
|
'falcon.util',
|
||||||
|
- 'falcon.vendor.mimeparse',
|
||||||
|
]
|
||||||
|
|
||||||
|
modules_to_exclude = [
|
||||||
|
--
|
||||||
|
2.31.1
|
||||||
|
|
249
SPECS/python-falcon.spec
Normal file
249
SPECS/python-falcon.spec
Normal file
@ -0,0 +1,249 @@
|
|||||||
|
# what it's called on pypi
|
||||||
|
%global srcname falcon
|
||||||
|
# what it's imported as
|
||||||
|
%global libname %{srcname}
|
||||||
|
# name of egg info directory
|
||||||
|
%global eggname %{srcname}
|
||||||
|
# package name fragment
|
||||||
|
%global pkgname %{srcname}
|
||||||
|
|
||||||
|
%global common_description %{expand:
|
||||||
|
Falcon is a reliable, high-performance Python web framework for building
|
||||||
|
large-scale app backends and microservices. It encourages the REST
|
||||||
|
architectural style, and tries to do as little as possible while remaining
|
||||||
|
highly effective.}
|
||||||
|
|
||||||
|
%bcond_without tests
|
||||||
|
|
||||||
|
|
||||||
|
Name: python-%{pkgname}
|
||||||
|
Version: 3.1.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: An unladen web framework for building APIs and app backends
|
||||||
|
License: ASL 2.0
|
||||||
|
URL: https://falconframework.org
|
||||||
|
Source0: %pypi_source
|
||||||
|
|
||||||
|
# downstream-only patch to remove bundled library
|
||||||
|
Patch0: 0001-Remove-vendored-mimeparse.patch
|
||||||
|
|
||||||
|
BuildRequires: gcc
|
||||||
|
|
||||||
|
|
||||||
|
%description %{common_description}
|
||||||
|
|
||||||
|
|
||||||
|
%package -n python3-%{pkgname}
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: %{py3_dist setuptools cython}
|
||||||
|
%if %{with tests}
|
||||||
|
# requirements/tests
|
||||||
|
BuildRequires: %{py3_dist pytest pyyaml requests testtools}
|
||||||
|
BuildRequires: %{py3_dist pytest-asyncio httpx uvicorn aiofiles websockets}
|
||||||
|
BuildRequires: %{py3_dist cbor2 msgpack mujson ujson python-mimeparse}
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
|
%description -n python3-%{pkgname} %{common_description}
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -p 1 -n %{srcname}-%{version}
|
||||||
|
rm -rf %{eggname}.egg-info
|
||||||
|
|
||||||
|
# related to Patch0
|
||||||
|
rm -rf falcon/vendor
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%py3_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%py3_install
|
||||||
|
|
||||||
|
|
||||||
|
%if %{with tests}
|
||||||
|
%check
|
||||||
|
# tests/asgi/test_cythonized_asgi.py fails when cython is installed
|
||||||
|
%pytest --verbose \
|
||||||
|
--ignore tests/asgi/test_cythonized_asgi.py \
|
||||||
|
tests
|
||||||
|
%endif
|
||||||
|
|
||||||
|
|
||||||
|
%files -n python3-%{pkgname}
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.rst
|
||||||
|
%{python3_sitearch}/%{libname}
|
||||||
|
%exclude %{python3_sitearch}/examples
|
||||||
|
%{python3_sitearch}/%{eggname}-%{version}-py%{python3_version}.egg-info
|
||||||
|
%{_bindir}/falcon-bench
|
||||||
|
%{_bindir}/falcon-inspect-app
|
||||||
|
%{_bindir}/falcon-print-routes
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Oct 12 2021 Carl George <carl@george.computer> - 3.0.1-1
|
||||||
|
- Latest upstream
|
||||||
|
- Resolves: rhbz#1959197
|
||||||
|
|
||||||
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.0-4
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 3.0.0-3
|
||||||
|
- Rebuilt for Python 3.10
|
||||||
|
|
||||||
|
* Wed Apr 21 2021 Carl George <carl@george.computer> - 3.0.0-2
|
||||||
|
- Run media handlers tests
|
||||||
|
|
||||||
|
* Mon Apr 12 2021 Carl George <carl@george.computer> - 3.0.0-1
|
||||||
|
- Latest upstream
|
||||||
|
- Fixes: rhbz#1684836
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-3
|
||||||
|
- Rebuilt for Python 3.9
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Sep 05 2019 Javier Peña <jpena@redhat.com> - 2.0.0-1
|
||||||
|
- Updated to upstream 2.0.0
|
||||||
|
- This version removed Python 2.7 support
|
||||||
|
|
||||||
|
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.4.1-9
|
||||||
|
- Rebuilt for Python 3.8
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Apr 22 2019 Carl George <carl@george.computer> - 1.4.1-7
|
||||||
|
- Disable python2 subpackage on Fedora 31+ rhbz#1701670
|
||||||
|
- Run tests from buildroot, not builddir
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.4.1-4
|
||||||
|
- Rebuilt for Python 3.7
|
||||||
|
|
||||||
|
* Mon Feb 26 2018 Carl George <carl@george.computer> - 1.4.1-3
|
||||||
|
- Add BuildRequires for gcc
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 17 2018 Carl George <carl@george.computer> - 1.4.1-1
|
||||||
|
- Latest upstream rhbz#1535255
|
||||||
|
|
||||||
|
* Tue Jan 16 2018 Carl George <carl@george.computer> - 1.4.0-1
|
||||||
|
- Latest upstream rhbz#1528076
|
||||||
|
- Recommend ujson on Fedora
|
||||||
|
|
||||||
|
* Thu Sep 07 2017 Carl George <carl@george.computer> - 1.3.0-1
|
||||||
|
- Latest upstream
|
||||||
|
- Enable python34 EPEL subpackage
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 13 2017 Carl George <carl.george@rackspace.com> - 1.2.0-4
|
||||||
|
- The test test_deprecated_decorator fails in Koji, add patch006 to skip
|
||||||
|
|
||||||
|
* Fri Jun 09 2017 Carl George <carl.george@rackspace.com> - 1.2.0-3
|
||||||
|
- Only run test suite on F26+ due to pytest 3 requirement
|
||||||
|
|
||||||
|
* Thu May 04 2017 Carl George <carl.george@rackspace.com> - 1.2.0-2
|
||||||
|
- Spec file clean up
|
||||||
|
- Fix rpmlint error caused by srcname being undefined
|
||||||
|
|
||||||
|
* Tue May 02 2017 Carl George <carl.george@rackspace.com> - 1.2.0-1
|
||||||
|
- Latest upstream
|
||||||
|
- Switch from nosetests to pytest
|
||||||
|
- Require mimeparse >= 1.5.2 (related rhbz#1339379)
|
||||||
|
- Add Patch005 to create versioned scripts
|
||||||
|
- Include LICENSE
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 1.0.0-3
|
||||||
|
- Rebuild for Python 3.6
|
||||||
|
|
||||||
|
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||||
|
|
||||||
|
* Tue May 24 2016 Carl George <carl.george@rackspace.com> - 1.0.0-1
|
||||||
|
- Latest upstream
|
||||||
|
- Patch002 and Patch003 fixed upstream
|
||||||
|
- Patch004 added to make test suite pass with old version of mimeparse
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Dec 05 2015 Carl George <carl.george@rackspace.com> - 0.3.0-4
|
||||||
|
- Specify minimum version of python-six
|
||||||
|
- Change python3 control macros to a bcond macro
|
||||||
|
- Add bcond macro to optionally require explicit python2 names
|
||||||
|
|
||||||
|
* Mon Nov 16 2015 Carl George <carl.george@rackspace.com> - 0.3.0-3
|
||||||
|
- Add patch to disable coverage
|
||||||
|
- Add patch to skip test_request_cookie_parsing on Python 3.5
|
||||||
|
|
||||||
|
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||||
|
|
||||||
|
* Tue Sep 01 2015 Carl George <carl.george@rackspace.com> - 0.3.0-1
|
||||||
|
- Upstream 0.3.0
|
||||||
|
- Add patch1 to fix GH#558
|
||||||
|
- Update to new packaging guidelines
|
||||||
|
- Add new test suite dependencies
|
||||||
|
- Call nosetests directly
|
||||||
|
|
||||||
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.10-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Nov 05 2014 Haïkel Guémar <hguemar@fedoraproject.org> - 0.1.10-5
|
||||||
|
- Upstream 0.1.10
|
||||||
|
- No python3 in EL7
|
||||||
|
|
||||||
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.8-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.8-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon May 19 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 0.1.8-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
|
||||||
|
|
||||||
|
* Mon Mar 24 2014 Jamie Lennox <jamielennox@redhat.com> - 0.1.8-2
|
||||||
|
- Remove now missing doc files
|
||||||
|
- Remove installed test files
|
||||||
|
|
||||||
|
* Thu Feb 27 2014 Jamie Lennox <jamielennox@redhat.com> - 0.1.8-1
|
||||||
|
- Bump to 0.1.8
|
||||||
|
|
||||||
|
* Mon Sep 23 2013 Jamie Lennox <jamielennox@redhat.com> - 0.1.7-1
|
||||||
|
- Add Python 3 packaging details and patch to fix for Python 3.
|
||||||
|
- Remove falcon-bench from package.
|
||||||
|
- Added check section.
|
||||||
|
|
||||||
|
* Wed Sep 18 2013 Jamie Lennox <jamielennox@redhat.com> - 0.1.7-1
|
||||||
|
- Initial package.
|
Loading…
Reference in New Issue
Block a user