Update to 0.0.16
This commit is contained in:
parent
49020e2a34
commit
c368529b2e
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
|||||||
/drgn-0.0.13.tar.gz
|
/drgn-0.0.13.tar.gz
|
||||||
/drgn-0.0.14.tar.gz
|
/drgn-0.0.14.tar.gz
|
||||||
/drgn-0.0.15.tar.gz
|
/drgn-0.0.15.tar.gz
|
||||||
|
/drgn-0.0.16.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From ad2119aaa3a08896a94c0ae0ad5c12a3af96197a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Omar Sandoval <osandov@osandov.com>
|
|
||||||
Date: Thu, 12 Aug 2021 14:39:29 -0700
|
|
||||||
Subject: [PATCH] Tell pytest not to match classes/functions starting with
|
|
||||||
"test"
|
|
||||||
|
|
||||||
I run tests with setup.py or with the unittest module, but Fedora uses
|
|
||||||
pytest. pytest assumes that any class or function starting with "test"
|
|
||||||
is a test case, which is not always the case (e.g.,
|
|
||||||
drgn.helpers.linux.bitops.test_bit()). We've hit this at least twice, in
|
|
||||||
#94 and #112.
|
|
||||||
|
|
||||||
All of our tests are unittest.TestCase cases, so we can tell pytest to
|
|
||||||
not match anything else. I'm using pytest.ini instead of pyproject.toml
|
|
||||||
because pytest only started supporting the latter relatively recently.
|
|
||||||
|
|
||||||
Closes #112.
|
|
||||||
|
|
||||||
Signed-off-by: Omar Sandoval <osandov@osandov.com>
|
|
||||||
---
|
|
||||||
pytest.ini | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
create mode 100644 pytest.ini
|
|
||||||
|
|
||||||
diff --git a/pytest.ini b/pytest.ini
|
|
||||||
new file mode 100644
|
|
||||||
index 00000000..976c8482
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/pytest.ini
|
|
||||||
@@ -0,0 +1,3 @@
|
|
||||||
+[pytest]
|
|
||||||
+python_classes =
|
|
||||||
+python_functions =
|
|
@ -14,15 +14,13 @@ drgn exposes the types and variables in a program for easy, expressive
|
|||||||
scripting in Python.}
|
scripting in Python.}
|
||||||
|
|
||||||
Name: python-%{pypi_name}
|
Name: python-%{pypi_name}
|
||||||
Version: 0.0.15
|
Version: 0.0.16
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
Summary: Scriptable debugger library
|
Summary: Programmable debugger
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: https://github.com/osandov/drgn
|
URL: https://github.com/osandov/drgn
|
||||||
Source0: %{pypi_source}
|
Source0: %{pypi_source}
|
||||||
# Tell pytest not to match classes/functions starting with "test"
|
|
||||||
Patch0: %{url}/commit/ad2119aaa3a08896a94c0ae0ad5c12a3af96197a.patch
|
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: python3dist(setuptools)
|
BuildRequires: python3dist(setuptools)
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (drgn-0.0.15.tar.gz) = e396f1e271c29a081def4d9ed8adba000c4e5f5ea63d61556308eb76179f01ef0b8eff9e52633d7f2cccb76e465353b49493b327f4f736732e600b438ca70962
|
SHA512 (drgn-0.0.16.tar.gz) = f1fc9aaddbd65d598d5668b69eb4d98df04c35343412e0e68c9702be31b52faba99abf969a3b39a6007ce39153f4c295e5721676c2d645697b34a3571599aad6
|
||||||
|
Loading…
Reference in New Issue
Block a user