python-docs/SOURCES/python-2.7-texinfomakefile....

34 lines
1.4 KiB
Diff

diff --git a/Doc/Makefile b/Doc/Makefile
index ebabc02..8a396a2 100644
--- a/Doc/Makefile
+++ b/Doc/Makefile
@@ -13,7 +13,7 @@ DISTVERSION = $(shell $(PYTHON) tools/extensions/patchlevel.py)
ALLSPHINXOPTS = -b $(BUILDER) -d build/doctrees -D latex_elements.papersize=$(PAPER) \
$(SPHINXOPTS) . build/$(BUILDER) $(SOURCES)
-.PHONY: help build html htmlhelp latex text changes linkcheck \
+.PHONY: help build html htmlhelp latex text texinfo changes linkcheck \
suspicious coverage doctest pydoc-topics htmlview clean dist check serve \
autobuild-dev autobuild-stable
@@ -24,6 +24,7 @@ help:
@echo " htmlview to open the index page built by the html target in your browser"
@echo " htmlhelp to make HTML files and a HTML help project"
@echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " texinfo to make Texinfo (.texi) files"
@echo " text to make plain text files"
@echo " epub to make EPUB files"
@echo " changes to make an overview over all changed/added/deprecated items"
@@ -59,6 +60,11 @@ text: BUILDER = text
text: build
@echo "Build finished; the text files are in build/text."
+texinfo: BUILDER = texinfo
+texinfo: build
+ @echo "Build finished; the TeXInfo files are in build/texinfo."
+ @echo "Run \`make info' in that directory to generate the info files."
+
epub: BUILDER = epub
epub: build
@echo "Build finished; the epub files are in build/epub."