Update to 41.0.3
- Update to upstream version 41.0.3 - Use pyo3 0.19 Resolves: rhbz#2211237
This commit is contained in:
parent
9421b4a468
commit
7b18e1445d
2
.gitignore
vendored
2
.gitignore
vendored
@ -55,3 +55,5 @@
|
||||
/cryptography-40.0.1-vendor.tar.bz2
|
||||
/cryptography-40.0.2.tar.gz
|
||||
/cryptography-40.0.2-vendor.tar.bz2
|
||||
/cryptography-41.0.3.tar.gz
|
||||
/cryptography-41.0.3-vendor.tar.bz2
|
||||
|
52
pyo3-0.19.patch
Normal file
52
pyo3-0.19.patch
Normal file
@ -0,0 +1,52 @@
|
||||
diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
|
||||
index 01fba147e..9dd060f8b 100644
|
||||
--- a/src/rust/Cargo.toml
|
||||
+++ b/src/rust/Cargo.toml
|
||||
@@ -9,7 +9,7 @@ rust-version = "1.56.0"
|
||||
|
||||
[dependencies]
|
||||
once_cell = "1"
|
||||
-pyo3 = { version = "0.18", features = ["abi3-py37"] }
|
||||
+pyo3 = { version = "0.19", features = ["abi3-py37"] }
|
||||
asn1 = { version = "0.15.2", default-features = false }
|
||||
cryptography-cffi = { path = "cryptography-cffi" }
|
||||
cryptography-x509 = { path = "cryptography-x509" }
|
||||
diff --git a/src/rust/cryptography-cffi/Cargo.toml b/src/rust/cryptography-cffi/Cargo.toml
|
||||
index 65051c2a4..24e53991b 100644
|
||||
--- a/src/rust/cryptography-cffi/Cargo.toml
|
||||
+++ b/src/rust/cryptography-cffi/Cargo.toml
|
||||
@@ -8,7 +8,7 @@ publish = false
|
||||
rust-version = "1.56.0"
|
||||
|
||||
[dependencies]
|
||||
-pyo3 = { version = "0.18", features = ["abi3-py37"] }
|
||||
+pyo3 = { version = "0.19", features = ["abi3-py37"] }
|
||||
openssl-sys = "0.9.88"
|
||||
|
||||
[build-dependencies]
|
||||
diff --git a/src/rust/src/x509/crl.rs b/src/rust/src/x509/crl.rs
|
||||
index 923015035..1380d6eb8 100644
|
||||
--- a/src/rust/src/x509/crl.rs
|
||||
+++ b/src/rust/src/x509/crl.rs
|
||||
@@ -145,7 +145,7 @@ impl CertificateRevocationList {
|
||||
revoked_certs
|
||||
});
|
||||
|
||||
- if idx.is_instance_of::<pyo3::types::PySlice>()? {
|
||||
+ if idx.is_instance_of::<pyo3::types::PySlice>() {
|
||||
let indices = idx
|
||||
.downcast::<pyo3::types::PySlice>()?
|
||||
.indices(self.len().try_into().unwrap())?;
|
||||
diff --git a/src/rust/src/x509/extensions.rs b/src/rust/src/x509/extensions.rs
|
||||
index 98d1bd63b..dcf28833f 100644
|
||||
--- a/src/rust/src/x509/extensions.rs
|
||||
+++ b/src/rust/src/x509/extensions.rs
|
||||
@@ -211,7 +211,7 @@ fn encode_certificate_policies(
|
||||
let mut qualifiers = vec![];
|
||||
for py_qualifier in py_policy_qualifiers.iter()? {
|
||||
let py_qualifier = py_qualifier?;
|
||||
- let qualifier = if py_qualifier.is_instance_of::<pyo3::types::PyString>()? {
|
||||
+ let qualifier = if py_qualifier.is_instance_of::<pyo3::types::PyString>() {
|
||||
let cps_uri = match asn1::IA5String::new(py_qualifier.extract()?) {
|
||||
Some(s) => s,
|
||||
None => {
|
@ -5,8 +5,8 @@
|
||||
%global srcname cryptography
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 40.0.2
|
||||
Release: 5%{?dist}
|
||||
Version: 41.0.3
|
||||
Release: 1%{?dist}
|
||||
Summary: PyCA's cryptography library
|
||||
|
||||
# cryptography is dual licensed under the Apache-2.0 and BSD-3-Clause,
|
||||
@ -19,6 +19,8 @@ Source0: https://github.com/pyca/cryptography/archive/%{version}/%{srcnam
|
||||
Source1: cryptography-%{version}-vendor.tar.bz2
|
||||
Source2: conftest-skipper.py
|
||||
|
||||
Patch1: pyo3-0.19.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: openssl-devel
|
||||
@ -69,8 +71,10 @@ cryptography is a package designed to expose cryptographic primitives and
|
||||
recipes to Python developers.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{srcname}-%{version}
|
||||
%autosetup -p1 -N -n %{srcname}-%{version}
|
||||
%if 0%{?fedora}
|
||||
# patch pyo3 depedency
|
||||
%autopatch -p1 1
|
||||
%cargo_prep
|
||||
rm src/rust/Cargo.lock
|
||||
%else
|
||||
@ -131,6 +135,10 @@ PYTHONPATH=${PWD}/vectors:%{buildroot}%{python3_sitearch} \
|
||||
%{python3_sitearch}/%{srcname}-%{version}-py*.egg-info
|
||||
|
||||
%changelog
|
||||
* Wed Aug 09 2023 Christian Heimes <cheimes@redhat.com> - 41.0.3-1
|
||||
- Update to 41.0.3, resolves rhbz#2211237
|
||||
- Use pyo3 0.19
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 40.0.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (cryptography-40.0.2.tar.gz) = 4f49a71cc7348cf90ff4e67d73486a07e065efdc3e321c7f2a642dd459057a90b1c26055bdbed076ebe5b8ea4ec544aaa62b9811fd62f0d818af7e0687b4aa9e
|
||||
SHA512 (cryptography-40.0.2-vendor.tar.bz2) = d45692545b50a1995837ec61b193f395bf4de021e3c4f059e3c3cc705b1b09628b1e8f00efd1d0f3f0936dc66e39cb2ac9defe484f952552e7b0e402e947fd6d
|
||||
SHA512 (cryptography-41.0.3.tar.gz) = a1b3c922dc1cc527af152e3d26d65754806c4eeef5e3bcb13e5d86e67c618a7a04de6ca182bc332ff36f3c670b9e5581e6f609f738e0236ada89aa65681fa0cd
|
||||
SHA512 (cryptography-41.0.3-vendor.tar.bz2) = 67f0575a1ff53bfba01b14f01f79f2442b0971c67c23eb32ebf77813c7a7e22efdcea3ed6926712cb4d875f71b6f21d24c105b3cdad51e24dc84fa3995edd381
|
||||
|
Loading…
Reference in New Issue
Block a user