New upstream release: 0.8

This commit is contained in:
Nathaniel McCallum 2015-03-13 10:43:13 -04:00
parent 6c8f1e1f5c
commit 0773ac1a4f
4 changed files with 8 additions and 44 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/cryptography-0.6.1.tar.gz
/cryptography-0.7.2.tar.gz
/cryptography-0.8.tar.gz

View File

@ -1,39 +0,0 @@
From e8179e79bcb1d8d6e09fffe8e0123afce09ce02d Mon Sep 17 00:00:00 2001
From: Donald Stufft <donald@stufft.io>
Date: Thu, 19 Feb 2015 22:37:49 -0500
Subject: [PATCH] Pass the sys.path into the subprocess
If we're running tests via ``python setup.py test`` in a clean
environment then all of our dependencies are going to be installed
into either the current directory or the .eggs directory. However the
subprocess won't know to activate these dependencies, so we'll get it
to do so by passing our entire sys.path into the subprocess via the
PYTHONPATH environment variable.
---
tests/hazmat/backends/test_openssl.py | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/tests/hazmat/backends/test_openssl.py b/tests/hazmat/backends/test_openssl.py
index 2bf66a0..0e4d75e 100644
--- a/tests/hazmat/backends/test_openssl.py
+++ b/tests/hazmat/backends/test_openssl.py
@@ -234,9 +234,19 @@ def test_osrandom_engine_is_default(self, tmpdir):
)
engine_name = tmpdir.join('engine_name')
+ # If we're running tests via ``python setup.py test`` in a clean
+ # environment then all of our dependencies are going to be installed
+ # into either the current directory or the .eggs directory. However the
+ # subprocess won't know to activate these dependencies, so we'll get it
+ # to do so by passing our entire sys.path into the subprocess via the
+ # PYTHONPATH environment variable.
+ env = os.environ.copy()
+ env["PYTHONPATH"] = os.pathsep.join(sys.path)
+
with engine_name.open('w') as out:
subprocess.check_call(
[sys.executable, "-c", engine_printer],
+ env=env,
stdout=out
)

View File

@ -6,15 +6,14 @@
%endif
Name: python-cryptography
Version: 0.7.2
Release: 2%{?dist}
Version: 0.8
Release: 1%{?dist}
Summary: PyCA's cryptography library
Group: Development/Libraries
License: ASL 2.0 or BSD
URL: https://cryptography.io/en/latest/
Source0: https://pypi.python.org/packages/source/c/cryptography/cryptography-%{version}.tar.gz
Patch0: python-cryptography-0.7.2-testspath.patch
BuildRequires: openssl-devel
BuildRequires: python-enum34
@ -66,7 +65,6 @@ recipes to Python developers.
%prep
%setup -q -n cryptography-%{version}
%patch0 -p1
%if 0%{?with_python3}
rm -rf %{py3dir}
@ -123,6 +121,10 @@ popd
%changelog
* Fri Mar 13 2015 Nathaniel McCallum <nathaniel@natemccallum.com> - 0.8-1
- New upstream release
- Remove upstreamed patch
* Wed Mar 04 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-2
- Add python3-cryptography-vectors build requires
- Add python-enum34 requires

View File

@ -1 +1 @@
a62beaac9f3a78109dba6d31db98cce9 cryptography-0.7.2.tar.gz
c0871039903e8b554179fd2b30a6647d cryptography-0.8.tar.gz