update to 1.1.fb1
Signed-off-by: Andy Grover <agrover@redhat.com>
This commit is contained in:
parent
cd1faa86e8
commit
61229f1acc
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/configshell-1.99.1.git987b63b.tar.gz
|
||||
/1.1
|
||||
/v1.1.fb1
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/configshell/__init__.py b/configshell/__init__.py
|
||||
index 9bfcdb3..1614267 100644
|
||||
--- a/configshell/__init__.py
|
||||
+++ b/configshell/__init__.py
|
||||
@@ -21,7 +21,7 @@ from shell import ConfigShell
|
||||
from node import ConfigNode, ExecutionError
|
||||
from prefs import Prefs
|
||||
|
||||
-__version__ = 'GIT_VERSION'
|
||||
+__version__ = '987b63b'
|
||||
__author__ = "Jerome Martin <jxm@risingtidesystems.com>"
|
||||
__url__ = "http://www.risingtidesystems.com"
|
||||
__description__ = "A framework to implement simple but nice CLIs."
|
@ -1,50 +0,0 @@
|
||||
From 06b7577eec64de5cca72496127fc0cdde4195c7a Mon Sep 17 00:00:00 2001
|
||||
From: Andy Grover <agrover@redhat.com>
|
||||
Date: Thu, 25 Aug 2011 13:39:15 -0700
|
||||
Subject: [PATCH] Do not require epydoc at runtime
|
||||
|
||||
It's a little excessive to require the entire epydoc package so that
|
||||
configshell can output italic/bold help text. If it's present, use it,
|
||||
but otherwise just print plaintext.
|
||||
|
||||
Signed-off-by: Andy Grover <agrover@redhat.com>
|
||||
---
|
||||
configshell/console.py | 15 ++++++++++++++-
|
||||
1 files changed, 14 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/configshell/console.py b/configshell/console.py
|
||||
index 52558dd..a6871e1 100644
|
||||
--- a/configshell/console.py
|
||||
+++ b/configshell/console.py
|
||||
@@ -23,7 +23,12 @@ import prefs
|
||||
import struct
|
||||
import termios
|
||||
import textwrap
|
||||
-import epydoc.markup.epytext
|
||||
+
|
||||
+# avoid requiring epydoc at runtime
|
||||
+try:
|
||||
+ import epydoc.markup.epytext
|
||||
+except ImportError:
|
||||
+ pass
|
||||
|
||||
class Console(object):
|
||||
'''
|
||||
@@ -150,6 +155,14 @@ class Console(object):
|
||||
text = self.dedent(text)
|
||||
try:
|
||||
dom_tree = epydoc.markup.epytext.parse(text, None)
|
||||
+ except NameError:
|
||||
+ # epydoc not installed, strip markup
|
||||
+ dom_tree = text
|
||||
+ dom_tree = dom_tree.replace("B{", "")
|
||||
+ dom_tree = dom_tree.replace("I{", "")
|
||||
+ dom_tree = dom_tree.replace("C{", "")
|
||||
+ dom_tree = dom_tree.replace("}", "")
|
||||
+ dom_tree += "\n"
|
||||
except:
|
||||
self.display(text)
|
||||
raise
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,18 +1,16 @@
|
||||
# Copyright 2011, Red Hat
|
||||
|
||||
%global oname configshell-fedora
|
||||
%global oname configshell-fb
|
||||
|
||||
Name: python-configshell
|
||||
License: AGPLv3
|
||||
Group: System Environment/Libraries
|
||||
Summary: A framework to implement simple but nice CLIs
|
||||
Epoch: 1
|
||||
Version: 1.1
|
||||
Release: 2%{?dist}
|
||||
URL: https://github.com/agrover/configshell-fedora
|
||||
Source: https://github.com/agrover/%{oname}/tarball/%{version}
|
||||
Patch1: %{name}-git-version.patch
|
||||
Patch2: %{name}-remove-epydoc-dep.patch
|
||||
Version: 1.1.fb1
|
||||
Release: 1%{?dist}
|
||||
URL: https://github.com/agrover/configshell-fb
|
||||
Source: https://github.com/agrover/%{oname}/tarball/v%{version}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
BuildRequires: python-devel epydoc python-simpleparse python-urwid
|
||||
@ -23,9 +21,7 @@ A framework to implement simple but nice configuration-oriented
|
||||
command-line interfaces.
|
||||
|
||||
%prep
|
||||
%setup -q -n agrover-%{oname}-3ba5560
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%setup -q -n agrover-%{oname}-b76d10b
|
||||
|
||||
%build
|
||||
%{__python} setup.py build
|
||||
@ -44,6 +40,12 @@ rm -rf %{buildroot}
|
||||
%doc COPYING README
|
||||
|
||||
%changelog
|
||||
* Tue Dec 6 2011 Andy Grover <agrover@redhat.com> - 1:1.1.fb1-1
|
||||
- New upstream source and release
|
||||
- Remove patches:
|
||||
* python-configshell-remove-epydoc-dep.patch
|
||||
* python-configshell-git-version.patch
|
||||
|
||||
* Mon Nov 21 2011 Andy Grover <agrover@redhat.com> - 1:1.1-2
|
||||
- Properly update changelog
|
||||
- Sync version with upstream, Epoch used
|
||||
|
Loading…
Reference in New Issue
Block a user