59 lines
1.7 KiB
Diff
59 lines
1.7 KiB
Diff
From 1b5abc5fa73df1ff33b138c337dfce1bb439cfc1 Mon Sep 17 00:00:00 2001
|
|
From: Haikel Guemar <hguemar@fedoraproject.org>
|
|
Date: Thu, 21 Jun 2018 09:25:02 +0200
|
|
Subject: [PATCH 1/1] Fix date util version for EL7
|
|
|
|
---
|
|
requirements.txt | 4 ++--
|
|
setup.cfg | 4 ++--
|
|
setup.py | 4 ++--
|
|
3 files changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/requirements.txt b/requirements.txt
|
|
index b8db4b4..6e74c23 100644
|
|
--- a/requirements.txt
|
|
+++ b/requirements.txt
|
|
@@ -1,6 +1,6 @@
|
|
tox>=2.5.0,<3.0.0
|
|
-python-dateutil>=2.1,<2.7.0; python_version=="2.6"
|
|
-python-dateutil>=2.1,<3.0.0; python_version>="2.7"
|
|
+python-dateutil>=1.4,<2.7.0; python_version=="2.6"
|
|
+python-dateutil>=1.4,<3.0.0; python_version>="2.7"
|
|
nose==1.3.7
|
|
mock==1.3.0
|
|
wheel==0.24.0
|
|
diff --git a/setup.cfg b/setup.cfg
|
|
index a6878a2..05c72d5 100644
|
|
--- a/setup.cfg
|
|
+++ b/setup.cfg
|
|
@@ -3,8 +3,8 @@ universal = 1
|
|
|
|
[metadata]
|
|
requires-dist =
|
|
- python-dateutil>=2.1,<2.7.0; python_version=="2.6"
|
|
- python-dateutil>=2.1,<3.0.0; python_version>="2.7"
|
|
+ python-dateutil>=1.4,<2.7.0; python_version=="2.6"
|
|
+ python-dateutil>=1.4,<3.0.0; python_version>="2.7"
|
|
jmespath>=0.7.1,<1.0.0
|
|
docutils>=0.10
|
|
ordereddict==1.1; python_version=="2.6"
|
|
diff --git a/setup.py b/setup.py
|
|
index f11600c..2ccc6f9 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -38,9 +38,9 @@ if sys.version_info[:2] == (2, 6):
|
|
# JSON objects. The 2.7 json module has this. For 2.6
|
|
# we need simplejson.
|
|
requires.append('simplejson==3.3.0')
|
|
- requires.append('python-dateutil>=2.1,<2.7.0')
|
|
+ requires.append('python-dateutil>=1.4,<2.7.0')
|
|
else:
|
|
- requires.append('python-dateutil>=2.1,<3.0.0')
|
|
+ requires.append('python-dateutil>=1.4,<3.0.0')
|
|
|
|
|
|
setup(
|
|
--
|
|
2.17.1
|
|
|