1.27.72
This commit is contained in:
parent
3db21370de
commit
ef718ee25e
1
.gitignore
vendored
1
.gitignore
vendored
@ -622,3 +622,4 @@
|
||||
/botocore-1.27.61.tar.gz
|
||||
/botocore-1.27.62.tar.gz
|
||||
/botocore-1.27.71.tar.gz
|
||||
/botocore-1.27.72.tar.gz
|
||||
|
124
2761.patch
124
2761.patch
@ -1,124 +0,0 @@
|
||||
From 01f58a14a7a69a3309480be3f10c16135ec13978 Mon Sep 17 00:00:00 2001
|
||||
From: Jonas Neubert <jonasneu@amazon.com>
|
||||
Date: Mon, 12 Sep 2022 14:21:46 -0600
|
||||
Subject: [PATCH 1/2] add missing `super().tearDown()` for test classes with
|
||||
custom base classes
|
||||
|
||||
---
|
||||
tests/functional/test_mturk.py | 2 +-
|
||||
tests/functional/test_sagemaker.py | 1 +
|
||||
tests/unit/auth/test_signers.py | 4 ++++
|
||||
tests/unit/test_configloader.py | 1 +
|
||||
4 files changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/functional/test_mturk.py b/tests/functional/test_mturk.py
|
||||
index b30461b2f3..bd4e4267f6 100644
|
||||
--- a/tests/functional/test_mturk.py
|
||||
+++ b/tests/functional/test_mturk.py
|
||||
@@ -23,7 +23,7 @@ def setUp(self):
|
||||
self.stubber.activate()
|
||||
|
||||
def tearDown(self):
|
||||
- super().setUp()
|
||||
+ super().tearDown()
|
||||
self.stubber.deactivate()
|
||||
|
||||
def test_list_hits_aliased(self):
|
||||
diff --git a/tests/functional/test_sagemaker.py b/tests/functional/test_sagemaker.py
|
||||
index 354d8d2c7e..59a5d61434 100644
|
||||
--- a/tests/functional/test_sagemaker.py
|
||||
+++ b/tests/functional/test_sagemaker.py
|
||||
@@ -15,6 +15,7 @@ def _hook(self, **kwargs):
|
||||
self.hook_calls.append(kwargs['event_name'])
|
||||
|
||||
def tearDown(self):
|
||||
+ super().tearDown()
|
||||
self.stubber.deactivate()
|
||||
|
||||
def test_event_with_old_prefix(self):
|
||||
diff --git a/tests/unit/auth/test_signers.py b/tests/unit/auth/test_signers.py
|
||||
index bfb25e8cf0..880b6bbaaf 100644
|
||||
--- a/tests/unit/auth/test_signers.py
|
||||
+++ b/tests/unit/auth/test_signers.py
|
||||
@@ -716,6 +716,7 @@ def setUp(self):
|
||||
|
||||
def tearDown(self):
|
||||
self.time_patch.stop()
|
||||
+ super().tearDown()
|
||||
|
||||
def test_presign_with_query_string(self):
|
||||
self.request.url = (
|
||||
@@ -808,6 +809,7 @@ def setUp(self):
|
||||
|
||||
def tearDown(self):
|
||||
self.datetime_patcher.stop()
|
||||
+ super().tearDown()
|
||||
|
||||
def test_presign_no_params(self):
|
||||
request = AWSRequest()
|
||||
@@ -1044,6 +1046,7 @@ def setUp(self):
|
||||
|
||||
def tearDown(self):
|
||||
self.time_patch.stop()
|
||||
+ super().tearDown()
|
||||
|
||||
def test_presign_post(self):
|
||||
self.auth.add_auth(self.request)
|
||||
@@ -1110,6 +1113,7 @@ def setUp(self):
|
||||
|
||||
def tearDown(self):
|
||||
self.datetime_patcher.stop()
|
||||
+ super().tearDown()
|
||||
|
||||
def test_presign_post(self):
|
||||
self.auth.add_auth(self.request)
|
||||
diff --git a/tests/unit/test_configloader.py b/tests/unit/test_configloader.py
|
||||
index e8ef97d133..5f3989d0fb 100644
|
||||
--- a/tests/unit/test_configloader.py
|
||||
+++ b/tests/unit/test_configloader.py
|
||||
@@ -39,6 +39,7 @@ def setUp(self):
|
||||
|
||||
def tearDown(self):
|
||||
shutil.rmtree(self.tempdir)
|
||||
+ super().tearDown()
|
||||
|
||||
def create_config_file(self, filename):
|
||||
contents = (
|
||||
|
||||
From 92e28185408db6784518a37f104c9c9690a58b5d Mon Sep 17 00:00:00 2001
|
||||
From: Jonas Neubert <jonasneu@amazon.com>
|
||||
Date: Mon, 12 Sep 2022 14:38:07 -0600
|
||||
Subject: [PATCH 2/2] remove unused base class for TestConfigLoader
|
||||
|
||||
---
|
||||
tests/unit/test_configloader.py | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/tests/unit/test_configloader.py b/tests/unit/test_configloader.py
|
||||
index 5f3989d0fb..9f68815f5e 100644
|
||||
--- a/tests/unit/test_configloader.py
|
||||
+++ b/tests/unit/test_configloader.py
|
||||
@@ -23,7 +23,7 @@
|
||||
multi_file_load_config,
|
||||
raw_config_parse,
|
||||
)
|
||||
-from tests import BaseEnvVar, mock, unittest
|
||||
+from tests import mock, unittest
|
||||
|
||||
|
||||
def path(filename):
|
||||
@@ -33,13 +33,12 @@ def path(filename):
|
||||
return os.path.join(directory, filename)
|
||||
|
||||
|
||||
-class TestConfigLoader(BaseEnvVar):
|
||||
+class TestConfigLoader(unittest.TestCase):
|
||||
def setUp(self):
|
||||
self.tempdir = tempfile.mkdtemp()
|
||||
|
||||
def tearDown(self):
|
||||
shutil.rmtree(self.tempdir)
|
||||
- super().tearDown()
|
||||
|
||||
def create_config_file(self, filename):
|
||||
contents = (
|
@ -2,14 +2,13 @@
|
||||
|
||||
Name: python-%{pypi_name}
|
||||
# NOTICE - Updating this package requires updating python-boto3
|
||||
Version: 1.27.71
|
||||
Version: 1.27.72
|
||||
Release: 1%{?dist}
|
||||
Summary: Low-level, data-driven core of boto 3
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/boto/botocore
|
||||
Source0: %{pypi_source}
|
||||
Patch0: 2761.patch
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: pyproject-rpm-macros
|
||||
@ -67,6 +66,9 @@ rm -vr tests/functional/leak
|
||||
%{python3_sitelib}/%{pypi_name}-*.dist-info/
|
||||
|
||||
%changelog
|
||||
* Tue Sep 13 2022 Gwyn Ciesla <gwync@protonmail.com> - 1.27.72-1
|
||||
- 1.27.72
|
||||
|
||||
* Mon Sep 12 2022 Gwyn Ciesla <gwync@protonmail.com> - 1.27.71-1
|
||||
- 1.27.71, patch for test failure
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (botocore-1.27.71.tar.gz) = bb37eb4d90ad9f21e7471efdfeb05d3533995a359259e871c4abb0d8df0281650b3a77d6981d0755fc16c10ccbcf25258d55006a76bdc8d4a17f1a55b27a3002
|
||||
SHA512 (botocore-1.27.72.tar.gz) = e5b4ec6b8d04e6821d457344074c918965e5930b0b8cdc4b6defa4e8ec0b148572df1b65c431864af865a443cb33e7b4755b6b393200fa4111edf546ae99b30f
|
||||
|
Loading…
Reference in New Issue
Block a user