Fix EL7 dateutil patch

This commit is contained in:
Haikel Guemar 2018-06-21 09:28:09 +02:00
parent 476a1bec7a
commit c81b6d55e0
3 changed files with 64 additions and 38 deletions

View File

@ -0,0 +1,58 @@
From 1b5abc5fa73df1ff33b138c337dfce1bb439cfc1 Mon Sep 17 00:00:00 2001
From: Haikel Guemar <hguemar@fedoraproject.org>
Date: Thu, 21 Jun 2018 09:25:02 +0200
Subject: [PATCH 1/1] Fix date util version for EL7
---
requirements.txt | 4 ++--
setup.cfg | 4 ++--
setup.py | 4 ++--
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/requirements.txt b/requirements.txt
index b8db4b4..6e74c23 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,6 +1,6 @@
tox>=2.5.0,<3.0.0
-python-dateutil>=2.1,<2.7.0; python_version=="2.6"
-python-dateutil>=2.1,<3.0.0; python_version>="2.7"
+python-dateutil>=1.4,<2.7.0; python_version=="2.6"
+python-dateutil>=1.4,<3.0.0; python_version>="2.7"
nose==1.3.7
mock==1.3.0
wheel==0.24.0
diff --git a/setup.cfg b/setup.cfg
index a6878a2..05c72d5 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -3,8 +3,8 @@ universal = 1
[metadata]
requires-dist =
- python-dateutil>=2.1,<2.7.0; python_version=="2.6"
- python-dateutil>=2.1,<3.0.0; python_version>="2.7"
+ python-dateutil>=1.4,<2.7.0; python_version=="2.6"
+ python-dateutil>=1.4,<3.0.0; python_version>="2.7"
jmespath>=0.7.1,<1.0.0
docutils>=0.10
ordereddict==1.1; python_version=="2.6"
diff --git a/setup.py b/setup.py
index f11600c..2ccc6f9 100644
--- a/setup.py
+++ b/setup.py
@@ -38,9 +38,9 @@ if sys.version_info[:2] == (2, 6):
# JSON objects. The 2.7 json module has this. For 2.6
# we need simplejson.
requires.append('simplejson==3.3.0')
- requires.append('python-dateutil>=2.1,<2.7.0')
+ requires.append('python-dateutil>=1.4,<2.7.0')
else:
- requires.append('python-dateutil>=2.1,<3.0.0')
+ requires.append('python-dateutil>=1.4,<3.0.0')
setup(
--
2.17.1

View File

@ -1,34 +0,0 @@
diff -ur botocore-1.5.3.orig/requirements.txt botocore-1.5.3/requirements.txt
--- botocore-1.5.3.orig/requirements.txt 2017-01-20 11:06:07.081344531 +0000
+++ botocore-1.5.3/requirements.txt 2017-01-20 11:06:56.409021742 +0000
@@ -1,5 +1,5 @@
tox>=2.5.0,<3.0.0
-python-dateutil>=2.1,<3.0.0
+python-dateutil>=1.4,<3.0.0
nose==1.3.0
mock==1.3.0
wheel==0.24.0
diff -ur botocore-1.5.3.orig/setup.cfg botocore-1.5.3/setup.cfg
--- botocore-1.5.3.orig/setup.cfg 2017-01-20 11:06:07.082344504 +0000
+++ botocore-1.5.3/setup.cfg 2017-01-20 11:07:15.994496531 +0000
@@ -3,7 +3,7 @@
[metadata]
requires-dist =
- python-dateutil>=2.1,<3.0.0
+ python-dateutil>=1.4,<3.0.0
jmespath>=0.7.1,<1.0.0
docutils>=0.10
ordereddict==1.1; python_version=="2.6"
diff -ur botocore-1.5.3.orig/setup.py botocore-1.5.3/setup.py
--- botocore-1.5.3.orig/setup.py 2017-01-20 11:06:07.078344611 +0000
+++ botocore-1.5.3/setup.py 2017-01-20 11:07:27.367191557 +0000
@@ -6,7 +6,7 @@
requires = ['jmespath>=0.7.1,<1.0.0',
- 'python-dateutil>=2.1,<3.0.0',
+ 'python-dateutil>=1.4,<3.0.0',
'docutils>=0.10']

View File

@ -15,13 +15,13 @@
Name: python-%{pypi_name} Name: python-%{pypi_name}
Version: 1.10.41 Version: 1.10.41
Release: 1%{?dist} Release: 2%{?dist}
Summary: Low-level, data-driven core of boto 3 Summary: Low-level, data-driven core of boto 3
License: ASL 2.0 License: ASL 2.0
URL: https://github.com/boto/botocore URL: https://github.com/boto/botocore
Source0: https://pypi.io/packages/source/b/%{pypi_name}/%{pypi_name}-%{version}.tar.gz Source0: https://pypi.io/packages/source/b/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
Patch0: botocore-1.5.3-fix_dateutil_version.patch Patch0: 0001-Fix-date-util-version-for-EL7.patch
BuildArch: noarch BuildArch: noarch
%description %description
@ -158,14 +158,16 @@ nosetests-3.5 --with-coverage --cover-erase --cover-package botocore --with-xuni
%{python3_sitelib}/%{pypi_name}/ %{python3_sitelib}/%{pypi_name}/
%{python3_sitelib}/%{pypi_name}-*.egg-info/ %{python3_sitelib}/%{pypi_name}-*.egg-info/
%endif # with python3 %endif # with python3
%if %{with docs} %if %{with docs}
%files doc %files doc
%doc html %doc html
%endif # with docs %endif # with docs
%changelog %changelog
* Wed Jun 20 2018 hguemar <hguemar@nozarashi.seireitei> - 1.10.41-1 * Wed Jun 20 2018 Haïkel Guémar <hguemar@fedoraproject.org> - 1.10.41-2
- Fix EL7 dateutil patch
* Wed Jun 20 2018 Haïkel Guémar <hguemar@fedoraproject.org> - 1.10.41-1
- Upstream 1.10.41 - Upstream 1.10.41
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.9.1-3 * Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.9.1-3