Dasd is a valid label type on s390x (#1538550)

This commit is contained in:
Vojtech Trefny 2018-03-06 15:28:41 +01:00
parent 9c2f46b0cb
commit fa9539ddcc
3 changed files with 63 additions and 4 deletions

View File

@ -0,0 +1,25 @@
From 4c58ccbd1aba4904d8d33ce5699b43bbaaffa9ec Mon Sep 17 00:00:00 2001
From: Vendula Poncova <vponcova@redhat.com>
Date: Tue, 27 Feb 2018 13:49:10 +0100
Subject: [PATCH] Dasd is a valid label type on s390x (#1538550)
Add the dasd label type to the list of valid label types for s390x.
This bug was introduced in the commit ebd43b6.
Resolves: rhbz#1538550
---
blivet/formats/disklabel.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/blivet/formats/disklabel.py b/blivet/formats/disklabel.py
index 6251fceb..44f9834c 100644
--- a/blivet/formats/disklabel.py
+++ b/blivet/formats/disklabel.py
@@ -226,7 +226,7 @@ def get_platform_label_types(cls):
elif arch.is_efi() and not arch.is_aarch64():
label_types = ["gpt"]
elif arch.is_s390():
- label_types = ["msdos"] # since 'dasd' is only for DASD, it isn't listed here
+ label_types = ["msdos", "dasd"]
return label_types

View File

@ -0,0 +1,31 @@
From 152387afadf3d189539e6c8bd4b6decc0e7f15f7 Mon Sep 17 00:00:00 2001
From: Vojtech Trefny <vtrefny@redhat.com>
Date: Wed, 7 Mar 2018 10:45:46 +0100
Subject: [PATCH] Do not try to update potfile during make all
---
po/Makefile | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/po/Makefile b/po/Makefile
index 2f845cd..bbc6b5e 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -27,7 +27,7 @@ MOFILES = $(patsubst %.po,%.mo,$(POFILES))
PYSRC = $(wildcard ../blivet/*.py ../blivet/*/*.py)
SRCFILES = $(PYSRC)
-all:: update-po $(MOFILES)
+all:: refresh-po $(MOFILES)
$(POTFILE): $(SRCFILES)
$(XGETTEXT) -L Python --keyword=_ --keyword=N_ --keyword=P_:1,2 $(SRCFILES)
@@ -65,5 +65,3 @@ install: $(MOFILES)
$(MSGFMT) -o $@ $<
.PHONY: missing depend
-
-
--
1.8.3.1

View File

@ -14,13 +14,15 @@ Version: 3.0.0
%global prerelease .b1
# prerelease, if defined, should be something like .a1, .b1, .b2.dev1, or .c2
Release: 0.2%{?prerelease}%{?dist}
Release: 0.3%{?prerelease}%{?dist}
Epoch: 1
License: LGPLv2+
Group: System Environment/Libraries
%global realname blivet
%global realversion %{version}%{?prerelease}
Source0: http://github.com/storaged-project/blivet/archive/%{realname}-%{realversion}.tar.gz
Patch0: 0001-Dasd-is-a-valid-label-type-on-s390x.patch
Patch1: 0002-Do-not-try-to-update-potfile-during-make-all.patch
# Versions of required components (done so we make sure the buildrequires
# match the requires versions of things).
@ -56,7 +58,6 @@ Summary: A python3 package for examining and modifying storage configuration.
%{?python_provide:%python_provide python3-%{realname}}
BuildRequires: gettext
BuildRequires: python3-pocketlint >= %{pocketlintver}
BuildRequires: python3-devel
BuildRequires: python3-setuptools
@ -89,7 +90,6 @@ Summary: A python2 package for examining and modifying storage configuration.
%{?python_provide:%python_provide python2-%{realname}}
BuildRequires: gettext
BuildRequires: python2-pocketlint >= %{pocketlintver}
BuildRequires: python2-devel
%if %{is_rhel}
@ -128,7 +128,7 @@ The python2-%{realname} is a python2 package for examining and modifying storage
configuration.
%prep
%autosetup -n %{realname}-%{realversion}
%autosetup -n %{realname}-%{realversion} -p1
%build
make PYTHON=%{__python2}
@ -165,6 +165,9 @@ make PYTHON=%{__python3} DESTDIR=%{buildroot} install
%endif
%changelog
* Tue Mar 06 2018 Vojtech Trefny <vtrefny@redhat.com> - 1:3.0.0-0.3.b1
- Dasd is a valid label type on s390x (#1538550)
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:3.0.0-0.2.b1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild