diff --git a/.gitignore b/.gitignore
index 0ce1c25..04c53c4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
 /awscrt-0.16.16.tar.gz
+/awscrt-0.20.2.tar.gz
diff --git a/0001-Skip-tests-which-require-networking.patch b/0001-Skip-tests-which-require-networking.patch
deleted file mode 100644
index 0f43ca5..0000000
--- a/0001-Skip-tests-which-require-networking.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From 21a2d3423786a0d2b0c426417e4450378b607f8c Mon Sep 17 00:00:00 2001
-From: Major Hayden <major@redhat.com>
-Date: Fri, 2 Feb 2024 10:11:44 -0600
-Subject: [PATCH] Skip tests which require networking
-
-Signed-off-by: Major Hayden <major@redhat.com>
----
- test/test_eventstream_rpc.py | 4 ++--
- test/test_http_client.py     | 2 ++
- test/test_io.py              | 1 +
- test/test_websocket.py       | 2 ++
- 4 files changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/test/test_eventstream_rpc.py b/test/test_eventstream_rpc.py
-index 35ddac1..700bac5 100644
---- a/test/test_eventstream_rpc.py
-+++ b/test/test_eventstream_rpc.py
-@@ -12,7 +12,7 @@ from queue import Queue
- from test import NativeResourceTest, TIMEOUT
- from threading import Event
- import time
--from unittest import skipUnless
-+from unittest import skip, skipUnless
- from uuid import UUID, uuid4
- import weakref
- 
-@@ -91,7 +91,7 @@ class ContinuationHandler(ClientContinuationHandler):
-             self.fail_test("shutdown can only fire once")
-         self.record.close_call.set()
- 
--
-+@skip("Requires network")
- class FailureClientTests(NativeResourceTest):
-     def _fail_test_from_callback(self, msg):
-         print("ERROR FROM CALLBACK", msg)
-diff --git a/test/test_http_client.py b/test/test_http_client.py
-index 5af87b6..4744dec 100644
---- a/test/test_http_client.py
-+++ b/test/test_http_client.py
-@@ -114,6 +114,7 @@ class TestClient(NativeResourceTest):
-     def test_connect_http(self):
-         self._test_connect(secure=False)
- 
-+    @unittest.skip("Requires network")
-     def test_connect_https(self):
-         self._test_connect(secure=True)
- 
-@@ -347,6 +348,7 @@ class TestClient(NativeResourceTest):
-                                                      tls_connection_options=tls_conn_opt)
-         return connection_future.result(self.timeout)
- 
-+    @unittest.skip("Requires network")
-     def test_h2_client(self):
-         url = urlparse("https://d1cz66xoahf9cl.cloudfront.net/http_test_doc.txt")
-         connection = self._new_h2_client_connection(url)
-diff --git a/test/test_io.py b/test/test_io.py
-index d841c04..8b0f228 100644
---- a/test/test_io.py
-+++ b/test/test_io.py
-@@ -9,6 +9,7 @@ import sys
- import unittest
- 
- 
-+@unittest.skip("Requires network")
- class EventLoopGroupTest(NativeResourceTest):
-     def test_init_defaults(self):
-         event_loop_group = EventLoopGroup()
-diff --git a/test/test_websocket.py b/test/test_websocket.py
-index 17de0a9..860d434 100644
---- a/test/test_websocket.py
-+++ b/test/test_websocket.py
-@@ -17,6 +17,7 @@ from test import NativeResourceTest
- import threading
- from time import sleep, time
- from typing import Optional
-+import unittest
- 
- # using a 3rdparty websocket library for the server
- import websockets.server as websockets_server_3rdparty
-@@ -491,6 +492,7 @@ class TestClient(NativeResourceTest):
- 
-             self.assertIsNone(handler.exception)
- 
-+    @unittest.skip("Requires network")
-     def test_exception_from_incoming_frame_callback_closes_websocket(self):
-         # loop 3 times, once for each type of on_incoming_frame_X callback
-         for i in ('begin', 'payload', 'complete'):
--- 
-2.43.0
-
diff --git a/python-awscrt.spec b/python-awscrt.spec
index 2d52ace..e6fcc06 100644
--- a/python-awscrt.spec
+++ b/python-awscrt.spec
@@ -3,8 +3,8 @@ Python bindings for the AWS Common Runtime}
 
 
 Name:           python-awscrt
-Version:        0.16.16
-Release:        3%{?dist}
+Version:        0.20.2
+Release:        1%{dist}
 
 Summary:        Python bindings for the AWS Common Runtime
 # All files are licensed under Apache-2.0, except:
@@ -16,8 +16,8 @@ URL:            https://github.com/awslabs/aws-crt-python
 
 Source0:        %{pypi_source awscrt}
 
-# Some tests require networking and/or open sockets.
-Patch0:         0001-Skip-tests-which-require-networking.patch
+# one test requires internet connection, skip it
+Patch0:         skip-test-requiring-network.patch
 
 BuildRequires:  python%{python3_pkgversion}-devel
 
@@ -68,7 +68,7 @@ export AWS_CRT_BUILD_USE_SYSTEM_LIBCRYPTO=1
 
 
 %check
-PYTHONPATH="%{buildroot}%{python3_sitearch}:%{buildroot}%{python3_sitelib}" %{python3} -m unittest discover --failfast --verbose
+PYTHONPATH="%{buildroot}%{python3_sitearch}:%{buildroot}%{python3_sitelib}" %{python3} -m unittest
 
 
 %files -n python%{python3_pkgversion}-awscrt -f %{pyproject_files}
@@ -76,17 +76,30 @@ PYTHONPATH="%{buildroot}%{python3_sitearch}:%{buildroot}%{python3_sitelib}" %{py
 
 
 %changelog
-* Fri Feb 02 2024 Major Hayden <major@redhat.com> - 0.16.16-3
-- Skip additional network tests
+* Tue Jan 02 2024 Packit <hello@packit.dev> - 0.20.2-1
+- [packit] 0.20.2 upstream release
+- Resolves rhbz#2254450
 
-* Wed Jan 31 2024 Major Hayden <mhayden@redhat.com> - 0.16.16-2
-- Skip websocket test as it requires networking
+* Wed Dec 06 2023 Nikola Forró <nforro@redhat.com> - 0.19.19-2
+- Add Packit config
 
-* Wed Apr 26 2023 Nikola Forró <nforro@redhat.com> - 0.16.16-1
-- New upstream release 0.16.16
+* Thu Nov 30 2023 Packit <hello@packit.dev> - 0.19.19-1
+- [packit] 0.19.19 upstream release
+- Resolves rhbz#2250726
 
-* Wed Mar 22 2023 Nikola Forró <nforro@redhat.com> - 0.16.13-2
-- Workaround a crash on %%ix86
+* Fri Nov 17 2023 Packit <hello@packit.dev> - 0.19.13-1
+- [packit] 0.19.13 upstream release
+- Resolves rhbz#2247105
 
-* Thu Mar 16 2023 Nikola Forró <nforro@redhat.com> - 0.16.13-1
-- Initial package
+* Wed Oct 25 2023 Packit <hello@packit.dev> - 0.19.6-1
+- [packit] 0.19.6 upstream release
+- Resolves rhbz#2211521 Upstream tag: v0.19.6 Upstream commit: b83949d0
+
+* Mon Oct 16 2023 Packit <hello@packit.dev> - 0.19.3-1
+- [packit] 0.19.3 upstream release
+
+* Mon Oct 02 2023 Packit <hello@packit.dev> - 0.19.2-1
+- [packit] 0.19.2 upstream release
+
+* Fri Aug 25 2023 Nikola Forró <nforro@redhat.com> - 0.18.0-1
+- Initial import for EPEL 9
diff --git a/skip-test-requiring-network.patch b/skip-test-requiring-network.patch
new file mode 100644
index 0000000..1cd7b50
--- /dev/null
+++ b/skip-test-requiring-network.patch
@@ -0,0 +1,12 @@
+diff --git a/test/test_http_client.py b/test/test_http_client.py
+index 5af87b6..dd2631a 100644
+--- a/test/test_http_client.py
++++ b/test/test_http_client.py
+@@ -347,6 +347,7 @@ class TestClient(NativeResourceTest):
+                                                      tls_connection_options=tls_conn_opt)
+         return connection_future.result(self.timeout)
+ 
++    @unittest.skip("Requires network")
+     def test_h2_client(self):
+         url = urlparse("https://d1cz66xoahf9cl.cloudfront.net/http_test_doc.txt")
+         connection = self._new_h2_client_connection(url)
diff --git a/sources b/sources
index d90d42b..e84d030 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (awscrt-0.16.16.tar.gz) = 5c94d6a33efc6000361283dc59d49a09bf7943c317fb5ef29bea3d7bc265420ae147510417fe7c0901fe71f3e5baf6235044b994a6cc03278a332c34df2b6e91
+SHA512 (awscrt-0.20.2.tar.gz) = 61b90100d2f0a96f341e5bb51e0b5d9f8f5b1e8a9b1d476e6acdfc447beddc9ba103b60a3c62cbf7c1e0b6ab533beeb02bb6b555e5dc83148d51ca2238859a44