diff --git a/.gitignore b/.gitignore
index 04c53c4..b09e041 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
 /awscrt-0.16.16.tar.gz
 /awscrt-0.20.2.tar.gz
+/pkcs11.h
diff --git a/python-awscrt.spec b/python-awscrt.spec
index e6fcc06..aead52f 100644
--- a/python-awscrt.spec
+++ b/python-awscrt.spec
@@ -4,7 +4,7 @@ Python bindings for the AWS Common Runtime}
 
 Name:           python-awscrt
 Version:        0.20.2
-Release:        1%{dist}
+Release:        2%{dist}
 
 Summary:        Python bindings for the AWS Common Runtime
 # All files are licensed under Apache-2.0, except:
@@ -16,6 +16,10 @@ URL:            https://github.com/awslabs/aws-crt-python
 
 Source0:        %{pypi_source awscrt}
 
+# Get an open source version of the pkcs11 header file from Simo's repository.
+# https://github.com/latchset/pkcs11-headers
+Source1:        https://raw.githubusercontent.com/latchset/pkcs11-headers/main/public-domain/2.40/pkcs11.h
+
 # one test requires internet connection, skip it
 Patch0:         skip-test-requiring-network.patch
 
@@ -47,6 +51,10 @@ Summary:        %{summary}
 %prep
 %autosetup -p1 -n awscrt-%{version}
 
+# Bring in the pkcs11 header file from Simo's repository.
+rm -fv crt/aws-c-io/source/pkcs11/v2.40/*
+cp %{SOURCE1} crt/aws-c-io/source/pkcs11/v2.40/
+
 
 %generate_buildrequires
 %pyproject_buildrequires
@@ -76,6 +84,9 @@ PYTHONPATH="%{buildroot}%{python3_sitearch}:%{buildroot}%{python3_sitelib}" %{py
 
 
 %changelog
+* Mon Feb 12 2024 Major Hayden <major@redhat.com> - 0.20.2-2
+- Replacing upstream's pkcs11.h with Simo's public domain version.
+
 * Tue Jan 02 2024 Packit <hello@packit.dev> - 0.20.2-1
 - [packit] 0.20.2 upstream release
 - Resolves rhbz#2254450
diff --git a/sources b/sources
index e84d030..3168a5f 100644
--- a/sources
+++ b/sources
@@ -1 +1,2 @@
 SHA512 (awscrt-0.20.2.tar.gz) = 61b90100d2f0a96f341e5bb51e0b5d9f8f5b1e8a9b1d476e6acdfc447beddc9ba103b60a3c62cbf7c1e0b6ab533beeb02bb6b555e5dc83148d51ca2238859a44
+SHA512 (pkcs11.h) = 36dba0fcde2327cff6a13d1492d2ae38161e73a088854235052abd79198943c0697fb66ce6f71e89eb1c6ce41ef727eaec96669d3ae013f76b291d3334e062f3