Allow pluggy >=1.0, build without BuildRequiring pytest
This commit is contained in:
parent
a2bad616d6
commit
8aeca5531b
53
9040.patch
Normal file
53
9040.patch
Normal file
@ -0,0 +1,53 @@
|
||||
From fbba504cd5e1a74d528a41a11a7b82297cd7da74 Mon Sep 17 00:00:00 2001
|
||||
From: Bruno Oliveira <nicoddemus@gmail.com>
|
||||
Date: Thu, 26 Aug 2021 09:26:51 -0300
|
||||
Subject: [PATCH 1/2] Allow pluggy >=1.0
|
||||
|
||||
Now that pluggy 1.0 has been released, we can allow pluggy 1.0 with new pytest versions.
|
||||
---
|
||||
setup.cfg | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.cfg b/setup.cfg
|
||||
index f919a94..5c69005 100644
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -44,7 +44,7 @@ install_requires =
|
||||
attrs>=19.2.0
|
||||
iniconfig
|
||||
packaging
|
||||
- pluggy>=0.12,<1.0.0a1
|
||||
+ pluggy>=0.12,<2.0
|
||||
py>=1.8.2
|
||||
toml
|
||||
atomicwrites>=1.0;sys_platform=="win32"
|
||||
|
||||
|
||||
From 109bc2649d8f1573e91f281d1a62e95dee0c2cc5 Mon Sep 17 00:00:00 2001
|
||||
From: Bruno Oliveira <nicoddemus@gmail.com>
|
||||
Date: Thu, 26 Aug 2021 09:33:50 -0300
|
||||
Subject: [PATCH 2/2] Adapt docs references to use pluggy 1.0
|
||||
|
||||
Also use the intersphinx reference instead of the class directly.
|
||||
---
|
||||
doc/en/reference/reference.rst | 5 +----
|
||||
doc/en/requirements.txt | 1 +
|
||||
2 files changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/doc/en/reference.rst b/doc/en/reference.rst
|
||||
index 8aa95ca..346c4fa 100644
|
||||
--- a/doc/en/reference.rst
|
||||
+++ b/doc/en/reference.rst
|
||||
@@ -920,11 +920,7 @@ TestReport
|
||||
_Result
|
||||
~~~~~~~
|
||||
|
||||
-Result used within :ref:`hook wrappers <hookwrapper>`.
|
||||
-
|
||||
-.. autoclass:: pluggy.callers._Result
|
||||
-.. automethod:: pluggy.callers._Result.get_result
|
||||
-.. automethod:: pluggy.callers._Result.force_result
|
||||
+Result object used within :ref:`hook wrappers <hookwrapper>`, see :py:class:`_Result in the pluggy documentation <pluggy._callers._Result>` for more information.
|
||||
|
||||
Global Variables
|
||||
----------------
|
16
pytest.spec
16
pytest.spec
@ -1,6 +1,6 @@
|
||||
Name: pytest
|
||||
Version: 6.2.4
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: Simple powerful testing with Python
|
||||
License: MIT
|
||||
URL: https://pytest.org
|
||||
@ -21,6 +21,11 @@ Patch2: 8555.patch
|
||||
# Rebased slightly
|
||||
Patch3: 8664.patch
|
||||
|
||||
# Allow pluggy >=1.0
|
||||
# Merged upstream, https://github.com/pytest-dev/pytest/pull/9040
|
||||
# Rebased slightly
|
||||
Patch4: 9040.patch
|
||||
|
||||
# When building pytest for the first time with new Python version
|
||||
# we might not yet have all the BRs, those conditionals allow us to do that.
|
||||
|
||||
@ -30,13 +35,13 @@ Patch3: 8664.patch
|
||||
# Only disabling the optional tests is a more complex but careful approach
|
||||
# Pytest will skip the related tests, so we only conditionalize the BRs
|
||||
# This bcond is ignored when tests are disabled
|
||||
%bcond_without optional_tests
|
||||
%bcond_with optional_tests
|
||||
|
||||
# To run the tests in %%check we use pytest-timeout
|
||||
# When building pytest for the first time with new Python version
|
||||
# that is not possible as it depends on pytest
|
||||
# The bcond is ignored when tests are disabled
|
||||
%bcond_without timeout
|
||||
%bcond_with timeout
|
||||
|
||||
# When building pytest for the first time with new Python version
|
||||
# we also don't have sphinx yet and cannot build docs.
|
||||
@ -79,6 +84,8 @@ BuildRequires: python3-pytest-timeout
|
||||
|
||||
%if %{with docs}
|
||||
BuildRequires: %{_bindir}/rst2html
|
||||
# pluggy >= 1 is needed to build the docs, older versions are allowed on runtime:
|
||||
BuildRequires: python3-pluggy >= 1
|
||||
BuildRequires: python3-pygments-pytest
|
||||
BuildRequires: python3-Pallets-Sphinx-Themes
|
||||
BuildRequires: python3-sphinx
|
||||
@ -172,6 +179,9 @@ export INPUTRC=$PWD/.inputrc
|
||||
%{python3_sitelib}/pytest/
|
||||
|
||||
%changelog
|
||||
* Fri Aug 27 2021 Miro Hrončok <mhroncok@redhat.com> - 6.2.4-6
|
||||
- Allow pluggy >=1.0
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.2.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user