Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/pytest.git#0c7408f2a1047574093b6fddac74f11813ae3e5e
This commit is contained in:
parent
054a77b06d
commit
5b4e5bfab0
@ -1,26 +0,0 @@
|
||||
From d9ac2efbcdee123f73edf1829c8bd6a91be3b6d2 Mon Sep 17 00:00:00 2001
|
||||
From: Ran Benita <ran@unusedvar.com>
|
||||
Date: Sun, 25 Oct 2020 01:08:12 +0200
|
||||
Subject: [PATCH] testing: python 3.10 fix
|
||||
|
||||
---
|
||||
testing/test_runner.py | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/testing/test_runner.py b/testing/test_runner.py
|
||||
index 95b8f5fccb..a1f1db48d0 100644
|
||||
--- a/testing/test_runner.py
|
||||
+++ b/testing/test_runner.py
|
||||
@@ -336,10 +336,9 @@ def test_method(self):
|
||||
assert reps[2].failed
|
||||
assert reps[2].when == "teardown"
|
||||
assert reps[2].longrepr.reprcrash.message in (
|
||||
- # python3 error
|
||||
"TypeError: teardown_method() missing 2 required positional arguments: 'y' and 'z'",
|
||||
- # python2 error
|
||||
- "TypeError: teardown_method() takes exactly 4 arguments (2 given)",
|
||||
+ # Python >= 3.10
|
||||
+ "TypeError: TestClass.teardown_method() missing 2 required positional arguments: 'y' and 'z'",
|
||||
)
|
||||
|
||||
def test_failure_in_setup_function_ignores_custom_repr(self, testdir) -> None:
|
30
pytest.spec
30
pytest.spec
@ -1,14 +1,11 @@
|
||||
Name: pytest
|
||||
Version: 6.0.2
|
||||
Release: 2%{?dist}
|
||||
Version: 6.2.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Simple powerful testing with Python
|
||||
License: MIT
|
||||
URL: https://pytest.org
|
||||
Source0: %{pypi_source}
|
||||
|
||||
# Python 3.10 compatibility
|
||||
Patch1: https://github.com/pytest-dev/pytest/commit/d9ac2efbcd.patch
|
||||
|
||||
# When building pytest for the first time with new Python version
|
||||
# we might not yet have all the BRs, those conditionals allow us to do that.
|
||||
|
||||
@ -39,7 +36,6 @@ BuildRequires: python3-setuptools_scm
|
||||
# before them and get broken dependencies
|
||||
BuildRequires: python3-attrs
|
||||
BuildRequires: python3-iniconfig
|
||||
BuildRequires: python3-more-itertools
|
||||
BuildRequires: python3-packaging
|
||||
BuildRequires: python3-pluggy >= 0.12
|
||||
BuildRequires: python3-py >= 1.5.0
|
||||
@ -51,14 +47,16 @@ BuildRequires: python3-hypothesis
|
||||
BuildRequires: python3-xmlschema
|
||||
%if %{with optional_tests}
|
||||
BuildRequires: python3-argcomplete
|
||||
#BuildRequires: python3-asynctest -- no 3.9 rebuild yet
|
||||
#BuildRequires: python3-asynctest -- not packaged in Fedora
|
||||
BuildRequires: python3-decorator
|
||||
BuildRequires: python3-jinja2
|
||||
BuildRequires: python3-mock
|
||||
BuildRequires: python3-nose
|
||||
BuildRequires: python3-numpy
|
||||
BuildRequires: python3-pexpect
|
||||
BuildRequires: python3-pytest-xdist
|
||||
BuildRequires: python3-twisted
|
||||
BuildRequires: /usr/bin/lsof
|
||||
%endif
|
||||
%if %{with timeout}
|
||||
BuildRequires: python3-pytest-timeout
|
||||
@ -78,17 +76,17 @@ BuildRequires: make
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
py.test provides simple, yet powerful testing for Python.
|
||||
The pytest framework makes it easy to write small tests, yet scales to support
|
||||
complex functional testing for applications and libraries.
|
||||
|
||||
|
||||
%package -n python3-%{name}
|
||||
Summary: Simple powerful testing with Python
|
||||
%{?python_provide:%python_provide python3-%{name}}
|
||||
Provides: pytest = %{version}-%{release}
|
||||
Conflicts: python-pytest < 4.6
|
||||
|
||||
%description -n python3-%{name}
|
||||
py.test provides simple, yet powerful testing for Python.
|
||||
The pytest framework makes it easy to write small tests, yet scales to support
|
||||
complex functional testing for applications and libraries.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{name}-%{version}
|
||||
@ -138,7 +136,7 @@ echo "set enable-bracketed-paste off" > .inputrc
|
||||
export INPUTRC=$PWD/.inputrc
|
||||
|
||||
%global __pytest %{buildroot}%{_bindir}/pytest
|
||||
%pytest testing %{?with_timeout:--timeout=30}
|
||||
%pytest testing %{?with_timeout:--timeout=30} -rs
|
||||
%endif
|
||||
|
||||
%files -n python3-%{name}
|
||||
@ -160,6 +158,14 @@ export INPUTRC=$PWD/.inputrc
|
||||
%{python3_sitelib}/pytest/
|
||||
|
||||
%changelog
|
||||
* Wed Jan 27 2021 Miro Hrončok <mhroncok@redhat.com> - 6.2.2-1
|
||||
- Update to 6.2.2
|
||||
- Update the description
|
||||
- Fixes: rhbz#1882935
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jan 20 2021 Miro Hrončok <mhroncok@redhat.com> - 6.0.2-2
|
||||
- Workaround the bracketed-paste mode breaking tests with Bash 5.1+
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pytest-6.0.2.tar.gz) = 478d28c30f4f990dcdd98edcd074051e32d9ab25941c21bdc9c4cc47b726da79b5b3a01572ff97f608598ef6bb9df075ebba49abb2f1420947e0c6d4fe0be9c8
|
||||
SHA512 (pytest-6.2.2.tar.gz) = a81def83759c550c169b3db8ed43b4df40433a88acb663e2e9422ef562149ed52041724b7f3cc5d0d6b532f2243a8d9a9614ffbcd87ed571f7fdde7f036c2297
|
||||
|
Loading…
Reference in New Issue
Block a user