2.0.1
This commit is contained in:
parent
462889d4e1
commit
03ffa9ddae
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
pyparsing-1.5.0.tar.gz
|
pyparsing-1.5.0.tar.gz
|
||||||
/pyparsing-1.5.5.tar.gz
|
/pyparsing-1.5.5.tar.gz
|
||||||
/pyparsing-1.5.6.tar.gz
|
/pyparsing-1.5.6.tar.gz
|
||||||
|
/pyparsing-2.0.1.tar.gz
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- pyparsing_py3.py.orig 2013-04-03 01:28:01.927400414 +0200
|
|
||||||
+++ pyparsing_py3.py 2013-04-03 01:28:23.903443448 +0200
|
|
||||||
@@ -891,7 +891,7 @@
|
|
||||||
ParserElement._exprArgCache[ lookup ] = (value[0],value[1].copy())
|
|
||||||
return value
|
|
||||||
except ParseBaseException as pe:
|
|
||||||
- exc.__traceback__ = None
|
|
||||||
+ pe.__traceback__ = None
|
|
||||||
ParserElement._exprArgCache[ lookup ] = pe
|
|
||||||
raise
|
|
||||||
|
|
@ -1,25 +1,17 @@
|
|||||||
%if 0%{?fedora} > 12
|
|
||||||
%global with_python3 1
|
%global with_python3 1
|
||||||
%else
|
|
||||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print (get_python_lib())")}
|
|
||||||
%endif
|
|
||||||
|
|
||||||
Name: pyparsing
|
Name: pyparsing
|
||||||
Version: 1.5.6
|
Version: 2.0.1
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An object-oriented approach to text processing
|
Summary: An object-oriented approach to text processing
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://pyparsing.wikispaces.com/
|
URL: http://pyparsing.wikispaces.com/
|
||||||
Source0: http://downloads.sourceforge.net/pyparsing/pyparsing-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/pyparsing/pyparsing-%{version}.tar.gz
|
||||||
Patch0: pyparsing-1.5.6-traceback-typo.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
BuildRequires: dos2unix
|
BuildRequires: dos2unix
|
||||||
BuildRequires: glibc-common
|
BuildRequires: glibc-common
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
%endif # if with_python3
|
%endif # if with_python3
|
||||||
@ -49,14 +41,10 @@ This is the Python 3 version.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
dos2unix -k pyparsing_py3.py
|
|
||||||
%patch0
|
|
||||||
mv docs/pyparsingClassDiagram.PNG docs/pyparsingClassDiagram.png
|
mv docs/pyparsingClassDiagram.PNG docs/pyparsingClassDiagram.png
|
||||||
rm docs/pyparsingClassDiagram.JPG
|
rm docs/pyparsingClassDiagram.JPG
|
||||||
dos2unix -k CHANGES LICENSE
|
dos2unix -k CHANGES LICENSE README
|
||||||
dos2unix -k docs/examples/*
|
for f in CHANGES ; do
|
||||||
dos2unix -k docs/htmldoc/epydoc*
|
|
||||||
for f in CHANGES docs/examples/{holaMundo.py,mozillaCalendarParser.py} ; do
|
|
||||||
mv $f $f.iso88591
|
mv $f $f.iso88591
|
||||||
iconv -f ISO-8859-1 -t UTF-8 -o $f $f.iso88591
|
iconv -f ISO-8859-1 -t UTF-8 -o $f $f.iso88591
|
||||||
touch -r $f.iso88591 $f
|
touch -r $f.iso88591 $f
|
||||||
@ -69,7 +57,7 @@ cp -a . %{py3dir}
|
|||||||
%endif # with_python3
|
%endif # with_python3
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{__python} setup.py build
|
%{__python2} setup.py build
|
||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
pushd %{py3dir}
|
pushd %{py3dir}
|
||||||
@ -87,13 +75,12 @@ pushd %{py3dir}
|
|||||||
popd
|
popd
|
||||||
%endif # with_python3
|
%endif # with_python3
|
||||||
|
|
||||||
%{__python} setup.py install -O1 --skip-build --root %{buildroot}
|
%{__python2} setup.py install -O1 --skip-build --root %{buildroot}
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf %{buildroot}
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc CHANGES README LICENSE
|
%doc CHANGES README LICENSE
|
||||||
%if 0%{?fedora} >= 9 || 0%{?rhel} >= 6
|
%if 0%{?fedora} >= 9 || 0%{?rhel} >= 6
|
||||||
%{python_sitelib}/pyparsing*egg-info
|
%{python_sitelib}/pyparsing*egg-info
|
||||||
@ -102,7 +89,6 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%if 0%{?with_python3}
|
%if 0%{?with_python3}
|
||||||
%files -n python3-pyparsing
|
%files -n python3-pyparsing
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc CHANGES README LICENSE
|
%doc CHANGES README LICENSE
|
||||||
%{python3_sitelib}/pyparsing*egg-info
|
%{python3_sitelib}/pyparsing*egg-info
|
||||||
%{python3_sitelib}/pyparsing.py*
|
%{python3_sitelib}/pyparsing.py*
|
||||||
@ -112,10 +98,12 @@ rm -rf %{buildroot}
|
|||||||
%endif # pycache
|
%endif # pycache
|
||||||
|
|
||||||
%files doc
|
%files doc
|
||||||
%defattr(-,root,root,-)
|
|
||||||
%doc CHANGES README LICENSE docs/*
|
%doc CHANGES README LICENSE docs/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 27 2013 Terje Rosten <terje.rosten@ntnu.no> - 2.0.1-1
|
||||||
|
- 2.0.1
|
||||||
|
|
||||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.6-9
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.6-9
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user