Fix the build with pango 1.44
https://bugzilla.redhat.com/show_bug.cgi?id=1763401
This commit is contained in:
parent
93b36f49fd
commit
b375c14e96
39
pygtk-Drop-the-PangoFont-find_shaper-virtual-method.patch
Normal file
39
pygtk-Drop-the-PangoFont-find_shaper-virtual-method.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 877164b6b70780468a31d8211f29421b6f34b0c8 Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Bridon <bochecha@daitauha.fr>
|
||||
Date: Thu, 24 Oct 2019 22:58:36 +0200
|
||||
Subject: [PATCH] Drop the PangoFont find_shaper virtual method
|
||||
|
||||
This API has been removed from Pango 1.44.6, because it was completely
|
||||
unused by anything.
|
||||
|
||||
However, PyGTK tries to bind everything, even unused API.
|
||||
|
||||
Removing this from PyGTK means we can build it against the latest Pango
|
||||
again.
|
||||
---
|
||||
pango.defs | 9 ---------
|
||||
1 file changed, 9 deletions(-)
|
||||
|
||||
diff --git a/pango.defs b/pango.defs
|
||||
index 2a79ecc..862667a 100644
|
||||
--- a/pango.defs
|
||||
+++ b/pango.defs
|
||||
@@ -1391,15 +1391,6 @@
|
||||
)
|
||||
)
|
||||
|
||||
-(define-virtual find_shaper
|
||||
- (of-object "PangoFont")
|
||||
- (return-type "PangoEngineShape*")
|
||||
- (parameters
|
||||
- '("PangoLanguage*" "lang")
|
||||
- '("guint32" "ch")
|
||||
- )
|
||||
-)
|
||||
-
|
||||
(define-virtual get_glyph_extents
|
||||
(of-object "PangoFont")
|
||||
(return-type "none")
|
||||
--
|
||||
2.21.0
|
||||
|
12
pygtk2.spec
12
pygtk2.spec
@ -15,7 +15,7 @@
|
||||
|
||||
Name: pygtk2
|
||||
Version: 2.24.0
|
||||
Release: 26%{?dist}
|
||||
Release: 27%{?dist}
|
||||
License: LGPLv2+
|
||||
Summary: Python bindings for GTK+
|
||||
URL: http://www.pygtk.org/
|
||||
@ -25,7 +25,9 @@ Source: http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/pygtk-%{version}.tar.b
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=660216
|
||||
# https://git.gnome.org/browse/pygtk/commit/?id=eca72baa56
|
||||
Patch0: 0001-Fix-leaks-of-Pango-objects.patch
|
||||
|
||||
# Fix the build with pango 1.44
|
||||
# https://github.com/flathub/org.glimpse_editor.Glimpse/blob/master/patches/pygtk-Drop-the-PangoFont-find_shaper-virtual-method.patch
|
||||
Patch1: pygtk-Drop-the-PangoFont-find_shaper-virtual-method.patch
|
||||
|
||||
# This was dropped from gnome-python; obsolete it here because, well,
|
||||
# we have to put it somewhere
|
||||
@ -94,8 +96,7 @@ BuildArch: noarch
|
||||
This package contains documentation files for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n pygtk-%{version}
|
||||
%patch0 -p1 -b .Fix-leaks-of-Pango-objects
|
||||
%autosetup -p1 -n pygtk-%{version}
|
||||
|
||||
# Fix shebangs to system Python2.x
|
||||
for file in $(%{_bindir}/find . -name '*.py' -type f)
|
||||
@ -144,6 +145,9 @@ find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
|
||||
%{_datadir}/gtk-doc/html/pygtk/
|
||||
|
||||
%changelog
|
||||
* Wed Nov 27 2019 Kalev Lember <klember@redhat.com> - 2.24.0-27
|
||||
- Fix the build with pango 1.44 (#1763401)
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.24.0-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user