use license tag for COPYING
This commit is contained in:
parent
48c975dec1
commit
79e8a64359
@ -1,29 +0,0 @@
|
||||
--- pygtk-2.10.4/gtk/__init__.py.orig 2007-01-16 07:50:07.000000000 -0500
|
||||
+++ pygtk-2.10.4/gtk/__init__.py 2007-02-05 17:09:37.000000000 -0500
|
||||
@@ -59,19 +59,14 @@
|
||||
def _init():
|
||||
import sys
|
||||
|
||||
- try:
|
||||
- sys_path = sys.path[:]
|
||||
+ sys_path = sys.path[:]
|
||||
|
||||
- try:
|
||||
- _gtk.init_check()
|
||||
- except RuntimeError, e:
|
||||
- import warnings
|
||||
- warnings.warn(str(e), _gtk.Warning)
|
||||
- finally:
|
||||
- # init_check calls PySys_SetArgv which calls sys.path.insert(0, ''),
|
||||
- # which causes problems for pychecker, restore it if modified.
|
||||
- if sys.path != sys_path:
|
||||
- sys.path[:] = sys_path
|
||||
+ _gtk.init_check()
|
||||
+
|
||||
+ # init_check calls PySys_SetArgv which calls sys.path.insert(0, ''),
|
||||
+ # which causes problems for pychecker, restore it if modified.
|
||||
+ if sys.path != sys_path:
|
||||
+ sys.path[:] = sys_path
|
||||
|
||||
# install the default log handlers
|
||||
_gtk.add_log_handlers()
|
17
pygtk2.spec
17
pygtk2.spec
@ -1,5 +1,3 @@
|
||||
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
|
||||
|
||||
# Last updated for version 2.17.0
|
||||
%define glib2_version 2.8.0
|
||||
%define pango_version 1.16.0
|
||||
@ -15,7 +13,7 @@
|
||||
|
||||
Name: pygtk2
|
||||
Version: 2.24.0
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Development/Languages
|
||||
Summary: Python bindings for GTK+
|
||||
@ -101,17 +99,15 @@ This package contains documentation files for %{name}.
|
||||
|
||||
%build
|
||||
%configure --enable-thread --enable-numpy
|
||||
export tagname=CC
|
||||
make LIBTOOL=/usr/bin/libtool
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
export tagname=CC
|
||||
make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
|
||||
%{make_install}
|
||||
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
|
||||
|
||||
%files
|
||||
%doc AUTHORS NEWS README MAPPING COPYING
|
||||
%doc AUTHORS NEWS README MAPPING
|
||||
%license COPYING
|
||||
%dir %{python_sitearch}/gtk-2.0
|
||||
%dir %{python_sitearch}/gtk-2.0/gtk
|
||||
%{python_sitearch}/gtk-2.0/gtk/*.py*
|
||||
@ -149,6 +145,9 @@ find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
|
||||
%{_datadir}/gtk-doc/html/pygtk
|
||||
|
||||
%changelog
|
||||
* Thu Jun 18 2015 Leigh Scott <leigh123linux@googlemail.com> - 2.24.0-12
|
||||
- use license tag for COPYING
|
||||
|
||||
* Sat Dec 06 2014 Leigh Scott <leigh123linux@googlemail.com> - 2.24.0-11
|
||||
- update spec file
|
||||
- drop patch (system-config-authentication is a gui app that requires X and I don't give a damn if it segfaults because someone runs it without X)
|
||||
|
Loading…
Reference in New Issue
Block a user