Update to 2.22.0
Bump requirements per configure and remove upstreamed patches
This commit is contained in:
parent
b167440948
commit
736d0c5461
@ -1,30 +0,0 @@
|
|||||||
From f19a28420f9132e0e0cac6a2747a63c473052489 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Tue, 20 Jul 2010 10:06:05 -0400
|
|
||||||
Subject: [PATCH] Remove deprecated sink functions
|
|
||||||
|
|
||||||
This is handled automatically now; see commit 00a85f6a844714d1 in pygobject.
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=624834
|
|
||||||
---
|
|
||||||
gtk/gtkmodule.c | 4 ----
|
|
||||||
1 files changed, 0 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/gtk/gtkmodule.c b/gtk/gtkmodule.c
|
|
||||||
index ff6420c..1672bf9 100644
|
|
||||||
--- a/gtk/gtkmodule.c
|
|
||||||
+++ b/gtk/gtkmodule.c
|
|
||||||
@@ -204,10 +204,6 @@ init_gtk(void)
|
|
||||||
/* initialise pygtk */
|
|
||||||
gtk_type_init(0);
|
|
||||||
|
|
||||||
- pygobject_register_sinkfunc(GTK_TYPE_WINDOW, sink_gtkwindow);
|
|
||||||
- pygobject_register_sinkfunc(GTK_TYPE_INVISIBLE, sink_gtkinvisible);
|
|
||||||
- pygobject_register_sinkfunc(GTK_TYPE_OBJECT, sink_gtkobject);
|
|
||||||
-
|
|
||||||
m = Py_InitModule("gtk._gtk", pygtk_functions);
|
|
||||||
d = PyModule_GetDict(m);
|
|
||||||
|
|
||||||
--
|
|
||||||
1.7.1.1
|
|
||||||
|
|
@ -1,25 +0,0 @@
|
|||||||
From a9e24426aae96e5968b95ef76aacf41d3153ddf7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Fri, 30 Jul 2010 10:23:56 -0400
|
|
||||||
Subject: [PATCH] [pygtk-2.0.pc] Should require gtk+-2.0
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=618944
|
|
||||||
---
|
|
||||||
pygtk-2.0.pc.in | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/pygtk-2.0.pc.in b/pygtk-2.0.pc.in
|
|
||||||
index 0506e75..e277e80 100644
|
|
||||||
--- a/pygtk-2.0.pc.in
|
|
||||||
+++ b/pygtk-2.0.pc.in
|
|
||||||
@@ -20,6 +20,6 @@ codegendir=${datadir}/pygobject/2.0/codegen
|
|
||||||
|
|
||||||
Name: PyGTK
|
|
||||||
Description: Python bindings for GTK+ and related libraries
|
|
||||||
-Requires: pygobject-2.0
|
|
||||||
+Requires: pygobject-2.0 gtk+-2.0
|
|
||||||
Version: @VERSION@
|
|
||||||
Cflags: -I${pygtkincludedir} @THREADING_CFLAGS@
|
|
||||||
--
|
|
||||||
1.7.2
|
|
||||||
|
|
18
pygtk2.spec
18
pygtk2.spec
@ -6,7 +6,7 @@
|
|||||||
%define gtk2_version 2.9.0
|
%define gtk2_version 2.9.0
|
||||||
%define libglade2_version 2.5.0
|
%define libglade2_version 2.5.0
|
||||||
%define pycairo_version 1.0.2
|
%define pycairo_version 1.0.2
|
||||||
%define pygobject2_version 2.16.1
|
%define pygobject2_version 2.21.3
|
||||||
%define python2_version 2.3.5
|
%define python2_version 2.3.5
|
||||||
|
|
||||||
%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
|
%define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
|
||||||
@ -14,26 +14,21 @@
|
|||||||
### Abstract ###
|
### Abstract ###
|
||||||
|
|
||||||
Name: pygtk2
|
Name: pygtk2
|
||||||
Version: 2.17.0
|
Version: 2.22.0
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Summary: Python bindings for GTK+
|
Summary: Python bindings for GTK+
|
||||||
URL: http://www.pygtk.org/
|
URL: http://www.pygtk.org/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
Source: http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.17/pygtk-%{version}.tar.bz2
|
Source: http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.22/pygtk-%{version}.tar.bz2
|
||||||
|
|
||||||
### Patches ###
|
### Patches ###
|
||||||
|
|
||||||
# RH bug #208608
|
# RH bug #208608
|
||||||
Patch0: pygtk-nodisplay-exception.patch
|
Patch0: pygtk-nodisplay-exception.patch
|
||||||
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=624834
|
|
||||||
Patch1: 0001-Remove-deprecated-sink-functions.patch
|
|
||||||
|
|
||||||
# http://git.gnome.org/browse/pygtk/commit/?id=a9e24426aae96e5968b95ef76aacf41d3153ddf7
|
|
||||||
# RH bug: https://bugzilla.redhat.com/show_bug.cgi?id=618944
|
|
||||||
Patch2: 0001-pygtk-2.0.pc-Should-require-gtk-2.0.patch
|
|
||||||
### Dependencies ###
|
### Dependencies ###
|
||||||
|
|
||||||
# Leave these requirements alone! RPM isn't smart enough
|
# Leave these requirements alone! RPM isn't smart enough
|
||||||
@ -104,8 +99,6 @@ This package contains documentation files for %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n pygtk-%{version}
|
%setup -q -n pygtk-%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --enable-thread --enable-numpy
|
%configure --enable-thread --enable-numpy
|
||||||
@ -167,6 +160,9 @@ rm -fr $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/gtk-doc/html/pygtk
|
%{_datadir}/gtk-doc/html/pygtk
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 21 2011 Christopher Aillon <caillon@redhat.com> - 2.22.0-1
|
||||||
|
- Update to 2.22.0
|
||||||
|
|
||||||
* Fri Jul 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.17.0-7
|
* Fri Jul 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.17.0-7
|
||||||
- Add upstream patch to fix pkgconfig dependencies
|
- Add upstream patch to fix pkgconfig dependencies
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user