143 lines
5.0 KiB
Diff
143 lines
5.0 KiB
Diff
diff --git a/elftools/common/construct_utils.py b/elftools/common/construct_utils.py
|
|
index 53caa97..41c2815 100644
|
|
--- a/elftools/common/construct_utils.py
|
|
+++ b/elftools/common/construct_utils.py
|
|
@@ -6,7 +6,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import Subconstruct, ConstructError, ArrayError
|
|
+from construct import Subconstruct, ConstructError, ArrayError
|
|
|
|
|
|
class RepeatUntilExcluding(Subconstruct):
|
|
diff --git a/elftools/common/utils.py b/elftools/common/utils.py
|
|
index 7bd1d5b..8b2400b 100644
|
|
--- a/elftools/common/utils.py
|
|
+++ b/elftools/common/utils.py
|
|
@@ -9,7 +9,7 @@
|
|
from contextlib import contextmanager
|
|
from .exceptions import ELFParseError, ELFError, DWARFError
|
|
from .py3compat import int2byte
|
|
-from ..construct import ConstructError
|
|
+from construct import ConstructError
|
|
|
|
|
|
def bytelist2string(bytelist):
|
|
diff --git a/elftools/dwarf/enums.py b/elftools/dwarf/enums.py
|
|
index 6508764..a474d32 100644
|
|
--- a/elftools/dwarf/enums.py
|
|
+++ b/elftools/dwarf/enums.py
|
|
@@ -6,7 +6,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import Pass
|
|
+from construct import Pass
|
|
|
|
|
|
ENUM_DW_TAG = dict(
|
|
diff --git a/elftools/dwarf/structs.py b/elftools/dwarf/structs.py
|
|
index 39e4815..c50a874 100644
|
|
--- a/elftools/dwarf/structs.py
|
|
+++ b/elftools/dwarf/structs.py
|
|
@@ -7,7 +7,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import (
|
|
+from construct import (
|
|
UBInt8, UBInt16, UBInt32, UBInt64, ULInt8, ULInt16, ULInt32, ULInt64,
|
|
SBInt8, SBInt16, SBInt32, SBInt64, SLInt8, SLInt16, SLInt32, SLInt64,
|
|
Adapter, Struct, ConstructError, If, RepeatUntil, Field, Rename, Enum,
|
|
diff --git a/elftools/elf/elffile.py b/elftools/elf/elffile.py
|
|
index 458273f..a4d62bd 100644
|
|
--- a/elftools/elf/elffile.py
|
|
+++ b/elftools/elf/elffile.py
|
|
@@ -9,7 +9,7 @@
|
|
from ..common.py3compat import BytesIO
|
|
from ..common.exceptions import ELFError
|
|
from ..common.utils import struct_parse, elf_assert
|
|
-from ..construct import ConstructError
|
|
+from construct import ConstructError
|
|
from .structs import ELFStructs
|
|
from .sections import (
|
|
Section, StringTableSection, SymbolTableSection,
|
|
diff --git a/elftools/elf/enums.py b/elftools/elf/enums.py
|
|
index deb9f35..7b778c7 100644
|
|
--- a/elftools/elf/enums.py
|
|
+++ b/elftools/elf/enums.py
|
|
@@ -6,7 +6,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import Pass
|
|
+from construct import Pass
|
|
|
|
|
|
# e_ident[EI_CLASS] in the ELF header
|
|
diff --git a/elftools/elf/gnuversions.py b/elftools/elf/gnuversions.py
|
|
index 4a4473f..d4f4b75 100644
|
|
--- a/elftools/elf/gnuversions.py
|
|
+++ b/elftools/elf/gnuversions.py
|
|
@@ -6,7 +6,7 @@
|
|
# Yann Rouillard (yann@pleiades.fr.eu.org)
|
|
# This code is in the public domain
|
|
#------------------------------------------------------------------------------
|
|
-from ..construct import CString
|
|
+from construct import CString
|
|
from ..common.utils import struct_parse, elf_assert
|
|
from .sections import Section, Symbol
|
|
|
|
diff --git a/elftools/elf/sections.py b/elftools/elf/sections.py
|
|
index ce62450..99b6613 100644
|
|
--- a/elftools/elf/sections.py
|
|
+++ b/elftools/elf/sections.py
|
|
@@ -6,7 +6,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import CString
|
|
+from construct import CString
|
|
from ..common.utils import struct_parse, elf_assert, parse_cstring_from_stream
|
|
|
|
|
|
diff --git a/elftools/elf/segments.py b/elftools/elf/segments.py
|
|
index bc54da2..dfb3a14 100644
|
|
--- a/elftools/elf/segments.py
|
|
+++ b/elftools/elf/segments.py
|
|
@@ -6,7 +6,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import CString
|
|
+from construct import CString
|
|
from ..common.utils import struct_parse
|
|
from .constants import SH_FLAGS
|
|
|
|
diff --git a/elftools/elf/structs.py b/elftools/elf/structs.py
|
|
index 0862400..51b1715 100644
|
|
--- a/elftools/elf/structs.py
|
|
+++ b/elftools/elf/structs.py
|
|
@@ -7,7 +7,7 @@
|
|
# Eli Bendersky (eliben@gmail.com)
|
|
# This code is in the public domain
|
|
#-------------------------------------------------------------------------------
|
|
-from ..construct import (
|
|
+from construct import (
|
|
UBInt8, UBInt16, UBInt32, UBInt64,
|
|
ULInt8, ULInt16, ULInt32, ULInt64,
|
|
SBInt32, SLInt32, SBInt64, SLInt64,
|
|
diff --git a/setup.py b/setup.py
|
|
index a105774..d8cd590 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -41,7 +41,6 @@ setup(
|
|
'elftools.elf',
|
|
'elftools.common',
|
|
'elftools.dwarf',
|
|
- 'elftools.construct', 'elftools.construct.lib',
|
|
],
|
|
|
|
scripts=['scripts/readelf.py']
|